Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
DISCONTINUED:openSUSE:11.2:Update
rhino
rhino.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File rhino.spec of Package rhino
# # spec file for package rhino (Version 1.7) # # Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # # norootforbuild %define section free %define cvs_version 1_7R2 %define archive_version 1_7R2pre Name: rhino Version: 1.7 Release: 6 Summary: JavaScript for Java License: MOZILLA PUBLIC LICENSE (MPL/NPL) Source0: ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino%{archive_version}.tar.bz2 Source2: rhino.script Source3: rhino-debugger.script Source4: rhino-idswitch.script Source5: rhino-jsc.script Source6: rhino-js.pom Source7: rhino.pom # export CVSROOT=:pserver:anonymous@cvs-mirror.mozilla.org:/www # vs -z3 co mozilla-org/html/rhino # cd mozilla-org/html/ # rm -r rhino/apidocs # the javadoc is in different directory # tar -cjf rhino-docs.tar.bz2 rhino Source100: rhino-docs.tar.bz2 Patch0: rhino-1.7-gcj.patch Url: http://www.mozilla.org/rhino/ Group: Development/Libraries/Java Requires: bea-stax-api Requires: xmlbeans BuildRequires: ant BuildRequires: jpackage-utils BuildRequires: bea-stax-api BuildRequires: xmlbeans-mini BuildRequires: unzip BuildRequires: xerces-j2-bootstrap #!BuildIgnore: xerces-j2 xml-commons xml-commons-apis xml-commons-resolver BuildArch: noarch #BuildRequires: java-devel BuildRequires: java-1_5_0-gcj-compat-devel BuildRoot: %{_tmppath}/%{name}-%{version}-build %description Rhino is an open-source implementation of JavaScript written entirely in Java. It is typically embedded into Java applications to provide scripting to end users. %package demo License: MOZILLA PUBLIC LICENSE (MPL/NPL) Summary: JavaScript for Java Group: Development/Libraries/Java %description demo Rhino is an open-source implementation of JavaScript written entirely in Java. It is typically embedded into Java applications to provide scripting to end users. %package manual License: MOZILLA PUBLIC LICENSE (MPL/NPL) Summary: JavaScript for Java Group: Development/Libraries/Java %description manual Rhino is an open-source implementation of JavaScript written entirely in Java. It is typically embedded into Java applications to provide scripting to end users. %package javadoc License: MOZILLA PUBLIC LICENSE (MPL/NPL) Summary: JavaScript for Java Group: Development/Libraries/Java %description javadoc Rhino is an open-source implementation of JavaScript written entirely in Java. It is typically embedded into Java applications to provide scripting to end users. %prep %setup -q -n %{name}%{archive_version} -a 100 # Fix build %{__perl} -pi -e 's|.*<get.*src=.*>\n||' build.xml testsrc/build.xml toolsrc/org/mozilla/javascript/tools/debugger/build.xml xmlimplsrc/build.xml # Fix manifest %{__perl} -pi -e 's|^Class-Path:.*\n||g' src/manifest # Add jpp release info to version %{__perl} -pi -e 's|^implementation.version: Rhino .* release .* \${implementation.date}|implementation.version: Rhino %{version} release %{release} \${implementation.date}|' build.properties (cd rhino; sed -i 's#\<apidocs/\>#/%{_javadocdir}/%{name}-%{version}#' *.html) %patch0 -b .sav0 # FIXME: these classes cannot be build with gcj (cd examples; rm {CounterTest,RunScript4}.java) %build export CLASSPATH= export OPT_JAR_LIST=: ant \ -Dxbean.jar=$(build-classpath xmlbeans/xbean) \ -Djsr173.jar=$(build-classpath bea-stax-api) \ -Dant.build.javac.source=1.5 -Dant.build.javac.target=1.5 \ deepclean jar copy-all javadoc %if 0 pushd examples export CLASSPATH=../build/%{name}%{archive_version}/js.jar:$(build-classpath xmlbeans/xbean 2>/dev/null) javac -C *.java jar cvf ../build/%{name}%{archive_version}/%{name}-examples-%{version}.jar *.class popd %endif %install # jars %{__mkdir_p} %{buildroot}%{_javadir} %{__cp} -a build/%{name}%{archive_version}/js.jar %{buildroot}%{_javadir}/%{name}-%{version}.jar %if 0 %{__cp} -a build/%{name}%{archive_version}/%{name}-examples-%{version}.jar %{buildroot}%{_javadir}/%{name}-examples-%{version}.jar %endif (cd %{buildroot}%{_javadir} && %{__ln_s} %{name}-%{version}.jar js-%{version}.jar) (cd %{buildroot}%{_javadir} && for jar in *-%{version}*; do %{__ln_s} ${jar} `echo $jar| %{__sed} "s|-%{version}||g"`; done) # poms %{__mkdir_p} %{buildroot}%{_datadir}/maven2/poms %{__cp} -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP-js.pom %{__cp} -a %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP-%{name}.pom %add_to_maven_depmap %{name} %{name} %{version} JPP %{name} %add_to_maven_depmap %{name} js %{version} JPP js # javadoc %{__mkdir_p} %{buildroot}%{_javadocdir}/%{name}-%{version} %{__cp} -a javadoc/* %{buildroot}%{_javadocdir}/%{name}-%{version} %{__ln_s} %{name}-%{version} %{buildroot}%{_javadocdir}/%{name} %{_bindir}/find %{buildroot}%{_javadocdir}/%{name}-%{version} -type f -name '*.html' | %{_bindir}/xargs %{__perl} -pi -e 's/\r$//g' # scripts %{__mkdir_p} %{buildroot}%{_bindir} %{__install} -p -m 0755 %{SOURCE2} %{buildroot}%{_bindir}/%{name} %{__install} -p -m 0755 %{SOURCE3} %{buildroot}%{_bindir}/%{name}-debugger %{__install} -p -m 0755 %{SOURCE4} %{buildroot}%{_bindir}/%{name}-idswitch %{__install} -p -m 0755 %{SOURCE5} %{buildroot}%{_bindir}/%{name}-jsc # examples %{__mkdir_p} %{buildroot}%{_datadir}/%{name} %{__cp} -a examples/* %{buildroot}%{_datadir}/%{name} %clean %{__rm} -rf %{buildroot} %files %defattr(0644,root,root,0755) %doc LICENSE.txt %attr(0755,root,root) %{_bindir}/%{name} %attr(0755,root,root) %{_bindir}/%{name}-debugger %attr(0755,root,root) %{_bindir}/%{name}-idswitch %attr(0755,root,root) %{_bindir}/%{name}-jsc %{_javadir}/*.jar %{_datadir}/maven2 %{_mavendepmapfragdir} %files demo %defattr(0644,root,root,0755) %{_datadir}/%{name} %files manual %defattr(0644,root,root,0755) %doc %{name}/* %files javadoc %defattr(0644,root,root,0755) %{_javadocdir}/%{name}-%{version} %{_javadocdir}/%{name} %changelog * Thu Nov 13 2008 mvyskocil@suse.cz - fixed bnc#444259 - rhino contains conflicting class in rhino-examples.jar - don't build and install a rhino-examples.jar * Thu Oct 16 2008 mvyskocil@suse.cz - Use xerces-j2-bootstrap to prevent another build cycle - Added a xerces-j2 and non-bootstrap xml-commons* packages to BuildIgnore * Wed Oct 01 2008 adrian@suse.de - Use xmlbeans-mini, instead of xmlbeans in BuildRequires to get rid of all the new build cycles * Mon Sep 08 2008 mvyskocil@suse.cz - Removed a src.zip - contains a non-free source codes. * Fri Sep 05 2008 mvyskocil@suse.cz - Fixed a build with gcj (to prevent of a build cycles with build of openjdk6) * Fri Sep 05 2008 mvyskocil@suse.cz - Update to 1.7 (from jpackage 1.7, due some license issues in source tarball ) - Add a doc from Mozilla's CVS - Removed a patches: - rhino-dojo patch contains part with permissive licnse - rhino-build patch is not necessary for java 5+ * Tue Sep 02 2008 mvyskocil@suse.cz - Initial packaging of rhino 1.6 (based on Jpackage 1.7)
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor