Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:Ledest:erlang:22
hackney
hackney.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File hackney.spec of Package hackney
%define bname hackney Name: %bname Version: 1.20.1 Release: 2 Summary: HTTP client library in Erlang License: Apache-2.0 Group: Development/Tools/Other URL: https://github.com/benoitc/%bname Source: %bname-%version.tar.xz Patch0: %bname-%version-git.patch BuildArch: noarch Provides: erlang-%bname = %version-%release Requires: erlang-certifi >= 2.7.0-1 Requires: erlang-idna >= 6.1.0-1 Requires: mimerl >= 1.1 Requires: erlang-metrics >= 1.0.0 Requires: erlang-ssl_verify_fun >= 1.1.0 BuildRequires: rpm-macros-erlang rpm-build-erlang BuildRequires: rebar >= 2.6.1-7 BuildRequires: erlang-public_key-devel # check BuildRequires: erlang-idna >= 6.1.0-1 BuildRequires: mimerl >= 1.1 BuildRequires: erlang-metrics >= 1.0.0 BuildRequires: erlang-cowboy1-devel erlang-cowboy1 BuildRequires: erlang-certifi >= 2.10.0-1 BuildRequires: erlang-ssl_verify_fun >= 1.1.0 %description hackney - HTTP client library in Erlang. Main features: - no message passing (except for asynchronous responses): response is directly streamed to the current process and state is kept in a #client{} record - binary streams - SSL support - keepalive handling - basic authentication - stream the response and the requests - fetch a response asynchronously - multipart support (streamed or not) - chunked encoding support - can send files using the sendfile API - optional socket pool - REST syntax: hackney:Method(URL) (where a method can be get, post, put, delete, ...). %package devel Summary: Headers of %bname Group: Development/Tools/Other Provides: erlang-%bname-devel = %version-%release Conflicts: %name < 1.7.1-2 %description devel hackney - HTTP client library in Erlang. This package contains headers of %bname. %package doc Summary: Documentation of %bname Group: Documentation/HTML Provides: erlang-%bname-doc = %version-%release Conflicts: %name < 1.7.1-2 %description doc hackney - HTTP client library in Erlang. This package contains documentation of %bname. %prep %setup -q -n %bname-%version %patch -p1 -P0 erl -noshell -eval ' {ok, [{application, %bname, L}]} = file:consult("src/%bname.app.src"), {_, A} = lists:keyfind(applications, 1, L), file:write_file("src/%bname.app.src", io_lib:format("{application, %bname, ~90p}.~n", [lists:keyreplace(applications, 1, lists:foldl(fun(K, Ac) -> lists:keydelete(K, 1, Ac) end, L, [files, included_applications]), {applications, lists:delete(unicode_util_compat, A)})]), [raw]), init:stop().' sed -i 's/string_compat:/string:/' src/%{bname}_ssl.erl src/%{bname}_connection.erl sed -i '1s|^.*$|#!%__escript|' examples/*.erl examples/*.escript examples/*.ebin rm -f test/hackney_ssl_tests.erl # FIX IT rm -f test/hackney_integration_tests.erl rm -f test/hackney_stream_tests.erl %build erl -noshell -eval ' {ok, L} = file:consult("rebar.config"), file:write_file("%bname.rebar.config", lists:map(fun(E) -> [io_lib:print(E), ".\n"] end, lists:keystore(edoc_opts, 1, lists:keydelete(deps, 1, L), {edoc_opts, case lists:keyfind(edoc_opts, 1, L) of {_, [_|_] = O} -> lists:keystore(new, 1, lists:keydelete(doclet, 1, O), {new, true}); _ -> [{new, true}] end})), [raw]), init:stop().' ERL_COMPILER_OPTIONS="[inline,verbose]" rebar %{?_smp_mflags} -C %bname.rebar.config compile -v rebar %{?_smp_mflags} -C %bname.rebar.config doc -v %install install -d -m 0755 %buildroot%_otplibdir/%bname-%version/ebin install -p -m 0644 ebin/* %buildroot%_otplibdir/%bname-%version/ebin/ install -d -m 0755 %buildroot%_otplibdir/%bname-%version/include install -p -m 0644 include/* %buildroot%_otplibdir/%bname-%version/include/ install -d -m 0755 %buildroot%_otplibdir/%bname-%version/examples install -p -m 0644 examples/*.json %buildroot%_otplibdir/%bname-%version/examples/ install -p -m 0755 examples/*.e{rl,script,bin} %buildroot%_otplibdir/%bname-%version/examples/ install -d -m 0755 %buildroot%_otplibdir/%bname-%version/doc install -p -m 0644 doc/*.{css,html,png} %buildroot%_otplibdir/%bname-%version/doc/ install -d -m 0755 %buildroot%_docdir/%name install -p -m 0644 *.md MAINTAINERS NOTICE THANKS %buildroot%_docdir/%name/ ln -sf %_otplibdir/%bname-%version/doc %buildroot%_docdir/%name/html ln -sf %_otplibdir/%bname-%version/examples %buildroot%_docdir/%name/ %check ERL_COMPILER_OPTIONS="[inline,verbose,{parse_transform,cowboy1_pt}]" rebar -C %bname.rebar.config eunit -v %files %defattr(-,root,root) %doc %_docdir/%name %_otplibdir/* %exclude %_otplibdir/%bname-*/include %exclude %_otplibdir/%bname-*/doc %exclude %_otplibdir/%bname-*/examples %files devel %defattr(-,root,root) %dir %_otplibdir/%bname-* %_otplibdir/%bname-*/include %files doc %defattr(-,root,root) %doc %_docdir/%name %doc %dir %_otplibdir/%bname-* %doc %_otplibdir/%bname-*/doc %doc %_otplibdir/%bname-*/examples %changelog * Tue May 07 2024 Led <ledest@gmail.com> 1.20.1-2 - git 7ae3831 * Sun Dec 03 2023 Led <ledest@gmail.com> 1.20.1-1 - 1.20.1 - remove patches: + 0001-Add-test-for-connect_timeout.patch * Mon Sep 25 2023 Led <ledest@gmail.com> 1.19.1-2 - add patches: + 0001-Add-test-for-connect_timeout.patch * Mon Sep 25 2023 Led <ledest@gmail.com> 1.19.1-1 - 1.19.1 * Mon Sep 25 2023 Led <ledest@gmail.com> 1.18.2-1 - 1.18.2 - git 745e795 * Tue Aug 08 2023 Led <ledest@gmail.com> 1.18.1-3 - git d6d075f * Tue Aug 08 2023 Led <ledest@gmail.com> 1.18.1-2 - update BuildRequires * Thu Mar 31 2022 Led <ledest@gmail.com> 1.18.1-1 - 1.18.1 - update Requires and BuildRequires * Thu Mar 31 2022 Led <ledest@gmail.com> 1.17.4-2 - add strict Requires and BuildRequires * Thu Mar 31 2022 Led <ledest@gmail.com> 1.17.4-1 - 1.17.4 * Thu Mar 31 2022 Led <ledest@gmail.com> 1.16.0-1 - 1.16.0 - git d8a0d97 * Wed Mar 30 2022 Led <ledest@gmail.com> 1.15.2-3 - disable sslv3 * Tue Oct 29 2019 Led <ledest@gmail.com> 1.15.2-2 - git 5b7363c * Sat Sep 28 2019 Led <ledest@gmail.com> 1.15.2-1 - 1.15.2 * Thu Sep 26 2019 Led <ledest@gmail.com> 1.8.6-1 - 1.8.6 - remove patches: + hackney-1.7.1-fix-test.patch * Thu Sep 26 2019 Led <ledest@gmail.com> 1.7.1-4 - improve descriptions * Mon Apr 17 2017 Led <ledest@gmail.com> 1.7.1-3 - git 362f062 - remove patches: + hackney-1.7.1-fixed-undefined-function.patch + hackney-1.7.1-close-connection-if-handshake-failed.patch * Sun Mar 12 2017 Led <ledest@gmail.com> 1.7.1-2 - move docs and examples to doc subpackage - move headers to devel subpackage * Sun Mar 12 2017 Led <ledest@gmail.com> 1.7.1-1 - initial build
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor