Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Evergreen:11.2:Test
clisp
clisp.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File clisp.spec of Package clisp
# # spec file for package clisp (Version 2.44.1) # # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # # norootforbuild Name: clisp # BuildRequires: db43-devel gcc-c++ libstdc++-devel openssl-devel pcre-devel postgresql-devel readline-devel texlive-latex xorg-x11-devel BuildRequires: db-devel openssl-devel pcre-devel postgresql-devel readline-devel xorg-x11-devel # # If set to yes do not forget to add # gcc-c++ # to BuildRequires # %define debug no License: GPL v2 or later Group: Development/Languages/Other PreReq: vim AutoReqProv: on Version: 2.44.1 Release: 63 Summary: A Common Lisp Interpreter Url: http://clisp.cons.org Source0: ftp://ftp.gnu.org/pub/gnu/clisp/latest/clisp-%{version}.tar.bz2 Source1: ftp://ftp.santafe.edu/pub/gnu/ffcall-1.10+2.43.tar.bz2 Source2: ftp://ftp.gnu.org/pub/gnu/libsigsegv/libsigsegv-2.5.tar.bz2 Source3: clisp-rpmlintrc Patch0: clisp-2.44.1.dif Patch1: clisp-2.44.1-map_private.patch Patch2: clisp-2.44.1-map_variable.patch Patch3: clisp-2.31-personality.patch Patch4: clisp-2.44.1-ia64.dif Patch5: clisp-2.36-alloca.patch Patch7: clisp-2.39-ia64-wooh.dif Patch8: clisp-2.39-clx.dif Patch9: clisp-2.39-berkeley-db.dif Patch10: ffcall-1.10+2.43.dif BuildRoot: %{_tmppath}/%{name}-%{version}-build %global vimdir %{_datadir}/vim/site/after/syntax %global xarch ppc64 s390x armv4l ExcludeArch: ppc64 s390x armv4l %description Common Lisp is a high-level, all-purpose programming language. CLISP is an implementation of Common Lisp that closely follows the book "Common Lisp - The Language" by Guy L. Steele Jr. This package includes an interactive programming environment with an interpreter, a compiler, and a debugger. Start this environment with the command 'clisp'. CLISP documentation is placed in the following directories: /usr/share/doc/packages/clisp/ /usr/share/doc/packages/clisp/doc/ As well as the conventional CLISP, this package also includes CLX, an extension of CLISP for the X Window System. The X Window System must be installed before running the clx command. The description of this CLX version (new-clx) is placed in /usr/share/doc/packages/clisp/clx/ with the file README. The subdirectory /usr/share/doc/packages/clisp/clx/demos/ contains two nice applications. Authors: -------- Bruno Haible <haible@ma2s2.mathematik.uni-karlsruhe.de> Michael Stoll <michael@rhein.iam.uni-bonn.de> Marcus Daniels <marcus@sysc.pdx.edu> Gilbert Baumann <gilbert@ma2s2.mathematik.uni-karlsruhe.de> %prep %setup -qT -b0 -a1 -a2 %patch1 -p0 -b .mappriv %patch2 -p0 -b .mapvar %patch3 -p0 -b .sel %patch4 -p0 -b .ia64 %patch5 -p0 -b .alloca %patch7 -p0 -b .wooh %patch8 -p0 -b .clx %patch9 -p0 -b .bdb %patch10 -p0 -b .ffcall %patch0 %build # # Overwrite stack size limit (hopefully a soft limit only) # ulimit -Ss unlimited || true ulimit -Hs unlimited || true unset LC_CTYPE LANG=POSIX LC_ALL=POSIX export LANG LC_ALL # # Current system # SYSTEM=${RPM_ARCH}-suse-linux # # Update autoconf files # AUTODIR=$(find -name autoconf -and -type d 2> /dev/null) %{?suse_update_config $AUTODIR} export PATH="$PATH:." # # Set gcc command line but do not use CFLAGS # if test %debug = yes ; then CC="g++" else CC="gcc" fi CC="${CC} -g ${RPM_OPT_FLAGS} -fno-strict-aliasing -fPIC -pipe" case "$RPM_ARCH" in i[0-9]86) CC="${CC} -falign-functions=4 -mieee-fp -ffloat-store" ;; ppc) CC="${CC}" ;; s390) CC="${CC}" ;; x86_64) CC="${CC} -fno-gcse" ;; sparc*) CC="${CC} -fno-gcse" ;; ppc64) CC="${CC} -fno-gcse -mpowerpc64" ;; s390x) CC="${CC} -fno-gcse" ;; ia64) CC="${CC} -fno-gcse" ;; axp|alpha) CC="${CC}" ;; esac noexec='-DLINUX_NOEXEC_HEAPCODES' nommap='-DNO_MULTIMAP_SHM -DNO_MULTIMAP_FILE -DNO_SINGLEMAP -DNO_TRIVIALMAP' safety='-DSAFETY=3 -O' MYCFLAGS="${MYCFLAGS} -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64" MYCFLAGS="${MYCFLAGS} -D_GNU_SOURCE -Wno-unused -Wno-uninitialized" case "$RPM_ARCH" in i[0-9]86) MYCFLAGS="${MYCFLAGS} ${noexec}" ;; ppc) MYCFLAGS="${MYCFLAGS} ${noexec}" ;; s390) MYCFLAGS="${MYCFLAGS} ${noexec}" ;; x86_64) MYCFLAGS="${MYCFLAGS} ${safety}" ;; sparc*) MYCFLAGS="${MYCFLAGS} ${safety}" ;; ppc64) MYCFLAGS="${MYCFLAGS} ${safety} -DWIDE_HARD" ;; s390x) MYCFLAGS="${MYCFLAGS} ${safety} -DWIDE_HARD" ;; ia64) MYCFLAGS="${MYCFLAGS} ${safety}" ;; axp|alpha) MYCFLAGS="${MYCFLAGS} ${nommap}" ;; esac export CC export MYCFLAGS unset cfi386 noexec nommap safety # # Environment for the case of missing terminal # rm -rf /tmp/clispIO mknod /tmp/clispIO p cat /tmp/clispIO & exec 0< /dev/null exec 1> /tmp/clispIO 2>&1 # # Build the current system # if test %debug = yes ; then DEBUG=--with-debug MYCFLAGS="${MYCFLAGS} -g3 -DDEBUG_GCSAFETY" else DEBUG="" MYCFLAGS="${MYCFLAGS}" fi # # May interfere with configure # unset CFLAGS # # The libsigsegv # SEGV=${PWD}/libsigsegv pushd libsigsegv-*/ ./configure --build ${SYSTEM} ${DEBUG}\ --prefix=%{_prefix} \ --libdir=%{_libdir} make make check make DESTDIR=${SEGV} install popd SEGV=${SEGV}/usr # # The libffcall # %ifnarch %xarch FFCALL=${PWD}/ffcall pushd ffcall-* ./configure --build ${SYSTEM} ${DEBUG}\ --prefix=%{_prefix} \ --libdir=%{_libdir} make -C avcall make -C callback make -C avcall check make -C callback check make DESTDIR=${FFCALL} install popd FFCALL=${FFCALL}/usr %endif # # The modules i18n, syscalls, regexp # are part of the base clisp system. # ./configure --build ${SYSTEM} ${DEBUG} \ --prefix=%{_prefix} \ --exec-prefix=%{_prefix} \ --libdir=%{_libdir} \ --vimdir=%{vimdir} \ --fsstnd=suse \ --with-readline \ --with-libsigsegv-prefix=${SEGV}\ %ifnarch %xarch --with-libffcall-prefix=${FFCALL}\ %else --without-ffcall \ %endif --with-dynamic-modules \ --with-gettext \ --with-module=queens \ --with-module=pcre \ --with-module=rawsock \ --with-module=zlib \ --with-module=wildcard \ --with-module=bindings/glibc \ --with-module=clx/new-clx \ --with-module=berkeley-db \ --with-module=postgresql # # Remove pipe # rm -f /tmp/clispIO # # Check for errors # test -z "$(ls ${SYSTEM}/tests/*.erg 2>/dev/null)" %install # # Current system # SYSTEM=${RPM_ARCH}-suse-linux LSPDOC=%{_docdir}/clisp DOCDOC=${LSPDOC}/doc CLXDOC=${LSPDOC}/clx LSPLIB=%{_libdir}/clisp-%{version} CLXLIB=${LSPLIB}/full # # Install the current system # make install -C ${SYSTEM} \ prefix=%{_prefix} \ exec_prefix=%{_prefix} \ mandir=%{_mandir} \ libdir=%{_libdir} \ DESTDIR=%{buildroot} \ INSTALL_DATA='install -cm 0444' # # The CLX interface # install -d %{buildroot}${CLXDOC} install -d %{buildroot}${CLXLIB} install -d %{buildroot}${LSPLIB}/fullnox pushd ${SYSTEM}/clx/new-clx/ install -c -m 0444 README %{buildroot}${CLXDOC}/ install -c -m 0444 README.SuSE %{buildroot}${CLXDOC}/ tar cf - demos/ | (cd %{buildroot}${CLXDOC}/ ; tar xf - ) popd pushd ${SYSTEM}/clx/ tar xfz clx-manual.tar.gz -C %{buildroot}${CLXDOC} popd chmod -R g+r,o+r %{buildroot}${LSPDOC}/ chmod u+xrw,a+rx %{buildroot}${LSPLIB}/clisp-link chmod a-x %{buildroot}${CLXDOC}/clx-manual/html/doc-index.cgi find %{buildroot}${LSPDOC} -type d | xargs chmod 755 rm -f %{buildroot}${CLXDOC}/*,v rm -f %{buildroot}${CLXDOC}/.\#* rm -f %{buildroot}${CLXDOC}/demos/*,v rm -f %{buildroot}${CLXDOC}/demos/.\#* rm -f %{buildroot}${CLXDOC}/demos/*.orig find %{buildroot}${LSPLIB}/ -name '*.dvi' | xargs -r rm -f find %{buildroot}${LSPLIB}/ -name '*.run' | xargs -r chmod 0755 %find_lang clisp %find_lang clisplow clisp.lang %files -f clisp.lang %defattr(-,root,root,755) %doc %{_docdir}/clisp/ %{_bindir}/clisp %{_libdir}/clisp-%{version}/ %{_datadir}/emacs/site-lisp/clhs.el %{_datadir}/emacs/site-lisp/clisp-coding.el %{_datadir}/emacs/site-lisp/clisp-ffi.el %{_datadir}/emacs/site-lisp/clisp-indent.el %{_datadir}/emacs/site-lisp/clisp-indent.lisp # Do not touch this but wait on check in of new vim!!! %{vimdir}/lisp.vim %doc %{_mandir}/man1/clisp.1.gz %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor