Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Step:15-SP2
netty3.36164
netty3.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File netty3.spec of Package netty3.36164
# # spec file for package netty3 # # Copyright (c) 2024 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # %global namedreltag .Final %global namedversion %{version}%{?namedreltag} Name: netty3 Version: 3.10.6 Release: 0 Summary: An asynchronous event-driven network application framework and tools for Java # CC0: src/main/java/org/jboss/netty/handler/codec/base64/Base64.java License: Apache-2.0 AND BSD-3-Clause AND SUSE-Public-Domain URL: https://netty.io/ Source0: https://github.com/netty/netty/archive/netty-%{namedversion}.tar.gz Patch0: netty-3.10.6-port-to-jzlib-1.1.0.patch Patch1: disableNPN.patch Patch2: x509certificate.patch Patch3: netty3-CVE-2021-43797.patch Patch4: netty3-CVE-2024-29025.patch BuildRequires: fdupes BuildRequires: java-devel >= 1.8 BuildRequires: maven-local BuildRequires: protobuf-devel BuildRequires: mvn(ant-contrib:ant-contrib) BuildRequires: mvn(com.google.protobuf:protobuf-java) BuildRequires: mvn(com.jcraft:jzlib) BuildRequires: mvn(commons-logging:commons-logging) BuildRequires: mvn(javax.servlet:javax.servlet-api) BuildRequires: mvn(log4j:log4j) BuildRequires: mvn(org.apache.ant:ant) BuildRequires: mvn(org.apache.ant:ant-launcher) BuildRequires: mvn(org.apache.felix:maven-bundle-plugin) BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin) BuildRequires: mvn(org.apache.tomcat:tomcat-jni) BuildRequires: mvn(org.bouncycastle:bcpkix-jdk15on) BuildRequires: mvn(org.bouncycastle:bcprov-jdk16) BuildRequires: mvn(org.jboss.logging:jboss-logging) BuildRequires: mvn(org.jboss.marshalling:jboss-marshalling) BuildRequires: mvn(org.osgi:osgi.cmpn) BuildRequires: mvn(org.osgi:osgi.core) BuildRequires: mvn(org.slf4j:slf4j-api) BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:) BuildArch: noarch %description Netty is a NIO client server framework which enables quick and easy development of network applications such as protocol servers and clients. It greatly simplifies and streamlines network programming such as TCP and UDP socket server. 'Quick and easy' doesn't mean that a resulting application will suffer from a maintainability or a performance issue. Netty has been designed carefully with the experiences earned from the implementation of a lot of protocols such as FTP, SMTP, HTTP, and various binary and text-based legacy protocols. As a result, Netty has succeeded to find a way to achieve ease of development, performance, stability, and flexibility without a compromise. %package javadoc Summary: API documentation for %{name} %description javadoc %{summary}. %prep %setup -q -n netty-netty-%{namedversion} # just to be sure, but not used anyway rm -rf jar doc license %pom_remove_plugin :maven-jxr-plugin %pom_remove_plugin :maven-checkstyle-plugin %pom_remove_plugin org.eclipse.m2e:lifecycle-mapping %pom_remove_plugin :animal-sniffer-maven-plugin %pom_remove_plugin :maven-enforcer-plugin %pom_remove_dep javax.activation:activation %pom_remove_dep :npn-api %pom_xpath_remove "pom:extension[pom:artifactId[text()='os-maven-plugin']]" %pom_xpath_remove "pom:execution[pom:id[text()='remove-examples']]" %pom_xpath_remove "pom:plugin[pom:artifactId[text()='maven-javadoc-plugin']]/pom:configuration" %pom_xpath_remove "pom:dependency[pom:artifactId[text()='netty-tcnative']]/pom:classifier" %pom_change_dep :netty-tcnative org.apache.tomcat:tomcat-jni # Set scope of optional compile dependencies to 'provided' %pom_xpath_set "pom:dependency[pom:scope[text()='compile'] and pom:optional[text()='true']]/pom:scope" provided %pom_xpath_set "pom:plugin[pom:artifactId[text()='maven-compiler-plugin']]/pom:configuration/pom:source" "8" %pom_xpath_set "pom:plugin[pom:artifactId[text()='maven-compiler-plugin']]/pom:configuration/pom:target" "8" # Force use servlet 3.1 apis %pom_change_dep :servlet-api javax.servlet:javax.servlet-api:3.1.0 # use latest OSGi implementation %pom_change_dep :org.osgi.core org.osgi:osgi.core %pom_change_dep :org.osgi.compendium org.osgi:osgi.cmpn # Uneeded tasks %pom_remove_plugin :maven-assembly-plugin %pom_remove_plugin :maven-source-plugin # Unavailable plugin %pom_remove_plugin kr.motd.maven:exec-maven-plugin # Fix javadoc doclint %pom_remove_plugin :maven-javadoc-plugin sed s/jboss-logging-spi/jboss-logging/ -i pom.xml # Remove bundled jzlib and use system jzlib rm -r src/main/java/org/jboss/netty/util/internal/jzlib %pom_add_dep com.jcraft:jzlib sed -i s/org.jboss.netty.util.internal.jzlib/com.jcraft.jzlib/ \ $(find src/main/java/org/jboss/netty/handler/codec -name \*.java | sort -u) %patch -P 0 -p1 %patch -P 1 -p1 # Reimplement the OpenJdkSelfSignedCertGenerator class # so that it does not use removed classes. This adds the # bouncycastle dependency %patch -P 2 -p1 %pom_add_dep org.bouncycastle:bcprov-jdk16 %patch -P 3 -p1 %patch -P 4 -p1 # adapting to excluded dep rm -v src/main/java/org/jboss/netty/handler/ssl/JettyNpnSslEngine.java %{mvn_alias} : org.jboss.netty: %{mvn_file} : %{name} %build # regenearate to be usable with newer versions of protobuf-java protoc src/main/java/org/jboss/netty/example/localtime/LocalTimeProtocol.proto \ --java_out=src/main/java %{mvn_build} -f -- \ %if %{?pkg_vcmp:%pkg_vcmp java-devel >= 9}%{!?pkg_vcmp:0} -Dmaven.compiler.release=8 \ %endif -Dproject.build.outputTimestamp=$(date -u -d @${SOURCE_DATE_EPOCH:-$(date +%%s)} +%%Y-%%m-%%dT%%H:%%M:%%SZ) \ -Dsource=8 %install %mvn_install %fdupes -s %{buildroot}%{_javadocdir} %files -f .mfiles %doc README.md %license LICENSE.txt NOTICE.txt %files javadoc -f .mfiles-javadoc %license LICENSE.txt NOTICE.txt %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor