Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
SUSE:SLE-12-SP1:GA
go1.4.2966
go1.4.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File go1.4.spec of Package go1.4.2966
# # spec file for package go1.4 # # Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # Name: go1.4 Version: 1.4.2 Release: 0 Summary: A compiled, garbage-collected, concurrent programming language License: BSD-3-Clause Group: Development/Languages/Other Url: http://golang.org Source0: http://golang.org/dl/go%{version}.src.tar.gz Source1: go-rpmlintrc Source2: go.sh Source3: macros.go Source4: go-wiki-gadget.xml Source5: README.SUSE # PATCH-FIX-OPENSUSE add -s flag to 'go install' (don't rebuild/install std libs) Patch1: go-build-dont-reinstall-stdlibs.patch # PATCH-FIX-OPENSUSE re-enable build binary only packages (we are binary distro) # see http://code.google.com/p/go/issues/detail?id=2775 & also issue 3268 Patch2: allow-binary-only-packages.patch #PATCH-FIX-OPENSUSE use -x verbose build output for qemu-arm builders Patch3: verbose-build.patch # PATCH-FIX-OPENSUSE BNC#776058 Patch4: go-install-dont-reinstall-stdlibs.patch # PATCH-FIX-OPENSUSE enable writing tools outside $GOROOT/pkg/tool for packaging Patch5: tools-packaging.patch # armv6l needs this patch for our build system # see https://groups.google.com/forum/#!topic/golang-nuts/MqKTX_XIOKE Patch6: armv6l.patch # PATCH-FIX-OPENSUSE fix_certificates_lookup.patch fcastelli@suse.com -- this patch forces Go to look for certificates only in the openSUSE/SLE locations. It also fixes certificate loading on SLE11, see https://github.com/golang/go/issues/6391 # PATCH-FIX-SUSE fix_certificates_lookup.patch fcastelli@suse.com -- this patch forces Go to look for certificates only in the openSUSE/SLE locations. It also fixes certificate loading on SLE11, see https://github.com/golang/go/issues/6391 Patch7: fix_certificates_lookup.patch Patch8: go-1.4.2-rel.plt-alignment.patch Patch9: CVE-2016-5386.patch BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildRequires: rpm %if 0%{?suse_version} >= 1210 BuildRequires: mercurial BuildRequires: systemd %endif %if 0%{?suse_version} >= 1100 BuildRequires: fdupes Recommends: %{name}-doc #BNC#818502 debug edit tool of rpm fails on i586 builds %if 0%{?suse_version} > 1230 BuildRequires: rpm >= 4.11.1 %endif %endif Requires(post): update-alternatives Requires(postun): update-alternatives Requires: gcc Provides: go-devel = go%{version} Provides: go-devel-static = go%{version} Provides: golang(API) = 1.4 Obsoletes: go-devel < go%{version} ExclusiveArch: %ix86 x86_64 %arm %description Go is an expressive, concurrent, garbage collected systems programming language that is type safe and memory safe. It has pointers but no pointer arithmetic. Go has fast builds, clean syntax, garbage collection, methods for any type, and run-time reflection. It feels like a dynamic language but has the speed and safety of a static language. %package doc Summary: Go documentation Group: Documentation/Other Requires: %{name} = %{version} %description doc Go examples and documentation. %prep %setup -q -n go %patch1 -p1 %patch2 -p1 %patch3 -p1 %patch4 -p1 %patch5 -p1 %ifarch armv6hl %patch6 -p1 %endif %patch7 -p1 %patch8 -p1 %patch9 -p1 cp %{SOURCE5} . # setup go_arch (BSD-like scheme) cp %{SOURCE3} go.macros %ifarch %ix86 sed -i 's|GOARCH|386|' go.macros %define go_arch 386 %endif %ifarch x86_64 sed -i 's|GOARCH|amd64|' go.macros %define go_arch amd64 %endif %ifarch %arm sed -i 's|GOARCH|arm|' go.macros %define go_arch arm %endif %build export GOROOT="`pwd`" export GOROOT_FINAL=%{_libdir}/%{name} export GOBIN="$GOROOT/bin" mkdir -p "$GOBIN" cd src HOST_EXTRA_CFLAGS="%{optflags} -Wno-error" ./make.bash %ifarch x86_64 # Install race detection version of std libraries (amd64 only) cd ../ bin/go install -race std %endif %install export GOROOT="%{buildroot}%{_libdir}/%{name}" install -Dm644 %{SOURCE2} $GOROOT/bin/profile.d/go.sh # locations for third party libraries, see README.SUSE for info about locations. install -d %{buildroot}%{_datadir}/%{name}/contrib install -d $GOROOT/contrib/pkg/linux_%{go_arch} ln -s %{_libdir}/%{name}/contrib/pkg/ %{buildroot}%{_datadir}/%{name}/contrib/pkg install -d %{buildroot}%{_datadir}/%{name}/contrib/cmd install -d %{buildroot}%{_datadir}/%{name}/contrib/src install -Dm644 README.SUSE $GOROOT/contrib/ ln -s %{_libdir}/%{name}/contrib/README.SUSE %{buildroot}%{_datadir}/%{name}/contrib/README.SUSE # source files for go install, godoc, etc install -d %{buildroot}%{_datadir}/%{name} for ext in *.{go,c,h,s,S,py}; do find src -name ${ext} -exec install -Dm644 \{\} %{buildroot}%{_datadir}/%{name}/\{\} \; done mkdir -p $GOROOT/src for i in $(ls %{buildroot}/usr/share/%{name}/src);do ln -s /usr/share/%{name}/src/$i $GOROOT/src/$i done # copy document templates, packages, obj libs and command utilities mkdir -p $GOROOT/bin mkdir -p $GOROOT/lib mv pkg $GOROOT mv bin/* $GOROOT/bin rm -f $GOROOT/bin/{hgpatch,quietgcc} # update-alternatives mkdir -p %{buildroot}%{_sysconfdir}/alternatives mkdir -p %{buildroot}%{_bindir} mkdir -p %{buildroot}%{_sysconfdir}/profile.d touch %{buildroot}%{_sysconfdir}/alternatives/{go,gofmt,go.sh} ln -sf %{_sysconfdir}/alternatives/go %{buildroot}%{_bindir}/go ln -sf %{_sysconfdir}/alternatives/gofmt %{buildroot}%{_bindir}/gofmt ln -sf %{_sysconfdir}/alternatives/go.sh %{buildroot}%{_sysconfdir}/profile.d/go.sh # documentation and examples # fix documetation permissions (rpmlint warning) find doc/ misc/ -type f -exec chmod 0644 '{}' \; # remove unwanted arch-dependant binaries (rpmlint warning) rm -rf misc/cgo/test/{_*,*.o,*.out,*.6,*.8} rm -f misc/dashboard/builder/{gobuilder,*6,*.8} # prepare for go-doc sub-package mkdir -p %{buildroot}%{_docdir}/%{name} cp -r AUTHORS CONTRIBUTORS LICENSE PATENTS README README.SUSE %{buildroot}%{_docdir}/%{name} cp -r doc/* %{buildroot}%{_docdir}/%{name} # install RPM macros ($GOARCH prepared in %%prep section) install -Dm644 go.macros %{buildroot}%{_sysconfdir}/rpm/macros.%{name} %if 0%{?suse_version} >= 1100 %fdupes -s %{buildroot}%{_prefix} %endif %post update-alternatives \ --install %{_bindir}/go go %{_libdir}/%{name}/bin/go 60 \ --slave %{_bindir}/gofmt gofmt %{_libdir}/%{name}/bin/gofmt \ --slave %{_sysconfdir}/profile.d/go.sh go.sh %{_libdir}/%{name}/bin/profile.d/go.sh %postun if [ $1 -eq 0 ] ; then update-alternatives --remove go %{_libdir}/%{name}/bin/go fi %files %defattr(-,root,root,-) %{_bindir}/go %{_bindir}/gofmt %ifarch %ix86 %{_libdir}/%{name}/pkg/tool/linux_%{go_arch}/8* %endif %ifarch x86_64 %{_libdir}/%{name}/pkg/tool/linux_%{go_arch}/6* %endif %ifarch %arm %{_libdir}/%{name}/pkg/tool/linux_%{go_arch}/5* %endif %{_libdir}/%{name} %{_datadir}/%{name}/ %ghost %{_sysconfdir}/alternatives/go %ghost %{_sysconfdir}/alternatives/gofmt %ghost %{_sysconfdir}/alternatives/go.sh %config %{_sysconfdir}/profile.d/go.sh %config %{_sysconfdir}/rpm/macros.%{name} %dir %{_docdir}/%{name}/ %doc %{_docdir}/%{name}/AUTHORS %doc %{_docdir}/%{name}/CONTRIBUTORS %doc %{_docdir}/%{name}/LICENSE %doc %{_docdir}/%{name}/PATENTS %doc %{_docdir}/%{name}/README %doc %{_docdir}/%{name}/README.SUSE %files doc %defattr(-,root,root,-) %doc %{_docdir}/%{name}/codewalk %doc %{_docdir}/%{name}/articles %doc %{_docdir}/%{name}/progs %doc %{_docdir}/%{name}/play %doc %{_docdir}/%{name}/gopher %doc %{_docdir}/%{name}/devel %doc %{_docdir}/%{name}/*.html %doc %{_docdir}/%{name}/*.css %doc %{_docdir}/%{name}/*.png %doc %{_docdir}/%{name}/*.gif %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor