Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
SUSE:SLE-12:Update
python
python-doc.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File python-doc.spec of Package python
# # spec file for package python-doc # # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # Name: python-doc Version: 2.7.9 Release: 0 Summary: Additional Package Documentation for Python License: Python-2.0 Group: Development/Languages/Python Url: http://www.python.org/ %define tarname Python-%{version} Source0: %{tarname}.tar.xz # docs for current version are regenerated every day # this messes with autobuild "file changed" checks #Source2: http://docs.python.org/%{version}/archives/python-%{pyver}-docs-pdf-a4.tar.bz2 #Source3: http://docs.python.org/%{version}/archives/python-%{pyver}-docs-pdf-letter.tar.bz2 Source2: python-%{version}-docs-pdf-a4.tar.bz2 Source3: python-%{version}-docs-pdf-letter.tar.bz2 Source7: dh2048.pem BuildRequires: python-Sphinx BuildRequires: xz # COMMON-PATCH-BEGIN Patch1: python-2.7-dirs.patch Patch2: python-distutils-rpm-8.patch Patch3: python-2.7.5-multilib.patch Patch4: python-2.5.1-sqlite.patch Patch5: python-2.7.4-canonicalize2.patch Patch7: python-2.6-gettext-plurals.patch Patch8: python-2.6b3-curses-panel.patch Patch10: sparc_longdouble.patch Patch13: python-2.7.2-fix_date_time_compiler.patch Patch17: remove-static-libpython.diff # PATCH-FEATURE-OPENSUSE python-bundle-lang.patch bnc#617751 dimstar@opensuse.org -- gettext: when looking in default_localedir also check in locale-bundle. Patch20: python-bundle-lang.patch # PATCH-FIX-UPSTREAM Fix argument passing in libffi for aarch64 Patch22: python-2.7-libffi-aarch64.patch Patch24: python-bsddb6.diff # PATCH-FIX-OPENSUSE remove link count optimization that breaks mhlib on btrfs (and possibly elsewhere) Patch31: python-2.7.7-mhlib-linkcount.patch # PATCH-FIX-UPSTREAM remove unconditional "import ssl" from test Patch32: python-2.7-urllib2-localnet-ssl.patch # PATCH-FIX-UPSTREAM accept directory-based CA paths as well Patch33: python-2.7.9-ssl_ca_path.patch # PATCH-FEATURE-SLE disable SSL verification-by-default in http clients Patch34: python-2.7.9-sles-disable-verification-by-default.patch # PATCH-FIX-SUSE python-fix-short-dh.patch - fix after openssl logjam update Patch35: python-fix-short-dh.patch # PATCH-FIX-UPSTREAM startTLS stripping vuln in smtplib Patch36: CVE-2016-0772-smtplib-starttls.patch # PATCH-FIX-UPSTREAM HTTP header injection in httplib Patch37: CVE-2016-5699-http-header-injection.patch # PATCH-FIX-UPSTREAM heap overflow in zipimporter Patch38: CVE-2016-5636-zipimporter-overflow.patch # PATCH-FIX-UPSTREAM httpoxy ignore proxy variables in CGI env Patch39: python-2.7-httpoxy.patch # PATCH-FIX-UPSTREAM CVE-2019-5010-null-defer-x509-cert-DOS.patch bnc#1122191 mcepl@suse.com # https://github.com/python/cpython/pull/11569 # Fix segfault in ssl's cert parser Patch40: CVE-2019-5010-null-defer-x509-cert-DOS.patch # COMMON-PATCH-END Provides: pyth_doc Provides: pyth_ps Obsoletes: pyth_doc Obsoletes: pyth_ps BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildArch: noarch Enhances: python = %{version} %description Tutorial, Global Module Index, Language Reference, Library Reference, Extending and Embedding Reference, Python/C API Reference, Documenting Python, and Macintosh Module Reference in HTML format. %package pdf Summary: Python PDF Documentation Group: Development/Languages/Python Provides: pyth_pdf Obsoletes: pyth_pdf %description pdf Tutorial, Global Module Index, Language Reference, Library Reference, Extending and Embedding Reference, Python/C API Reference, Documenting Python, and Macintosh Module Reference in PDF format. %prep %setup -q -n %{tarname} # COMMON-PREP-BEGIN %patch1 -p1 %patch2 -p1 %patch3 -p1 %patch4 -p1 %patch5 -p1 %patch7 -p1 %patch8 -p1 %patch10 -p1 %patch13 -p1 %patch17 -p1 %patch20 -p1 %patch22 -p1 %patch24 -p1 %patch31 -p1 %patch32 -p1 %patch33 -p1 %if %{suse_version} == 1315 %patch34 -p1 %endif %patch35 -p1 %patch36 -p1 %patch37 -p1 %patch38 -p1 %patch39 -p1 %patch40 -p1 cp %{SOURCE7} Lib/test/ # drop Autoconf version requirement sed -i 's/^version_required/dnl version_required/' configure.ac # COMMON-PREP-END %build TODAY_DATE=`date -r %{S:0} "+%B %d, %Y"` # TODO use not date of tarball but date of latest patch pushd Doc sed -i "s/^today = .*/today = '$TODAY_DATE'/" conf.py %if 0%{?suse_version} < 1320 # lower sphinx version requirement, docs seem to work fine with 1.1 sed -i "s/^needs_sphinx = .*/needs_sphinx = '1.1'/" conf.py %endif make html popd %install export PDOCS=%{buildroot}%{_docdir}/python install -d -m 755 $PDOCS/Misc rm Doc/build/html/.buildinfo mv Doc/build/html $PDOCS/html tar xfj %{SOURCE2} -C $PDOCS mv $PDOCS/docs-pdf $PDOCS/paper-a4 tar xfj %{SOURCE3} -C $PDOCS mv $PDOCS/docs-pdf $PDOCS/paper-letter # this is part of main package #install -c -m 644 README $PDOCS/README for i in Misc/* ; do [ -f $i ] && install -c -m 644 $i $PDOCS/Misc/ done %files %defattr(644,root,root,755) %dir %{_docdir}/python %doc %{_docdir}/python/Misc %doc %{_docdir}/python/html #%doc %{_docdir}/python/README %files pdf %defattr(644,root,root,755) %doc %{_docdir}/python/paper-a4 %doc %{_docdir}/python/paper-letter %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor