Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:FunkyM
gcc-d
gcc-d.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File gcc-d.spec of Package gcc-d
# # spec file for package gcc-d (Version 0.24) # # Copyright (c) 2007 Sukimashita # This file and all modifications and additions to the pristine # package are under the same license as the package itself. # # norootforbuild %define gcc_version 4.1.3 %define snapshot_date 20070724 Name: gcc-d BuildRequires: bison flex binutils gcc gcc-c++ libstdc++-devel glibc-devel gettext-devel texinfo %ifarch %ix86 x86_64 ia64 BuildRequires: glibc-devel-32bit %endif URL: http://dgcc.sourceforge.net/ License: GNU General Public License (GPL) Group: Development/Languages/D Autoreqprov: on Version: 0.24 Release: 3 Summary: The system GNU D Compiler Source: gcc-%{gcc_version}-%{snapshot_date}.tar.bz2 Source1: gdc-%{version}-src.tar.bz2 Source2: libgphobos.spec Patch1: gdc-disable-shared-libgcc.patch BuildRoot: %{_tmppath}/%{name}-%{version}-build Provides: d_compiler Obsoletes: gdc Requires: gcc gcc-d-stdlib-devel %description D is a general purpose systems and applications programming language. D is a higher level language than C++, but retains the ability to write high performance code and interface directly with the operating system API's and with hardware. D is well suited to writing medium to large scale million line programs with teams of developers. D is easy to learn, provides many capabilities to aid the programmer, and is well suited to aggressive compiler optimization technology. This package version of GDC (%{version}) was built using GCC version %{gcc_version}. See http://dgcc.sourceforge.net/ for more info on the GDC D Compiler. See http://gcc.gnu.org/ for more info on the GNU Compiler Collection. Authors: -------- David Friedman <dvdfrdmn@users.sf.net> %package -n gcc-d-phobos-devel Group: Development/Languages/D Summary: The system GNU D Compiler Provides: gcc-d-stdlib-devel %description -n gcc-d-phobos-devel D is a general purpose systems and applications programming language. D is a higher level language than C++, but retains the ability to write high performance code and interface directly with the operating system API's and with hardware. D is well suited to writing medium to large scale million line programs with teams of developers. D is easy to learn, provides many capabilities to aid the programmer, and is well suited to aggressive compiler optimization technology. This package version of GDC (%{version}) was built using GCC version %{gcc_version}. See http://dgcc.sourceforge.net/ for more info on the GDC D Compiler. See http://gcc.gnu.org/ for more info on the GNU Compiler Collection. Authors: -------- David Friedman <dvdfrdmn@users.sf.net> %debug_package %prep %setup -q -n gcc-%{gcc_version} -c -D -T -a 0 -a 1 mv d gcc-%{gcc_version}-%{snapshot_date}/gcc pushd gcc-%{gcc_version}-%{snapshot_date} %patch1 ./gcc/d/setup-gcc.sh popd %build rm -rf obj-%{_target_platform} mkdir obj-%{_target_platform} pushd obj-%{_target_platform} CFLAGS="$CFLAGS $RPM_OPT_FLAGS" ; export CFLAGS ; \ CXXFLAGS="$CXXFLAGS $RPM_OPT_FLAGS" ; export CXXFLAGS ; \ FFLAGS="$FFLAGS $RPM_OPT_FLAGS" ; export FFLAGS ; \ ../gcc-%{gcc_version}-%{snapshot_date}/configure \ --host=%{_target_platform} \ --prefix=%{_prefix} \ --exec-prefix=%{_exec_prefix} \ --bindir=%{_bindir} \ --sbindir=%{_sbindir} \ --sysconfdir=%{_sysconfdir} \ --datadir=%{_datadir} \ --includedir=%{_includedir} \ --libdir=%{_libdir} \ --libexecdir=%{_libexecdir} \ --localstatedir=%{_localstatedir} \ --sharedstatedir=%{_sharedstatedir} \ --mandir=%{_mandir} \ --infodir=%{_infodir} \ --with-slibdir=/%{_lib} --with-system-zlib \ --enable-__cxa_atexit \ --enable-libstdcxx-allocator=new \ --disable-multilib \ --enable-languages=d \ --without-system-unwind make %{?jobs:-j%jobs} popd %install pushd obj-%{_target_platform} %makeinstall popd cp -a %{S:2} $RPM_BUILD_ROOT%{_libdir}/ # Remove unrequired files rm -f $RPM_BUILD_ROOT%{_bindir}/cpp rm -f $RPM_BUILD_ROOT%{_bindir}/g[cd]* rm -f $RPM_BUILD_ROOT%{_bindir}/%{_target_platform}-gc* rm -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h rm -rf $RPM_BUILD_ROOT%{_infodir} rm -rf $RPM_BUILD_ROOT%{_datadir}/locale rm -f $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/gc* rm -rf $RPM_BUILD_ROOT%{_mandir}/man7 rm -f $RPM_BUILD_ROOT%{_libdir}/lib[smi]* rm -rf $RPM_BUILD_ROOT%{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/install-tools rm -rf $RPM_BUILD_ROOT%{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/include rm -f $RPM_BUILD_ROOT%{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/collect2 # These files are needed for gcc-4.1.3 used by gdc: #rm -f $RPM_BUILD_ROOT%{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/*.[oa] #rm -f $RPM_BUILD_ROOT%{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/cc1 # Fix symlinks ln -s %{_target_platform}-gdc $RPM_BUILD_ROOT%{_bindir}/gdc ln -s %{_target_platform}-gdmd $RPM_BUILD_ROOT%{_bindir}/gdmd %clean rm -rf $RPM_BUILD_ROOT %post %run_ldconfig %postun %run_ldconfig %files %defattr (-, root, root) %doc gcc-%{gcc_version}-%{snapshot_date}/gcc/d/README %doc gcc-%{gcc_version}-%{snapshot_date}/gcc/d/ChangeLog %{_bindir}/*gdc* %{_bindir}/*gdmd* %{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/cc1d %{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/*.[oa] %{_libexecdir}/gcc/%{_target_platform}/%{gcc_version}/cc1 %{_mandir}/man1/gdc.1* %{_mandir}/man1/gdmd.1* %files -n gcc-d-phobos-devel %defattr (-, root, root) %{_libdir}/libgphobos.a %{_libdir}/libgphobos.spec %{_includedir}/d/%{gcc_version} %changelog * Wed Aug 6 2008 florian.schaefer@gmail.com - Attempt to fix the libunwind issue * Wed Nov 21 2007 opensuse@sukimashita.com - Attempt to fix build issues for 64bit version * Wed Aug 22 2007 opensuse@sukimashita.com - Update to version 0.24 * Wed Mar 28 2007 opensuse@sukimashita.com - Add libunwind BuildRequires for linking * Mon Mar 26 2007 opensuse@sukimashita.com - Initial Package
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor