Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:Ledest:erlang:18
hackney
hackney.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File hackney.spec of Package hackney
%define bname hackney Name: %bname Version: 1.7.1 Release: 3 Summary: HTTP client library in Erlang License: Apache-2.0 Group: Development/Tools/Other URL: https://github.com/benoitc/%bname Source: %bname-%version.tar.xz Patch0: %bname-%version-git.patch Patch1: %bname-1.7.1-fix-test.patch BuildArch: noarch Provides: erlang-%bname = %version-%release BuildRequires: rpm-macros-erlang rpm-build-erlang BuildRequires: rebar >= 2.6.1-7 BuildRequires: erlang-public_key-devel # check BuildRequires: erlang-idna mimerl erlang-metrics erlang-cowboy erlang-certifi erlang-ssl_verify_fun %description hackney - HTTP client library in Erlang. Main features: - no message passing (except for asynchronous responses): response is directly streamed to the current process and state is kept in a #client{} record - binary streams - SSL support - keepalive handling - basic authentication - stream the response and the requests - fetch a response asynchronously - multipart support (streamed or not) - chunked encoding support - can send files using the sendfile API - optional socket pool - REST syntax: hackney:Method(URL) (where a method can be get, post, put, delete, ...). %package devel Summary: Headers of %bname Group: Development/Tools/Other Provides: erlang-%bname-devel = %version-%release Conflicts: %name < 1.7.1-2 %description devel Headers of %bname. %package doc Summary: Documentation of %bname Group: Documentation/HTML Provides: erlang-%bname-doc = %version-%release Conflicts: %name < 1.7.1-2 %description doc Documentation of %bname. %prep %setup -q -n %bname-%version %patch0 -p1 %patch1 -p1 sed -i '1s|^.*$|#!%_bindir/escript|' examples/*.e{rl,script,bin} # FIX IT rm -f test/hackney_integration_tests.erl %build erl -noshell -eval ' {ok, L} = file:consult("rebar.config"), file:write_file("%bname.rebar.config", lists:map(fun(E) -> [io_lib:print(E), ".\n"] end, lists:keystore(erl_opts, 1, lists:foldl(fun proplists:delete/2, L, [deps, cover_enabled]), {erl_opts, [slim, inline, no_debug_info|lists:delete(debug_info, proplists:get_value(erl_opts, L, []))]}))), halt().' rebar -C %bname.rebar.config compile -v rebar -C %bname.rebar.config doc -v %install install -d -m 0755 %buildroot%_otplibdir/%bname-%version/ebin install -p -m 0644 ebin/* %buildroot%_otplibdir/%bname-%version/ebin/ install -d -m 0755 %buildroot%_otplibdir/%bname-%version/include install -p -m 0644 include/* %buildroot%_otplibdir/%bname-%version/include/ install -d -m 0755 %buildroot%_otplibdir/%bname-%version/examples install -p -m 0644 examples/*.json %buildroot%_otplibdir/%bname-%version/examples/ install -p -m 0755 examples/*.e{rl,script,bin} %buildroot%_otplibdir/%bname-%version/examples/ install -d -m 0755 %buildroot%_otplibdir/%bname-%version/doc install -p -m 0644 doc/*.{css,html,png} %buildroot%_otplibdir/%bname-%version/doc/ install -d -m 0755 %buildroot%_docdir/%name install -p -m 0644 *.md MAINTAINERS NOTICE THANKS %buildroot%_docdir/%name/ ln -sf %_otplibdir/%bname-%version/doc %buildroot%_docdir/%name/html ln -sf %_otplibdir/%bname-%version/examples %buildroot%_docdir/%name/ %check rebar -C %bname.rebar.config eunit -v %files %defattr(-,root,root) %doc %_docdir/%name %_otplibdir/* %exclude %_otplibdir/%bname-*/include %exclude %_otplibdir/%bname-*/doc %exclude %_otplibdir/%bname-*/examples %files devel %defattr(-,root,root) %dir %_otplibdir/%bname-* %_otplibdir/%bname-*/include %files doc %defattr(-,root,root) %doc %_docdir/%name %doc %dir %_otplibdir/%bname-* %doc %_otplibdir/%bname-*/doc %doc %_otplibdir/%bname-*/examples %changelog * Mon Apr 17 2017 Led <ledest@gmail.com> 1.7.1-3 - git 362f062 - remove patches: + hackney-1.7.1-fixed-undefined-function.patch + hackney-1.7.1-close-connection-if-handshake-failed.patch * Sun Mar 12 2017 Led <ledest@gmail.com> 1.7.1-2 - move docs and examples to doc subpackage - move headers to devel subpackage * Sun Mar 12 2017 Led <ledest@gmail.com> 1.7.1-1 - initial build
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor