Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:dirkmueller:acdc:as_python3_module
python-pytest5.14582
python-pytest5.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File python-pytest5.spec of Package python-pytest5.14582
# # spec file for package python # # Copyright (c) 2020 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # %{?!python_module:%define python_module() python-%{**} python3-%{**}} %global flavor @BUILD_FLAVOR@%{nil} %if "%{flavor}" == "test" %define psuffix -%{flavor} %bcond_without test %else %define psuffix %{nil} %bcond_with test %endif %define skip_python2 1 Name: python-pytest5%{psuffix} Version: 5.3.5 Release: 0 Summary: Python testing tool with autodiscovery and detailed asserts License: MIT URL: https://github.com/pytest-dev/pytest Group: Development/Languages/Python Source: https://files.pythonhosted.org/packages/source/p/pytest/pytest-%{version}.tar.gz BuildRequires: %{python_module setuptools >= 40.0} BuildRequires: %{python_module setuptools_scm} BuildRequires: fdupes BuildRequires: python-rpm-macros Requires: python-atomicwrites >= 1.0 Requires: python-attrs >= 17.4.0 Requires: python-importlib-metadata >= 0.12 Requires: python-more-itertools >= 4.0.0 Requires: python-packaging Requires: python-pluggy >= 0.12 Requires: python-py >= 1.5.0 Requires: python-setuptools Requires: python-six >= 1.10.0 Requires: python-wcwidth Requires(post): update-alternatives Requires(postun): update-alternatives Provides: python-pytest = %{version}-%{release} Conflicts: python-pytest Obsoletes: python-pytest-doc BuildArch: noarch %if %{with test} BuildRequires: %{python_module Jinja2} BuildRequires: %{python_module Twisted} BuildRequires: %{python_module decorator} BuildRequires: %{python_module hypothesis} BuildRequires: %{python_module importlib-metadata >= 0.12} BuildRequires: %{python_module mock} BuildRequires: %{python_module nose} BuildRequires: %{python_module numpy} BuildRequires: %{python_module pexpect} BuildRequires: %{python_module pygments-pytest} BuildRequires: %{python_module pytest >= %{version}} BuildRequires: %{python_module pytest-forked} BuildRequires: %{python_module pytest-xdist} BuildRequires: %{python_module requests} BuildRequires: %{python_module setuptools_scm} BuildRequires: %{python_module xmlschema} BuildRequires: lsof %endif %if %{python3_version_nodots} < 36 Requires: python-pathlib2 >= 2.2.0 %endif %python_subpackages %description pytest is a cross-project Python testing tool. It provides: * auto-discovery of test modules and functions, * detailed info on failing assert statements (no need to remember self.assert* names), * modular fixtures for managing small or parametrized long-lived test resources. * multi-paradigm support: you can use py.test to run test suites based on unittest (or trial), nose, * single-source compatibility to Python2.4 all the way up to Python3.3, PyPy-1.9 and Jython-2.5.1, and * many external plugins. %prep %setup -q -n pytest-%{version} %autopatch -p1 %build %python_build %install %if ! %{with test} %python_install %python_clone -a %{buildroot}%{_bindir}/py.test %python_clone -a %{buildroot}%{_bindir}/pytest if [ -x %{buildroot}%{_bindir}/py.test-%{python2_bin_suffix} ]; then ln -s py.test-%{python2_bin_suffix} %{buildroot}%{_bindir}/py.test2 fi if [ -x %{buildroot}%{_bindir}/py.test-%{python3_bin_suffix} ]; then ln -s py.test-%{python3_bin_suffix} %{buildroot}%{_bindir}/py.test3 fi %python_expand %fdupes %{buildroot}%{$python_sitelib} %endif %check %if %{with test} SKIP_TEST="test_xdist_normal or test_pdb_can_be_rewritten" # gh#pytest-dev/pytest#6297 case $(uname -m) in s390*) SKIP_TEST="$SKIP_TEST or test_pdb_unittest_skip or test_pdb_print_captured_stdout_and_stderr" SKIP_TEST="$SKIP_TEST or test_doctest_set_trace_quit or test_pdb_continue_with_recursive_debug" SKIP_TEST="$SKIP_TEST or test_trace_sets_breakpoint or test_trace_with_parametrize_handles_shared_fixtureinfo" SKIP_TEST="$SKIP_TEST or test_pdb_suspends_fixture_capturing or test_report_collect_after_half_a_second" ;; esac export SKIP_TEST %pytest -k "not ($SKIP_TEST)" %endif %if ! %{with test} %post %{python_install_alternative py.test} \ --slave %{_bindir}/pytest pytest %{_bindir}/pytest-%{python_version} %postun %python_uninstall_alternative py.test %files %{python_files} %doc AUTHORS CHANGELOG.rst README.rst %license LICENSE %python_alternative %{_bindir}/py.test %python_alternative %{_bindir}/pytest %python2_only %{_bindir}/py.test2 %python3_only %{_bindir}/py.test3 %{python_sitelib}/* %endif %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor