Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:dirkmueller:branches:home:mimi_vx:ghc-bootstrap
ghc-prepare-binary-distributions
ghc-prepare-binary-distributions.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File ghc-prepare-binary-distributions.spec of Package ghc-prepare-binary-distributions
# # spec file for package ghc-prepare-binary-distributions # # Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %global unregisterised_archs s390 s390x %ifarch aarch64 %define longarch aarch64 %endif %ifarch ppc %define longarch powerpc %endif %ifarch ppc64 %define longarch powerpc64 %endif %ifarch ppc64le %define longarch powerpc64le %endif %ifarch riscv64 %define longarch riscv64 %endif %ifarch s390 %define longarch s390 %endif %ifarch s390x %define longarch s390x %endif %ifarch x86_64 %define longarch x86_64 %endif %ifarch s390 s390x %define sysname ibm %else %define sysname unknown %endif Name: ghc-prepare-binary-distributions Version: 8.10.7 Release: 0 Url: http://haskell.org/ghc/dist/%{version}/ghc-%{version}-src.tar.xz Summary: The Glorious Glasgow Haskell Compiler binary distribution License: BSD-3-Clause Group: Development/Languages/Other BuildRequires: ghc-bytestring-devel BuildRequires: ghc-compiler BuildRequires: ghc-binary-devel BuildRequires: ghc-containers-devel BuildRequires: ghc-directory-devel BuildRequires: ghc-pretty-devel BuildRequires: ghc-process-devel BuildRequires: ghc-transformers-devel BuildRequires: ghc-template-haskell-devel BuildRequires: ghc-xhtml-devel #%ifarch riscv64 #BuildRequires: gcc9 #%else BuildRequires: gcc #%endif BuildRequires: autoconf BuildRequires: automake BuildRequires: binutils-devel BuildRequires: glibc-devel BuildRequires: gmp-devel BuildRequires: libelf-devel BuildRequires: ncurses-devel BuildRequires: pkg-config %ifarch aarch64 riscv64 BuildRequires: llvm9-devel %endif BuildRequires: libffi-devel %define system_libffi 1 %if 0%{?suse_version} >= 1500 BuildRequires: memory-constraints %endif ExcludeArch: %{ix86} # ignore failures with unregisterised compilers (s390x) #!BuildIgnore: post-build-checks Source: http://haskell.org/ghc/dist/%{version}/ghc-%{version}-src.tar.xz # PATCH-FIX-UPSTREAM Disable-unboxed-arrays.patch ptrommler@icloud.com -- Do not use unboxed arrays on big-endian platforms. See Haskell Trac #15411. Patch3: Disable-unboxed-arrays.patch # PATCH-FIX-UPSTREAM fix-build-using-unregisterized-v8.4.patch Patch5: fix-build-using-unregisterized-v8.4.patch # PATCH-FIX-UPSTREAM fix-unregisterised-v8.4-8.6.patch Patch6: fix-unregisterised-v8.4-8.6.patch # PATCH-FIX-UPSTREAM ghc-pie.patch - set linux as default PIE platform Patch35: ghc-pie.patch # PATCH-FIX-OPENSUSE ghc-8.0.2-Cabal-dynlibdir.patch -- Fix shared library directory location. Patch100: ghc-8.0.2-Cabal-dynlibdir.patch # PATCH-FIX-UPSTREAM buildpath-abi-stability.patch -- debian patch for more stable abi-1 Patch110: buildpath-abi-stability.patch # patches for riscv64 thx to Andreas Schwab patch24300: riscv.patch Patch24301: libatomic.patch Patch24302: riscv-tntc.patch %description Haskell is the standard purely functional programming language; the current language version is Haskell 98, agreed in December 1998. GHC is a state-of-the-art programming suite for Haskell. Included is an optimising compiler generating good code for a variety of platforms, together with an interactive system for convenient, quick development. The distribution includes space and time profiling facilities, a large collection of libraries, and support for various language extensions, including concurrency, exceptions, and foreign language interfaces (C, C++, etc). A wide variety of Haskell related resources (tutorials, libraries, specifications, documentation, compilers, interprbeters, references, contact information, links to research groups) are available from the Haskell home page at <http://www.haskell.org/>. %prep %setup -q -n ghc-%{version} # workaround bogus gcc warning that causes unregistered builds to be rejected # by OBS - rpmlint filters do not work with OBS checks sed -i -e '/SRC_CC_OPTS/s/$/ -Wno-return-type/' mk/warnings.mk #%%patch1 -p1 %ifarch ppc64 s390 s390x %patch3 -p1 %endif %patch5 -p1 %patch6 -p1 %patch35 -p1 %patch100 -p1 %patch110 -p1 %patch24300 -p1 %patch24301 -p1 %patch24302 -p1 %build %if 0%{?qemu_user_space_build} %limit_build -m 15000 %endif cat > mk/build.mk <<EOF %ifnarch %{unregisterised_archs} %ifarch aarch64 %{arm} BuildFlavour = quick-llvm %else BuildFlavour = quick %endif %endif GhcLibWays = v DYNAMIC_GHC_PROGRAMS = NO %ifarch %{unregistered_archs} GhcUnregisterised=YES %endif HSCOLOUR_SRCS = NO HADDOCK_DOCS = NO EOF #%{ghc_set_gcc_flags} export LANG=C.utf8 export CFLAGS="${CFLAGS:-%optflags}" ./configure --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} \ --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \ --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} \ --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} \ --with-system-libffi \ %ifarch %{unregisterised_archs} --enable-unregisterised \ %endif --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} %ifarch %{unregisterised_archs} %if 0%{?qemu_user_space_build} %limit_build -m 15000 %else %limit_build -m 8000 %endif %else %limit_build -m 2000 %endif make -j 2 make binary-dist %install mkdir -p %{buildroot}%{_datadir}/ghc cp ghc-%{version}-%{longarch}-%{sysname}-linux.tar.xz %{buildroot}%{_datadir}/ghc %check cd /tmp tar -Jxvf %{buildroot}%{_datadir}/ghc/ghc-%{version}-%{longarch}-%{sysname}-linux.tar.xz cd ghc-%{version} ./configure --prefix=/tmp/disttest make install %files %defattr(-,root,root,-) %dir %{_datadir}/ghc %{_datadir}/ghc/ghc-%{version}-%{longarch}-%{sysname}-linux.tar.xz %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor