Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:ecsos:server
drupal10
drupal10.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File drupal10.spec of Package drupal10
# # spec file for package drupal10 # # Copyright (c) 2022 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # %define drupal_dir %{apache_serverroot}/%{name} %define sourcename drupal %define php_major_version %(php -r "echo PHP_MAJOR_VERSION;") Name: drupal10 %if 0%{?sle_version} == 120200 && !0%{?is_opensuse} BuildRequires: php8 >= 8.1.0 %else BuildRequires: php %endif %if 0%{?suse_version} BuildRequires: fdupes BuildRequires: php8-cli %endif %if 0%{?fedora_version} || 0%{?rhel_version} || 0%{?centos_version} BuildRequires: httpd-devel %endif %if 0%{?mandriva_version} BuildRequires: apache-devel BuildRequires: nginx BuildRequires: php-fpm %endif Version: 10.2.1 Release: 0.0 Requires: curl Summary: A content management framework written in PHP and distributed under the GNU License: GPL-2.0-or-later Group: Productivity/Publishing/Other URL: https://drupal.org/ Source0: http://ftp.drupal.org/files/projects/%{sourcename}-%{version}.tar.gz Source1: %{name}.apache2.conf.default Source2: %{name}.apache2.conf.vhost Source3: %{name}.apache2.conf.nonsuse Source4: %{name}.nginx.conf Source5: php-fpm.conf # PATCH-FIX-OPENSUSE drupal10_path.diff Patch0: %{name}_path.diff BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildArch: noarch BuildRequires: apache-rpm-macros %if 0%{?is_opensuse} BuildRequires: nginx ###%%if 0%%{?sle_version} >= 120200 BuildRequires: php8-fpm >= 8.1.0 ###%%else ###BuildRequires: php-fpm ###%%endif %endif %description Drupal is an open source content management platform powering millions of websites and applications. It’s built, used, and supported by an active and diverse community of people around the world. %package apache2 Summary: Apache configuration files for drupal10 Group: Productivity/Publishing/Other %if 0%{?suse_version} BuildRequires: apache2 Requires: apache2 Requires: (mod_php_any >= 8.1 or php-fpm) %endif %if 0%{?fedora_version} || 0%{?rhel_version} || 0%{?centos_version} Requires: httpd Requires: httpd-mod_php8 %endif %if 0%{?mandriva_version} Requires: apache-base Requires: apache-conf Requires: apache-mod_php8 %endif Requires: %{name} = %{version} Requires: php-gd Requires: php-mbstring Requires: php-mysql Requires: php-opcache Requires: php-pgsql Requires: php-zlib Supplements: packageand(apache2:%name) %description apache2 The Drupal10 Apache 2 mod_php configuration files %if 0%{?is_opensuse} %package nginx Summary: Nginx configuration files for drupal10 Group: Productivity/Publishing/Other Requires: %{name} = %{version} Requires: nginx Requires: php-fpm Requires: php-gd Requires: php-mbstring Requires: php-mysql Requires: php-opcache Requires: php-pgsql Requires: php-zlib Supplements: packageand(nginx:%name) %description nginx The Drupal10 Nginx php-fpm configuration files %endif %package fpm Summary: Fpm configuration files for drupal10 Group: Productivity/Publishing/Other Requires: %{name} = %{version} Requires: php-fpm Supplements: packageand(php-fpm:%name) %description fpm The Drupal10 php-fpm configuration files %prep %setup -q -n %{sourcename}-%{version} %patch0 -p1 # rpmlint find . -type f "(" -name '*~' -o -name '*.orig' -o -name '*.bak' ")" -delete find . -type f "(" -name '.editorconfig' -o -name '.travis.yml' ")" -delete find . -type f "(" -name '.gitignore' -o -name '.gitattributes' -o -name '.gitmodules' -o -name '.github' ")" -delete find . -type f "(" -name '.eslintignore' -o -name '.eslintrc' -o -name '.eslintrc.*' -o -name '.csslintrc' -o -name '.arclint' -o -name '.arcconfig' ")" -delete find . -type f -exec sed -i 's/#!\/usr\/bin\/env.*bash$/#!\/bin\/bash/' {} \; find . -type f -exec sed -i 's/#!\/usr\/bin\/env.*php$/#!\/usr\/bin\/php/' {} \; %build # nothing to build #find . -name ".coveralls.yml" -exec rm {} \; #find . -name ".scrutinizer.yml" -exec rm {} \; #find . -name ".travis.install.sh" -exec rm {} \; #find . -name ".php_cs" -exec rm {} \; %install %if 0%{?suse_version} mkdir -p %{buildroot}%{apache_sysconfdir}/conf.d cp -avL %{SOURCE1} %{buildroot}%{apache_sysconfdir}/conf.d/%{name}.conf mkdir -p %{buildroot}%{apache_sysconfdir}/vhosts.d cp -avL %{SOURCE2} %{buildroot}%{apache_sysconfdir}/vhosts.d/%{name}.conf %else mkdir -p %{buildroot}%{apache_sysconfdir}/../conf.d cp -avL %{SOURCE3} %{buildroot}%{apache_sysconfdir}/../conf.d/%{name}.conf %endif %if 0%{?is_opensuse} mkdir -p %{buildroot}%{_sysconfdir}/nginx/conf.d cp -avL %{SOURCE4} %{buildroot}%{_sysconfdir}/nginx/conf.d/drupal10.conf mkdir -p %{buildroot}%{_sysconfdir}/php%{php_major_version}/fpm cp -avL %{SOURCE5} %{buildroot}%{_sysconfdir}/php%{php_major_version}/fpm/php-fpm.conf %endif mkdir -p %{buildroot}%{drupal_dir} cp -avL ./ %{buildroot}/%{drupal_dir}/ mkdir -p %{buildroot}%{drupal_dir}/sites/default/files find %{buildroot}%{drupal_dir} -type f -exec grep -Hl "#!/usr/bin/php" {} \; | xargs chmod +x %if 0%{?suse_version} %fdupes -s %{buildroot}%{drupal_dir} %endif %files %defattr(-,%{apache_user},%{apache_group}) %config (noreplace) %{drupal_dir}/sites/ %{drupal_dir}/ %files apache2 %defattr(-,root,root) %if 0%{?suse_version} %dir %{apache_sysconfdir}/conf.d %config (noreplace) %{apache_sysconfdir}/conf.d/%{name}.conf %dir %{apache_sysconfdir}/vhosts.d %config (noreplace) %{apache_sysconfdir}/vhosts.d/%{name}.conf %else %dir %{apache_sysconfdir}/../conf.d %config (noreplace) %{apache_sysconfdir}/../conf.d/%{name}.conf %endif %if 0%{?is_opensuse} %files nginx %defattr(-,root,root) %dir %{_sysconfdir}/nginx/conf.d %config (noreplace) %{_sysconfdir}/nginx/conf.d/drupal10.conf %endif %files fpm %defattr(-,root,root) %config (noreplace) %{_sysconfdir}/php%{php_major_version}/fpm/php-fpm.conf %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor