Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:lafenghu
php5-pear-HTTP_Request
php5-pear-HTTP_Request.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File php5-pear-HTTP_Request.spec of Package php5-pear-HTTP_Request
# # spec file for package php5-pear-HTTP_Request # # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # Name: php5-pear-HTTP_Request %define pear_name HTTP_Request %define pear_sname http_request Summary: Provides an easy way to perform HTTP requests License: BSD-3-Clause Group: Productivity/Networking/Web/Servers Version: 1.4.4 Release: 0 BuildArch: noarch Url: http://pear.php.net/package/%{pear_name} Source: %{pear_name}-%{version}.tgz BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildRequires: php >= 4.3 BuildRequires: php-macros BuildRequires: php5-pear Requires: php >= 4.3 Requires: php5-pear Requires: php-pear-Net_URL >= 1.0.12 Requires: php-pear-Net_Socket >= 1.0.7 Provides: php-pear-%{pear_name} pear-%{pear_name} # Fix for renaming (package convention) Provides: php5-pear-%{pear_sname} = %{version} Provides: php-pear-%{pear_sname} = %{version} Provides: pear-%{pear_sname} = %{version} Obsoletes: php5-pear-%{pear_sname} < %{version} Obsoletes: php-pear-%{pear_sname} < %{version} Obsoletes: pear-%{pear_sname} < %{version} %description Supports GET/POST/HEAD/TRACE/PUT/DELETE, Basic authentication, Proxy, Proxy Authentication, SSL, file uploads etc. %prep %setup -c %build %install %{__mv} package*.xml %{pear_name}-%{version} cd %{pear_name}-%{version} PHP_PEAR_PHP_BIN="$(which php) -d memory_limit=50m" %{__pear} -v \ -d doc_dir=/doc \ -d bin_dir=%{_bindir} \ -d data_dir=%{php_peardir}/data \ install --offline --nodeps -R "%{buildroot}" package.xml %{__install} -D -m 0644 package.xml %{buildroot}%{php_pearxmldir}/%{pear_name}.xml %{__rm} -rf %{buildroot}/{doc,tmp} %{__rm} -rf %{buildroot}%{php_peardir}/.{filemap,lock,registry,channels,depdb,depdblock} # This should actually be performed in the build sections. But if it # is done the pear installer fails, because the md5sum of the files are not # as expected. %{__perl} -p -i -e 's|\r\n|\n|' docs/download-progress.php %{__perl} -p -i -e 's|\r\n|\n|' docs/example.php cd .. %php_pear_gen_filelist %post # on `rpm -ivh` PARAM is 1 # on `rpm -Uvh` PARAM is 2 if [ "$1" = "1" ]; then %{__pear} install --nodeps --soft --force --register-only %{php_pearxmldir}/%{pear_name}.xml fi if [ "$1" = "2" ]; then %{__pear} upgrade --offline --register-only %{php_pearxmldir}/%{pear_name}.xml fi %postun # on `rpm -e` PARAM is 0 if [ "$1" = "0" ]; then %{__pear} uninstall --nodeps --ignore-errors --register-only pear.php.net/%{pear_name} fi %clean %{__rm} -rf %{buildroot} %files -f %{name}.files %defattr(-, root, root) %doc %{pear_name}-%{version}/docs/* %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor