Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:lafenghu
python-grequests
python-grequests.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File python-grequests.spec of Package python-grequests
# # spec file for package python-grequests # # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ Name: python-grequests Version: 0.1.0 Release: 0 License: BSD-2-Clause Summary: Requests + Gevent Url: https://github.com/kennethreitz/grequests Group: Development/Languages/Python Source: http://pypi.python.org/packages/source/g/grequests/grequests-%{version}.tar.gz Source1: LICENSE BuildRequires: python-devel BuildRequires: python-distribute Requires: python-gevent BuildRoot: %{_tmppath}/%{name}-%{version}-build %if 0%{?suse_version} && 0%{?suse_version} <= 1110 %{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} %else BuildArch: noarch %endif %description GRequests allows you to use Requests with Gevent to make asyncronous HTTP Requests easily. Usage ----- Usage is simple:: import grequests urls = [ 'http://www.heroku.com', 'http://tablib.org', 'http://httpbin.org', 'http://python-requests.org', 'http://kennethreitz.com' ] Create a set of unsent Requests:: >>> rs = (grequests.get(u) for u in urls) Send them all at the same time:: >>> grequests.map(rs) [<Response [200]>, <Response [200]>, <Response [200]>, <Response [200]>, <Response [200]>] %prep %setup -q -n grequests-%{version} cp %{SOURCE1} . %build python setup.py build %install python setup.py install --prefix=%{_prefix} --root=%{buildroot} %files %defattr(-,root,root,-) %doc README LICENSE %{python_sitelib}/* %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor