Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:rhabacker:branches:windows:mingw:win32:KF565
mingw32-kconfig
kconfig.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File kconfig.spec of Package mingw32-kconfig
# # spec file for package mingw32-kconfig # # Copyright (c) 2019 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # %define sonum 5 %define _tar_path 5.65 # Full KF5 version (e.g. 5.33.0) %{!?_mingw32_kf5_version: %global _mingw32_kf5_version %{version}} # Last major and minor KF5 version (e.g. 5.33) %{!?_mingw32_kf5_bugfix_version: %define _mingw32_kf5_bugfix_version %(echo %{_mingw32_kf5_version} | awk -F. '{print $1"."$2}')} %bcond_without lang %define _name kconfig Name: mingw32-%{_name} Version: 5.65.0 Release: 0 Summary: Advanced configuration system License: LGPL-2.1-or-later AND GPL-2.0-or-later Group: System/GUI/KDE URL: https://www.kde.org Source: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz %if %{with lang} Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz.sig Source2: frameworks.keyring %endif # PATCH-FEATURE-OPENSUSE Patch0: kconfig-desktop-translations.patch Patch1: 0001-Add-cross-compile-support-for-kconfig_compiler-and-k.patch Patch2: 0002-Add-5-postfix-to-target-kconf_update-to-avoid-name-c.patch BuildRequires: cmake >= 3.5 BuildRequires: mingw32-cross-gcc-c++ BuildRequires: mingw32-extra-cmake-modules >= %{_mingw32_kf5_bugfix_version} BuildRequires: mingw32-kf5-filesystem BuildRequires: mingw32(cmake:Qt5Core) >= 5.11.0 BuildRequires: mingw32(cmake:Qt5DBus) >= 5.11.0 BuildRequires: mingw32(cmake:Qt5Gui) >= 5.11.0 BuildRequires: mingw32(cmake:Qt5Xml) >= 5.11.0 BuildRequires: mingw32(lib:intl) %if %{with lang} BuildRequires: mingw32(cmake:Qt5LinguistTools) >= 5.11.0 %endif %_mingw32_package_header_debug BuildArch: noarch %description KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. KConfigCore provides access to the configuration files themselves. It features: - centralized definition: define your configuration in an XML file and use `kconfig_compiler` to generate classes to read and write configuration entries. - lock-down (kiosk) support. KConfigGui provides a way to hook widgets to the configuration so that they are automatically initialized from the configuration and automatically propagate their changes to their respective configuration files. %package -n mingw32-libKF5ConfigCore%{sonum} Summary: System for configuration files Group: System/GUI/KDE %requires_ge mingw32-libQt5Core5 Recommends: mingw32-kconf_update5 = %{version} %if %{with lang} Recommends: mingw32-libKF5ConfigCore%{sonum}-lang = %{version} %endif %description -n mingw32-libKF5ConfigCore%{sonum} KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. KConfigCore provides access to the configuration files themselves. %package -n mingw32-libKF5ConfigGui%{sonum} Summary: Widgets hooks for configuration entities Group: System/GUI/KDE %requires_ge mingw32-libKF5ConfigCore5 %requires_ge mingw32-libQt5Core5 %requires_ge mingw32-libQt5Gui5 %requires_ge mingw32-libQt5Xml5 %description -n mingw32-libKF5ConfigGui%{sonum} KConfigGui provides a way to hook widgets to the configuration so that they are automatically initialized from the configuration and automatically propagate their changes to their respective configuration files. %package -n mingw32-kconf_update5 Summary: Configuration file access Group: System/GUI/KDE Requires: mingw32-libKF5ConfigCore%{sonum} = %{version} %description -n mingw32-kconf_update5 KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. This package contains the kconf_update tool. %package devel Summary: KConfig Development files Group: Development/Libraries/KDE Requires: mingw32-extra-cmake-modules Requires: mingw32-kconf_update5 = %{version} Requires: mingw32-libKF5ConfigCore%{sonum} = %{version} Requires: mingw32-libKF5ConfigGui%{sonum} = %{version} Requires: mingw32(cmake:Qt5Xml) >= 5.11.0 Requires: mingw32-cross-kf5-tools %description devel KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. KConfigCore provides access to the configuration files themselves. It features: - centralized definition: define your configuration in an XML file and use `kconfig_compiler` to generate classes to read and write configuration entries. - lock-down (kiosk) support. KConfigGui provides a way to hook widgets to the configuration so that they are automatically initialized from the configuration and automatically propagate their changes to their respective configuration files. Development files. %lang_package -n mingw32-libKF5ConfigCore%{sonum} %_mingw32_debug_package %prep %autosetup -p1 -n %{_name}-%{version} %build %_mingw32_cmake_kf5 -d build -- -DKDEWIN_LIBRARIES=intl %make_jobs %install %_mingw32_kf5_makeinstall -C build %if %{with lang} %_mingw32_find_lang %{_name}5 --with-qt --without-mo %endif %if %{with lang} %files -n mingw32-libKF5ConfigCore%{sonum}-lang -f %{_name}5.lang %endif %files -n mingw32-libKF5ConfigCore%{sonum} %license COPYING* %doc README* %{_mingw32_kf5_bindir}/k*config5.exe %{_mingw32_kf5_bindir}/libKF5ConfigCore*.dll %{_mingw32_kf5_debugdir}/kconfig.categories %files -n mingw32-libKF5ConfigGui%{sonum} %license COPYING* %doc README* %{_mingw32_kf5_bindir}/libKF5ConfigGui*.dll %files -n mingw32-kconf_update5 %license COPYING* %doc README* %dir %{_mingw32_kf5_libexecdir} %{_mingw32_kf5_libexecdir}/kconf_update5.exe %files devel %{_mingw32_kf5_libexecdir}/kconfig_compiler_kf5.exe %{_mingw32_kf5_libdir}/libKF5ConfigCore.dll.a %{_mingw32_kf5_libdir}/libKF5ConfigGui.dll.a %{_mingw32_kf5_libdir}/cmake/KF5Config/ %{_mingw32_kf5_includedir}/ %{_mingw32_kf5_mkspecsdir}/qt_KConfigCore.pri %{_mingw32_kf5_mkspecsdir}/qt_KConfigGui.pri %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor