Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:schaats
vmpk
vmpk.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File vmpk.spec of Package vmpk
# # spec file for package vmpk # # Copyright (c) 2021 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # Name: vmpk Version: 0.8.4 Release: 0 Summary: Virtual MIDI Piano Keyboard License: GPL-3.0-or-later Group: Productivity/Multimedia/Sound/Midi URL: https://vmpk.sourceforge.io/ Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2 BuildRequires: cmake BuildRequires: hicolor-icon-theme BuildRequires: pkgconfig BuildRequires: update-desktop-files BuildRequires: cmake(Qt5DBus) BuildRequires: cmake(Qt5LinguistTools) BuildRequires: cmake(Qt5Network) BuildRequires: cmake(Qt5Widgets) >= 5.12.0 BuildRequires: cmake(Qt5X11Extras) BuildRequires: cmake(drumstick-rt) >= 2.1 BuildRequires: cmake(drumstick-widgets) BuildRequires: pkgconfig(xcb) # Causes build issues when installed #!BuildIgnore: libxslt-tools %description VMPK is a MIDI event generator/receiver. It doesn't produce any sound by itself, but can be used to drive a MIDI synthesizer (either hardware or software, internal or external). You can use the computer's keyboard to play MIDI notes, and also the mouse. You can use the Virtual MIDI Piano Keyboard to display the played MIDI notes from another instrument or MIDI file player. %prep %setup -q %build %cmake %cmake_build %install %cmake_install %suse_update_desktop_file -G "Virtual MIDI Piano Keyboard" -r net.sourceforge.VMPK AudioVideo Midi Education Music %files %license COPYING %doc NEWS README.md ChangeLog AUTHORS %{_bindir}/vmpk %{_datadir}/applications/net.sourceforge.VMPK.desktop %{_datadir}/metainfo/net.sourceforge.VMPK.appdata.xml %{_datadir}/icons/hicolor/*/apps/vmpk.png %{_datadir}/icons/hicolor/scalable/apps/vmpk.svgz %{_datadir}/vmpk/ %{_mandir}/man1/%{name}.1%{?ext_man} %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor