File dtb-aarch64.spec of Package kernel-debug (Revision 88fb6b73fbc5877570aa8206082528f8)
Currently displaying revision 88fb6b73fbc5877570aa8206082528f8 , Show latest
869
1
#
2
# spec file for package dtb-aarch64
3
#
4
# Copyright (c) 2024 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define srcversion 6.11
20
%define patchversion 6.11.0
21
%define variant %{nil}
22
23
%include %_sourcedir/kernel-spec-macros
24
25
%(chmod +x %_sourcedir/{guards,apply-patches,check-for-config-changes,group-source-files.pl,split-modules,modversions,kabi.pl,mkspec,compute-PATCHVERSION.sh,arch-symbols,log.sh,try-disable-staging-driver,compress-vmlinux.sh,mkspec-dtb,check-module-license,klp-symbols,splitflist,mergedep,moddep,modflist,kernel-subpackage-build})
26
27
Name: dtb-aarch64
28
Version: 6.11.0
29
%if 0%{?is_kotd}
30
Release: <RELEASE>.gb87e886
31
%else
32
Release: 0
33
%endif
34
Summary: Device Tree files for $MACHINES
35
License: GPL-2.0-only
36
Group: System/Boot
37
URL: https://www.kernel.org/
38
BuildRequires: cpp
39
BuildRequires: dtc >= 1.4.3
40
BuildRequires: xz
41
%if ! 0%{?is_kotd} || ! %{?is_kotd_qa}%{!?is_kotd_qa:0}
42
ExclusiveArch: aarch64
43
%else
44
ExclusiveArch: do_not_build
45
%endif
46
47
%define dtbdir /boot/dtb-%kernelrelease
48
49
Source0: https://www.kernel.org/pub/linux/kernel/v6.x/linux-%srcversion.tar.xz
50
Source3: kernel-source.rpmlintrc
51
Source14: series.conf
52
Source16: guards
53
Source17: apply-patches
54
Source19: kernel-binary-conflicts
55
Source20: obsolete-kmps
56
Source21: config.conf
57
Source23: supported.conf
58
Source33: check-for-config-changes
59
Source35: group-source-files.pl
60
Source36: README.PATCH-POLICY.SUSE
61
Source37: README.SUSE
62
Source38: README.KSYMS
63
Source40: source-timestamp
64
Source46: split-modules
65
Source47: modversions
66
Source48: macros.kernel-source
67
Source49: kernel-module-subpackage
68
Source50: kabi.pl
69
Source51: mkspec
70
Source52: kernel-source%variant.changes
71
Source53: kernel-source.spec.in
72
Source54: kernel-binary.spec.in
73
Source55: kernel-syms.spec.in
74
Source56: kernel-docs.spec.in
75
Source57: kernel-cert-subpackage
76
Source58: constraints.in
77
Source60: config.sh
78
Source61: compute-PATCHVERSION.sh
79
Source62: old-flavors
80
Source63: arch-symbols
81
Source64: package-descriptions
82
Source65: kernel-spec-macros
83
Source67: log.sh
84
Source68: host-memcpy-hack.h
85
Source69: try-disable-staging-driver
86
Source70: kernel-obs-build.spec.in
87
Source71: kernel-obs-qa.spec.in
88
Source72: compress-vmlinux.sh
89
Source73: dtb.spec.in.in
90
Source74: mkspec-dtb
91
Source75: release-projects
92
Source76: check-module-license
93
Source77: klp-symbols
94
Source78: modules.fips
95
Source79: splitflist
96
Source80: mergedep
97
Source81: moddep
98
Source82: modflist
99
Source83: kernel-subpackage-build
100
Source84: kernel-subpackage-spec
101
Source85: kernel-default-base.spec.txt
102
Source86: old_changelog.txt
103
Source100: config.tar.bz2
104
Source101: config.addon.tar.bz2
105
Source102: patches.arch.tar.bz2
106
Source103: patches.drivers.tar.bz2
107
Source104: patches.fixes.tar.bz2
108
Source105: patches.rpmify.tar.bz2
109
Source106: patches.suse.tar.bz2
110
Source108: patches.addon.tar.bz2
111
Source109: patches.kernel.org.tar.bz2
112
Source110: patches.apparmor.tar.bz2
113
Source111: patches.rt.tar.bz2
114
Source113: patches.kabi.tar.bz2
115
Source114: patches.drm.tar.bz2
116
Source120: kabi.tar.bz2
117
Source121: sysctl.tar.bz2
118
# These files are found in the kernel-source package:
119
NoSource: 0
120
NoSource: 3
121
NoSource: 14
122
NoSource: 16
123
NoSource: 17
124
NoSource: 19
125
NoSource: 20
126
NoSource: 21
127
NoSource: 23
128
NoSource: 33
129
NoSource: 35
130
NoSource: 36
131
NoSource: 37
132
NoSource: 38
133
NoSource: 40
134
NoSource: 46
135
NoSource: 47
136
NoSource: 48
137
NoSource: 49
138
NoSource: 50
139
NoSource: 51
140
NoSource: 52
141
NoSource: 53
142
NoSource: 54
143
NoSource: 55
144
NoSource: 56
145
NoSource: 57
146
NoSource: 58
147
NoSource: 60
148
NoSource: 61
149
NoSource: 62
150
NoSource: 63
151
NoSource: 64
152
NoSource: 65
153
NoSource: 67
154
NoSource: 68
155
NoSource: 69
156
NoSource: 70
157
NoSource: 71
158
NoSource: 72
159
NoSource: 73
160
NoSource: 74
161
NoSource: 75
162
NoSource: 76
163
NoSource: 77
164
NoSource: 78
165
NoSource: 79
166
NoSource: 80
167
NoSource: 81
168
NoSource: 82
169
NoSource: 83
170
NoSource: 84
171
NoSource: 85
172
NoSource: 86
173
NoSource: 100
174
NoSource: 101
175
NoSource: 102
176
NoSource: 103
177
NoSource: 104
178
NoSource: 105
179
NoSource: 106
180
NoSource: 108
181
NoSource: 109
182
NoSource: 110
183
NoSource: 111
184
NoSource: 113
185
NoSource: 114
186
NoSource: 120
187
NoSource: 121
188
Requires: kernel = %version
189
190
%description
191
Device Tree files for $MACHINES.
192
193
%package -n dtb-allwinner
194
Summary: Allwinner based arm64 systems
195
Group: System/Boot
196
Provides: multiversion(dtb)
197
Requires(post): coreutils
198
199
%description -n dtb-allwinner
200
Device Tree files for Allwinner based arm64 systems.
201
202
%post -n dtb-allwinner
203
cd /boot
204
# If /boot/dtb is a symlink, remove it, so that we can replace it.
205
[ -d dtb ] && [ -L dtb ] && rm -f dtb
206
# Unless /boot/dtb exists as real directory, create a symlink.
207
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
208
209
%ifarch %arm aarch64 riscv64
210
%files -n dtb-allwinner -f dtb-allwinner.list
211
%else
212
%files -n dtb-allwinner
213
%endif
214
%defattr(-,root,root)
215
%ghost /boot/dtb
216
%dir %{dtbdir}
217
%dir %{dtbdir}/allwinner
218
%{dtbdir}/allwinner/*.dtb
219
220
%package -n dtb-altera
221
Summary: Altera based arm64 systems
222
Group: System/Boot
223
Provides: multiversion(dtb)
224
Requires(post): coreutils
225
226
%description -n dtb-altera
227
Device Tree files for Altera based arm64 systems.
228
229
%post -n dtb-altera
230
cd /boot
231
# If /boot/dtb is a symlink, remove it, so that we can replace it.
232
[ -d dtb ] && [ -L dtb ] && rm -f dtb
233
# Unless /boot/dtb exists as real directory, create a symlink.
234
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
235
236
%ifarch %arm aarch64 riscv64
237
%files -n dtb-altera -f dtb-altera.list
238
%else
239
%files -n dtb-altera
240
%endif
241
%defattr(-,root,root)
242
%ghost /boot/dtb
243
%dir %{dtbdir}
244
%dir %{dtbdir}/altera
245
%{dtbdir}/altera/*.dtb
246
247
%package -n dtb-amazon
248
Summary: Amazon based arm64 systems
249
Group: System/Boot
250
Provides: dtb-al = %version
251
Provides: multiversion(dtb)
252
Requires(post): coreutils
253
254
%description -n dtb-amazon
255
Device Tree files for Amazon based arm64 systems.
256
257
%post -n dtb-amazon
258
cd /boot
259
# If /boot/dtb is a symlink, remove it, so that we can replace it.
260
[ -d dtb ] && [ -L dtb ] && rm -f dtb
261
# Unless /boot/dtb exists as real directory, create a symlink.
262
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
263
264
%ifarch %arm aarch64 riscv64
265
%files -n dtb-amazon -f dtb-amazon.list
266
%else
267
%files -n dtb-amazon
268
%endif
269
%defattr(-,root,root)
270
%ghost /boot/dtb
271
%dir %{dtbdir}
272
%dir %{dtbdir}/amazon
273
%{dtbdir}/amazon/*.dtb
274
275
%package -n dtb-amd
276
Summary: AMD based arm64 systems
277
Group: System/Boot
278
Provides: multiversion(dtb)
279
Requires(post): coreutils
280
281
%description -n dtb-amd
282
Device Tree files for AMD based arm64 systems.
283
284
%post -n dtb-amd
285
cd /boot
286
# If /boot/dtb is a symlink, remove it, so that we can replace it.
287
[ -d dtb ] && [ -L dtb ] && rm -f dtb
288
# Unless /boot/dtb exists as real directory, create a symlink.
289
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
290
291
%ifarch %arm aarch64 riscv64
292
%files -n dtb-amd -f dtb-amd.list
293
%else
294
%files -n dtb-amd
295
%endif
296
%defattr(-,root,root)
297
%ghost /boot/dtb
298
%dir %{dtbdir}
299
%dir %{dtbdir}/amd
300
%{dtbdir}/amd/*.dtb
301
302
%package -n dtb-amlogic
303
Summary: Amlogic based arm64 systems
304
Group: System/Boot
305
Provides: multiversion(dtb)
306
Requires(post): coreutils
307
308
%description -n dtb-amlogic
309
Device Tree files for Amlogic based arm64 systems.
310
311
%post -n dtb-amlogic
312
cd /boot
313
# If /boot/dtb is a symlink, remove it, so that we can replace it.
314
[ -d dtb ] && [ -L dtb ] && rm -f dtb
315
# Unless /boot/dtb exists as real directory, create a symlink.
316
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
317
318
%ifarch %arm aarch64 riscv64
319
%files -n dtb-amlogic -f dtb-amlogic.list
320
%else
321
%files -n dtb-amlogic
322
%endif
323
%defattr(-,root,root)
324
%ghost /boot/dtb
325
%dir %{dtbdir}
326
%dir %{dtbdir}/amlogic
327
%{dtbdir}/amlogic/*.dtb
328
329
%package -n dtb-apm
330
Summary: AppliedMicro based arm64 systems
331
Group: System/Boot
332
Provides: dtb-apm-mustang = %version
333
Provides: multiversion(dtb)
334
Requires(post): coreutils
335
336
%description -n dtb-apm
337
Device Tree files for AppliedMicro based arm64 systems.
338
339
%post -n dtb-apm
340
cd /boot
341
# If /boot/dtb is a symlink, remove it, so that we can replace it.
342
[ -d dtb ] && [ -L dtb ] && rm -f dtb
343
# Unless /boot/dtb exists as real directory, create a symlink.
344
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
345
346
%ifarch %arm aarch64 riscv64
347
%files -n dtb-apm -f dtb-apm.list
348
%else
349
%files -n dtb-apm
350
%endif
351
%defattr(-,root,root)
352
%ghost /boot/dtb
353
%dir %{dtbdir}
354
%dir %{dtbdir}/apm
355
%{dtbdir}/apm/*.dtb
356
357
%package -n dtb-apple
358
Summary: Apple SOC based arm64 systems
359
Group: System/Boot
360
Provides: multiversion(dtb)
361
Requires(post): coreutils
362
363
%description -n dtb-apple
364
Device Tree files for Apple SOC based arm64 systems.
365
366
%post -n dtb-apple
367
cd /boot
368
# If /boot/dtb is a symlink, remove it, so that we can replace it.
369
[ -d dtb ] && [ -L dtb ] && rm -f dtb
370
# Unless /boot/dtb exists as real directory, create a symlink.
371
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
372
373
%ifarch %arm aarch64 riscv64
374
%files -n dtb-apple -f dtb-apple.list
375
%else
376
%files -n dtb-apple
377
%endif
378
%defattr(-,root,root)
379
%ghost /boot/dtb
380
%dir %{dtbdir}
381
%dir %{dtbdir}/apple
382
%{dtbdir}/apple/*.dtb
383
384
%package -n dtb-arm
385
Summary: ARM Ltd. based arm64 systems
386
Group: System/Boot
387
Provides: dtb-foundation-v8 = %version
388
Provides: dtb-rtsm_ve-aemv8a = %version
389
Provides: multiversion(dtb)
390
Requires(post): coreutils
391
392
%description -n dtb-arm
393
Device Tree files for ARM Ltd. based arm64 systems.
394
395
%post -n dtb-arm
396
cd /boot
397
# If /boot/dtb is a symlink, remove it, so that we can replace it.
398
[ -d dtb ] && [ -L dtb ] && rm -f dtb
399
# Unless /boot/dtb exists as real directory, create a symlink.
400
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
401
402
%ifarch %arm aarch64 riscv64
403
%files -n dtb-arm -f dtb-arm.list
404
%else
405
%files -n dtb-arm
406
%endif
407
%defattr(-,root,root)
408
%ghost /boot/dtb
409
%dir %{dtbdir}
410
%dir %{dtbdir}/arm
411
%{dtbdir}/arm/*.dtb
412
413
%package -n dtb-broadcom
414
Summary: Broadcom based arm64 systems
415
Group: System/Boot
416
Provides: multiversion(dtb)
417
Requires(post): coreutils
418
419
%description -n dtb-broadcom
420
Device Tree files for Broadcom based arm64 systems.
421
422
%post -n dtb-broadcom
423
cd /boot
424
# If /boot/dtb is a symlink, remove it, so that we can replace it.
425
[ -d dtb ] && [ -L dtb ] && rm -f dtb
426
# Unless /boot/dtb exists as real directory, create a symlink.
427
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
428
429
%ifarch %arm aarch64 riscv64
430
%files -n dtb-broadcom -f dtb-broadcom.list
431
%else
432
%files -n dtb-broadcom
433
%endif
434
%defattr(-,root,root)
435
%ghost /boot/dtb
436
%dir %{dtbdir}
437
%dir %{dtbdir}/broadcom
438
%{dtbdir}/broadcom/*.dtb
439
440
%package -n dtb-cavium
441
Summary: Cavium based arm64 systems
442
Group: System/Boot
443
Provides: dtb-thunder-88xx = %version
444
Provides: multiversion(dtb)
445
Requires(post): coreutils
446
447
%description -n dtb-cavium
448
Device Tree files for Cavium based arm64 systems.
449
450
%post -n dtb-cavium
451
cd /boot
452
# If /boot/dtb is a symlink, remove it, so that we can replace it.
453
[ -d dtb ] && [ -L dtb ] && rm -f dtb
454
# Unless /boot/dtb exists as real directory, create a symlink.
455
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
456
457
%ifarch %arm aarch64 riscv64
458
%files -n dtb-cavium -f dtb-cavium.list
459
%else
460
%files -n dtb-cavium
461
%endif
462
%defattr(-,root,root)
463
%ghost /boot/dtb
464
%dir %{dtbdir}
465
%dir %{dtbdir}/cavium
466
%{dtbdir}/cavium/*.dtb
467
468
%package -n dtb-exynos
469
Summary: Samsung Exynos based arm64 systems
470
Group: System/Boot
471
Provides: multiversion(dtb)
472
Requires(post): coreutils
473
474
%description -n dtb-exynos
475
Device Tree files for Samsung Exynos based arm64 systems.
476
477
%post -n dtb-exynos
478
cd /boot
479
# If /boot/dtb is a symlink, remove it, so that we can replace it.
480
[ -d dtb ] && [ -L dtb ] && rm -f dtb
481
# Unless /boot/dtb exists as real directory, create a symlink.
482
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
483
484
%ifarch %arm aarch64 riscv64
485
%files -n dtb-exynos -f dtb-exynos.list
486
%else
487
%files -n dtb-exynos
488
%endif
489
%defattr(-,root,root)
490
%ghost /boot/dtb
491
%dir %{dtbdir}
492
%dir %{dtbdir}/exynos
493
%{dtbdir}/exynos/*.dtb
494
495
%package -n dtb-freescale
496
Summary: NXP (Freescale) based arm64 systems
497
Group: System/Boot
498
Provides: multiversion(dtb)
499
Requires(post): coreutils
500
501
%description -n dtb-freescale
502
Device Tree files for NXP (Freescale) based arm64 systems.
503
504
%post -n dtb-freescale
505
cd /boot
506
# If /boot/dtb is a symlink, remove it, so that we can replace it.
507
[ -d dtb ] && [ -L dtb ] && rm -f dtb
508
# Unless /boot/dtb exists as real directory, create a symlink.
509
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
510
511
%ifarch %arm aarch64 riscv64
512
%files -n dtb-freescale -f dtb-freescale.list
513
%else
514
%files -n dtb-freescale
515
%endif
516
%defattr(-,root,root)
517
%ghost /boot/dtb
518
%dir %{dtbdir}
519
%dir %{dtbdir}/freescale
520
%{dtbdir}/freescale/*.dtb
521
522
%package -n dtb-hisilicon
523
Summary: HiSilicon based arm64 systems
524
Group: System/Boot
525
Provides: dtb-hisilicon64 = %version
526
Provides: multiversion(dtb)
527
Requires(post): coreutils
528
529
%description -n dtb-hisilicon
530
Device Tree files for HiSilicon based arm64 systems.
531
532
%post -n dtb-hisilicon
533
cd /boot
534
# If /boot/dtb is a symlink, remove it, so that we can replace it.
535
[ -d dtb ] && [ -L dtb ] && rm -f dtb
536
# Unless /boot/dtb exists as real directory, create a symlink.
537
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
538
539
%ifarch %arm aarch64 riscv64
540
%files -n dtb-hisilicon -f dtb-hisilicon.list
541
%else
542
%files -n dtb-hisilicon
543
%endif
544
%defattr(-,root,root)
545
%ghost /boot/dtb
546
%dir %{dtbdir}
547
%dir %{dtbdir}/hisilicon
548
%{dtbdir}/hisilicon/*.dtb
549
550
%package -n dtb-lg
551
Summary: LG based arm64 systems
552
Group: System/Boot
553
Provides: multiversion(dtb)
554
Requires(post): coreutils
555
556
%description -n dtb-lg
557
Device Tree files for LG based arm64 systems.
558
559
%post -n dtb-lg
560
cd /boot
561
# If /boot/dtb is a symlink, remove it, so that we can replace it.
562
[ -d dtb ] && [ -L dtb ] && rm -f dtb
563
# Unless /boot/dtb exists as real directory, create a symlink.
564
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
565
566
%ifarch %arm aarch64 riscv64
567
%files -n dtb-lg -f dtb-lg.list
568
%else
569
%files -n dtb-lg
570
%endif
571
%defattr(-,root,root)
572
%ghost /boot/dtb
573
%dir %{dtbdir}
574
%dir %{dtbdir}/lg
575
%{dtbdir}/lg/*.dtb
576
577
%package -n dtb-marvell
578
Summary: Marvell based arm64 systems
579
Group: System/Boot
580
Provides: multiversion(dtb)
581
Requires(post): coreutils
582
583
%description -n dtb-marvell
584
Device Tree files for Marvell based arm64 systems.
585
586
%post -n dtb-marvell
587
cd /boot
588
# If /boot/dtb is a symlink, remove it, so that we can replace it.
589
[ -d dtb ] && [ -L dtb ] && rm -f dtb
590
# Unless /boot/dtb exists as real directory, create a symlink.
591
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
592
593
%ifarch %arm aarch64 riscv64
594
%files -n dtb-marvell -f dtb-marvell.list
595
%else
596
%files -n dtb-marvell
597
%endif
598
%defattr(-,root,root)
599
%ghost /boot/dtb
600
%dir %{dtbdir}
601
%dir %{dtbdir}/marvell
602
%{dtbdir}/marvell/*.dtb
603
604
%package -n dtb-mediatek
605
Summary: MediaTek based arm64 systems
606
Group: System/Boot
607
Provides: multiversion(dtb)
608
Requires(post): coreutils
609
610
%description -n dtb-mediatek
611
Device Tree files for MediaTek based arm64 systems.
612
613
%post -n dtb-mediatek
614
cd /boot
615
# If /boot/dtb is a symlink, remove it, so that we can replace it.
616
[ -d dtb ] && [ -L dtb ] && rm -f dtb
617
# Unless /boot/dtb exists as real directory, create a symlink.
618
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
619
620
%ifarch %arm aarch64 riscv64
621
%files -n dtb-mediatek -f dtb-mediatek.list
622
%else
623
%files -n dtb-mediatek
624
%endif
625
%defattr(-,root,root)
626
%ghost /boot/dtb
627
%dir %{dtbdir}
628
%dir %{dtbdir}/mediatek
629
%{dtbdir}/mediatek/*.dtb
630
631
%package -n dtb-nvidia
632
Summary: Nvidia based arm64 systems
633
Group: System/Boot
634
Provides: multiversion(dtb)
635
Requires(post): coreutils
636
637
%description -n dtb-nvidia
638
Device Tree files for Nvidia based arm64 systems.
639
640
%post -n dtb-nvidia
641
cd /boot
642
# If /boot/dtb is a symlink, remove it, so that we can replace it.
643
[ -d dtb ] && [ -L dtb ] && rm -f dtb
644
# Unless /boot/dtb exists as real directory, create a symlink.
645
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
646
647
%ifarch %arm aarch64 riscv64
648
%files -n dtb-nvidia -f dtb-nvidia.list
649
%else
650
%files -n dtb-nvidia
651
%endif
652
%defattr(-,root,root)
653
%ghost /boot/dtb
654
%dir %{dtbdir}
655
%dir %{dtbdir}/nvidia
656
%{dtbdir}/nvidia/*.dtb
657
658
%package -n dtb-qcom
659
Summary: Qualcomm based arm64 systems
660
Group: System/Boot
661
Provides: multiversion(dtb)
662
Requires(post): coreutils
663
664
%description -n dtb-qcom
665
Device Tree files for Qualcomm based arm64 systems.
666
667
%post -n dtb-qcom
668
cd /boot
669
# If /boot/dtb is a symlink, remove it, so that we can replace it.
670
[ -d dtb ] && [ -L dtb ] && rm -f dtb
671
# Unless /boot/dtb exists as real directory, create a symlink.
672
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
673
674
%ifarch %arm aarch64 riscv64
675
%files -n dtb-qcom -f dtb-qcom.list
676
%else
677
%files -n dtb-qcom
678
%endif
679
%defattr(-,root,root)
680
%ghost /boot/dtb
681
%dir %{dtbdir}
682
%dir %{dtbdir}/qcom
683
%{dtbdir}/qcom/*.dtb
684
685
%package -n dtb-renesas
686
Summary: Renesas based arm64 systems
687
Group: System/Boot
688
Provides: multiversion(dtb)
689
Requires(post): coreutils
690
691
%description -n dtb-renesas
692
Device Tree files for Renesas based arm64 systems.
693
694
%post -n dtb-renesas
695
cd /boot
696
# If /boot/dtb is a symlink, remove it, so that we can replace it.
697
[ -d dtb ] && [ -L dtb ] && rm -f dtb
698
# Unless /boot/dtb exists as real directory, create a symlink.
699
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
700
701
%ifarch %arm aarch64 riscv64
702
%files -n dtb-renesas -f dtb-renesas.list
703
%else
704
%files -n dtb-renesas
705
%endif
706
%defattr(-,root,root)
707
%ghost /boot/dtb
708
%dir %{dtbdir}
709
%dir %{dtbdir}/renesas
710
%{dtbdir}/renesas/*.dtb
711
712
%package -n dtb-rockchip
713
Summary: Rockchip based arm64 systems
714
Group: System/Boot
715
Provides: multiversion(dtb)
716
Requires(post): coreutils
717
718
%description -n dtb-rockchip
719
Device Tree files for Rockchip based arm64 systems.
720
721
%post -n dtb-rockchip
722
cd /boot
723
# If /boot/dtb is a symlink, remove it, so that we can replace it.
724
[ -d dtb ] && [ -L dtb ] && rm -f dtb
725
# Unless /boot/dtb exists as real directory, create a symlink.
726
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
727
728
%ifarch %arm aarch64 riscv64
729
%files -n dtb-rockchip -f dtb-rockchip.list
730
%else
731
%files -n dtb-rockchip
732
%endif
733
%defattr(-,root,root)
734
%ghost /boot/dtb
735
%dir %{dtbdir}
736
%dir %{dtbdir}/rockchip
737
%{dtbdir}/rockchip/*.dtb
738
739
%package -n dtb-socionext
740
Summary: Socionext based arm64 systems
741
Group: System/Boot
742
Provides: multiversion(dtb)
743
Requires(post): coreutils
744
745
%description -n dtb-socionext
746
Device Tree files for Socionext based arm64 systems.
747
748
%post -n dtb-socionext
749
cd /boot
750
# If /boot/dtb is a symlink, remove it, so that we can replace it.
751
[ -d dtb ] && [ -L dtb ] && rm -f dtb
752
# Unless /boot/dtb exists as real directory, create a symlink.
753
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
754
755
%ifarch %arm aarch64 riscv64
756
%files -n dtb-socionext -f dtb-socionext.list
757
%else
758
%files -n dtb-socionext
759
%endif
760
%defattr(-,root,root)
761
%ghost /boot/dtb
762
%dir %{dtbdir}
763
%dir %{dtbdir}/socionext
764
%{dtbdir}/socionext/*.dtb
765
766
%package -n dtb-sprd
767
Summary: Spreadtrum based arm64 systems
768
Group: System/Boot
769
Provides: multiversion(dtb)
770
Requires(post): coreutils
771
772
%description -n dtb-sprd
773
Device Tree files for Spreadtrum based arm64 systems.
774
775
%post -n dtb-sprd
776
cd /boot
777
# If /boot/dtb is a symlink, remove it, so that we can replace it.
778
[ -d dtb ] && [ -L dtb ] && rm -f dtb
779
# Unless /boot/dtb exists as real directory, create a symlink.
780
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
781
782
%ifarch %arm aarch64 riscv64
783
%files -n dtb-sprd -f dtb-sprd.list
784
%else
785
%files -n dtb-sprd
786
%endif
787
%defattr(-,root,root)
788
%ghost /boot/dtb
789
%dir %{dtbdir}
790
%dir %{dtbdir}/sprd
791
%{dtbdir}/sprd/*.dtb
792
793
%package -n dtb-xilinx
794
Summary: Xilinx based arm64 systems
795
Group: System/Boot
796
Provides: multiversion(dtb)
797
Requires(post): coreutils
798
799
%description -n dtb-xilinx
800
Device Tree files for Xilinx based arm64 systems.
801
802
%post -n dtb-xilinx
803
cd /boot
804
# If /boot/dtb is a symlink, remove it, so that we can replace it.
805
[ -d dtb ] && [ -L dtb ] && rm -f dtb
806
# Unless /boot/dtb exists as real directory, create a symlink.
807
[ -d dtb ] || ln -sf dtb-%kernelrelease dtb
808
809
%ifarch %arm aarch64 riscv64
810
%files -n dtb-xilinx -f dtb-xilinx.list
811
%else
812
%files -n dtb-xilinx
813
%endif
814
%defattr(-,root,root)
815
%ghost /boot/dtb
816
%dir %{dtbdir}
817
%dir %{dtbdir}/xilinx
818
%{dtbdir}/xilinx/*.dtb
819
820
821
822
%prep
823
# Unpack all sources and patches
824
%setup -q -c -T -a 0 -a 100 -a 101 -a 102 -a 103 -a 104 -a 105 -a 106 -a 108 -a 109 -a 110 -a 111 -a 113 -a 114 -a 120 -a 121
825
cd linux-%srcversion
826
%_sourcedir/apply-patches %_sourcedir/series.conf ..
827
828
%build
829
source=linux-%srcversion
830
cp $source/COPYING .
831
SRCDIR=$PWD/$source
832
mkdir pp
833
PPDIR=$PWD/pp
834
export DTC_FLAGS="-R 4 -p 0x1000"
835
DTC_FLAGS="$DTC_FLAGS -@"
836
837
cd $source/arch/arm64/boot/dts
838
for dts in allwinner/*.dts altera/*.dts amazon/*.dts amd/*.dts amlogic/*.dts apm/*.dts apple/*.dts arm/*.dts broadcom/*.dts cavium/*.dts exynos/*.dts freescale/*.dts hisilicon/*.dts lg/*.dts marvell/*.dts mediatek/*.dts nvidia/*.dts qcom/*.dts renesas/*.dts rockchip/*.dts socionext/*.dts sprd/*.dts xilinx/*.dts ; do
839
target=${dts%*.dts}
840
mkdir -p $PPDIR/$(dirname $target)
841
cpp -x assembler-with-cpp -undef -D__DTS__ -nostdinc -I. -I$SRCDIR/include/ -I$SRCDIR/scripts/dtc/include-prefixes/ -P $target.dts -o $PPDIR/$target.dts
842
dtc $DTC_FLAGS -I dts -O dtb -i ./$(dirname $target) -o $PPDIR/$target.dtb $PPDIR/$target.dts
843
done
844
845
%install
846
cd pp
847
for dts in allwinner/*.dts altera/*.dts amazon/*.dts amd/*.dts amlogic/*.dts apm/*.dts apple/*.dts arm/*.dts broadcom/*.dts cavium/*.dts exynos/*.dts freescale/*.dts hisilicon/*.dts lg/*.dts marvell/*.dts mediatek/*.dts nvidia/*.dts qcom/*.dts renesas/*.dts rockchip/*.dts socionext/*.dts sprd/*.dts xilinx/*.dts ; do
848
target=${dts%*.dts}
849
install -m 755 -d %{buildroot}%{dtbdir}/$(dirname $target)
850
# install -m 644 COPYING %{buildroot}%{dtbdir}/$(dirname $target)
851
install -m 644 $target.dtb %{buildroot}%{dtbdir}/$(dirname $target)
852
%ifarch %arm aarch64 riscv64
853
# HACK: work around U-Boot ignoring vendor dir
854
baselink=%{dtbdir}/$(basename $target).dtb
855
ln -s $target.dtb %{buildroot}$baselink
856
%ifarch %arm
857
case $dts in
858
esac
859
echo $baselink >> ../$pkgname.list
860
%else
861
vendordir=$(basename $(dirname $target))
862
echo $baselink >> ../dtb-$vendordir.list
863
%endif
864
%endif
865
done
866
cd -
867
868
%changelog
869