Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:thomas-schraitle
storybook
storybook.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File storybook.spec of Package storybook
# # spec file for package storybook # # Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany. # This file and all modifications and additions to the pristine # package are under the same license as the package itself. # # Please submit bugfixes or comments via http://bugs.opensuse.org/ # Name: storybook License: GPL3 Vendor: Intertec Group: Productivity/Publishing/ Summary: Story Writing Software for Novelists, Authors and Creative Writers Version: 2.1.12 Release: 13 URL: http://storybook.intertec.ch Source0: %{name}-%{version}_src.tar.bz2 Source1: %{name}.sh.in Source2: Demo.index.db Source3: Demo.data.db Source4: README_SUSE Source5: %{name}-rpmlintrc Source6: %{name}-configuration.xml Source7: log4j.xml Source8: log4j.dtd # Source20: %{name}.png Source21: %{name}.desktop # Patch0: %{name}-FontChooser.java.diff Patch1: %{name}-build.xml.diff # BuildArchitectures: noarch BuildRoot: %{_tmppath}/%{name}-%{version}-build # Needed 1.6 as it NOT works with lower Java version BuildRequires: java-devel >= 1.6 %if 0%{?suse_version} BuildRequires: update-desktop-files %endif BuildRequires: unzip bzip2 ant dos2unix BuildRequires: jpackage-utils log4j BuildRequires: jakarta-commons-logging jakarta-commons-beanutils BuildRequires: jakarta-commons-collections BuildRequires: jakarta-commons-digester jakarta-commons-lang BuildRequires: jakarta-commons-io #BuildRequires: itext tinylaf # BuildRequires: jdic Requires: java >= 1.6 Requires: jakarta-commons-logging jakarta-commons-beanutils Requires: jakarta-commons-collections Requires: jakarta-commons-digester jakarta-commons-lang Requires: jakarta-commons-io log4j #Requires: itext tinylaf # Requires: jdic %description StorYBook is a free, open source story writing software for creative writers, novelists and authors that helps to keep the overview over the strands when writing a book, a novel or a story. StorYBook assists you in structuring your book. Have all your data in one place. With StorYBook you can manage chapters, scenes, characters and locations and assign them to the related scenes. Authors -------- Martin Mustun Daniel Wall Werner Keil %define SB_HOME %{_datadir}/%{name} %prep %setup -q %patch0 %patch1 %{__cat} %{S:1} | sed s=@SB_HOME@=%{SB_HOME}= > %{name} %{__cp} %{S:2} %{S:3} %{S:4} %{S:5} %{S:6} %{S:7} %{S:8} . # %{__cp} %{S:20} %{S:21} . # Remove these files: [ -e lib/storybook.jar ] && %{__rm} lib/storybook.jar [ -e lib/attesoro.bat ] && %{__rm} lib/attesoro.bat %{__rm} -rf lib/windows lib/jdic/lib/windows %build %{ant} -Dant.build.javac.source=1.6 \ -Dant.build.javac.target=1.6 \ jar %{__rm} -rf lib/jdic/ lib/sunos/ pushd lib for i in commons-beanutils-*.jar \ commons-io-*.jar \ commons-lang-*.jar \ commons-logging-*.jar \ commons-collections-*.jar \ commons-digester-*.jar \ log4j-*.jar ; do # iText*.jar tinylaf; # commons-javaflow-*.jar commons-lang-*.jar # iText-*.jar jasperreports-*.jar jcalendar-*.jar # jcommon-*.jar jfreechart-*.jar miglayout-*-swing.jar # substance.jar testng-jdk15.jar tinylaf.jar toniclf.jar [ -e "$i" ] && %{__rm} $i done popd # Relink the above from our own packages: build-jar-repository --soft -p lib \ commons-beanutils \ commons-logging \ log4j \ jakarta-commons-collections \ jakarta-commons-digester \ jakarta-commons-io \ jakarta-commons-lang \ jakarta-commons-logging # tinylaf iText \ ## Check for unlinked jar files: JARfiles="" for j in $(find -name \*.jar); do if [ ! -L $j ] ; then JARfiles="$JARfiles $j" fi done if [ ! -z "$JARfiles" ] ; then echo "These JAR files should be deleted and symlinked to system JAR files: $JARfiles" # exit 1 fi # Correct manifest file for storybook.jar # using the following procedure: # 1. Build the "Class-Path" for the manifest file # 2. Extract the just built storybook.jar file # and remove the META-INF directory # 3. Build the new storybook.jar #pushd lib # Sort the jars #build-classpath-directory . | tr : '\n' | sed 's#\./##g' > tmp # Process each jar file and insert one or two spaces in front of # the filename to avoid "line too long" error from jar: #echo "Class-Path: $jars" > ../manifest #for j in $(sort tmp); do # echo " $j" >> ../manifest #done #jar uvfm storybook.jar ../manifest #popd %install # %{__rm} -rf $RPM_BUILD_ROOT #%{__mkdir} %buildroot %{__mkdir_p} $RPM_BUILD_ROOT%{SB_HOME}/projects %{__mkdir_p} $RPM_BUILD_ROOT%{_prefix}/bin %{__install} -m 755 %{name} $RPM_BUILD_ROOT%{_prefix}/bin/%{name} %{__cp} -a dict reports resources lib $RPM_BUILD_ROOT%{SB_HOME} #%{__cp} -a reports/* $RPM_BUILD_ROOT%{SB_HOME}/reports %{__install} -m 644 Demo*.db README_SUSE \ $RPM_BUILD_ROOT%{SB_HOME}/projects %{__install} -m 644 %{name}-configuration.xml \ $RPM_BUILD_ROOT%{SB_HOME}/configuration.xml %{__install} -m 644 log4j.* $RPM_BUILD_ROOT%{SB_HOME} ## build-jar-repository --soft \ -p $RPM_BUILD_ROOT%{SB_HOME}/lib \ commons-logging log4j commons-beanutils \ jakarta-commons-collections \ jakarta-commons-logging ## %if 0%{?suse_version} %suse_update_desktop_file -i -n storybook Office Viewer Literature %else %{__install} -d $RPM_BUILD_ROOT%{_datadir}/{pixmaps,applications} %{__install} -m 644 %{name}.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png %{__install} -m 644 %{name}.desktop $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop %endif # Correct DOS line endings for i in README.txt LICENSE.txt; do dos2unix $i done # Install all known JAR files: #pushd . #cd lib #for i in *.jar ; do #%{__install} -m 644 $i $RPM_BUILD_ROOT%{SB_HOME}/lib #done #popd ## <HINT> ## This doesn't seem to work: ## #pushd . #cd lib #for i in commons-javaflow-*.jar \ # jasperreports*.jar jcalendar*.jar jortho*.jar \ # miglayout-*-swing.jar \ # h2*.jar itext-*.jar \ # storybook.jar substance.jar \ # testng-jdk15.jar toniclf.jar tinylaf*.jar; \ #do #%{__install} -m 644 $i $RPM_BUILD_ROOT%{SB_HOME}/lib #done #popd # Link with required libraries: #pushd . #cd $RPM_BUILD_ROOT%{SB_HOME}/lib #for i in commons-beanutils.jar commons-collections.jar \ # commons-digester.jar commons-lang.jar \ # commons-logging.jar log4j.jar ; #do ## [ -e %{_javadir}/$i ] && #%{__ln_s} %{_javadir}/$i . #done #popd ## </HINT> export NO_BRP_CHECK_BYTECODE_VERSION=true %post %if 0%{?fedora_version} desktop-file-install --delete-original %{_datadir}/applications/%{name}.desktop touch --no-create %{_datadir}/icons/hicolor &>/dev/null || : %endif %postun %if 0%{?fedora_version} if [ $1 -eq 0 ] ; then touch --no-create %{_datadir}/icons/hicolor &>/dev/null gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || : fi %endif %clean %{__rm} -rf $RPM_BUILD_ROOT %files %defattr(-, root, root) %doc INSTALL.txt LICENSE.txt README.txt %dir %{SB_HOME} %{SB_HOME}/* %{_prefix}/bin/%{name} %{_datadir}/applications/%{name}.desktop %{_datadir}/pixmaps/%{name}.png
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor