Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:vlj:fedora14:maven2
plexus-classworlds
plexus-classworlds.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File plexus-classworlds.spec of Package plexus-classworlds
# Copyright (c) 2000-2007, JPackage Project # All rights reserved. # # Redistribution and use in source and binary forms, with or without # modification, are permitted provided that the following conditions # are met: # # 1. Redistributions of source code must retain the above copyright # notice, this list of conditions and the following disclaimer. # 2. Redistributions in binary form must reproduce the above copyright # notice, this list of conditions and the following disclaimer in the # documentation and/or other materials provided with the # distribution. # 3. Neither the name of the JPackage Project nor the names of its # contributors may be used to endorse or promote products derived # from this software without specific prior written permission. # # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. # %global bootstrap 1 %global _mavenpomdir /usr/share/maven2/poms %global _mavendepmapfragdir /etc/maven/fragments %global with_maven 1 %global parent plexus %global subname classworlds Name: %{parent}-%{subname} Version: 2.2.3 Release: 1%{?dist} Summary: Plexus Classworlds Classloader Framework License: ASL 2.0 and Plexus Group: Development/Libraries URL: http://plexus.codehaus.org/ # svn export http://svn.codehaus.org/plexus/plexus-classworlds/tags/plexus-classworlds-2.2.3 plexus-classworlds-2.2.3 # tar caf plexus-classworlds-2.2.3.tar.xz plexus-classworlds-2.2.3 Source0: %{name}-%{version}.tar.xz # Generated with mvn ant:ant Source1: plexus-classworlds-1.2-build.xml # Fedora-specific maven bits Source3: plexus-classworlds-settings.xml # workaround objectweb-asm depmap Source5: %{name}.depmap Patch0: pom.patch BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildArch: noarch BuildRequires: jpackage-utils BuildRequires: ant BuildRequires: mvn-helper xz java-devel %if !%{bootstrap} BuildRequires: apache-commons-logging BuildRequires: xml-commons-jaxp-1.3-apis BuildRequires: maven2 BuildRequires: maven-compiler-plugin BuildRequires: maven-install-plugin BuildRequires: maven-jar-plugin BuildRequires: maven-javadoc-plugin BuildRequires: maven-resources-plugin BuildRequires: maven-doxia BuildRequires: maven-doxia-sitetools BuildRequires: maven-release-plugin BuildRequires: maven-shared-invoker BuildRequires: maven-shared-reporting-impl BuildRequires: maven-dependency-plugin BuildRequires: maven-surefire-maven-plugin BuildRequires: maven-surefire-provider-junit BuildRequires: plexus-utils %endif Requires(post): jpackage-utils Requires(postun): jpackage-utils %description Classworlds is a framework for container developers who require complex manipulation of Java's ClassLoaders. Java's native ClassLoader mechanisms and classes can cause much headache and confusion for certain types of application developers. Projects which involve dynamic loading of components or otherwise represent a 'container' can benefit from the classloading control provided by classworlds. # %package javadoc # Summary: Javadoc for %{name} # Group: Documentation # Requires: jpackage-utils # # %description javadoc # API documentation for %{name}. %prep %setup -q -n %{name}-%{version} %patch0 for j in $(find . -name "*.jar" | grep -v /test-data/ | grep -v /test-jars/); do mv $j $j.no done cp %{SOURCE1} build.xml cp %{SOURCE3} settings.xml mkdir -p lib ln -sf $(build-classpath xml-commons-jaxp-1.3-apis) lib/xml-apis-1.3.02.jar ln -sf $(build-classpath ant) lib/ant-1.6.5.jar ln -sf $(build-classpath commons-logging) lib/commons-logging-1.0.3.jar mvn-helper replace -r /usr/share/maven2/bootstrap_repo/mvn-pass1/ . mvn-helper filter -f /etc/mvn-helper/filters.xml . %build export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository mkdir -p $MAVEN_REPO_LOCAL # tests skipped because of old commons-cli package these fail # %if %{with_maven} # mvn-jpp \ # -e \ # -Dmaven.test.skip=true \ # -Dmaven.repo.local=$MAVEN_REPO_LOCAL \ # -Dmaven2.jpp.depmap.file=%{SOURCE5} \ # install javadoc:javadoc # # %else # export CLASSPATH= # CLASSPATH=$CLASSPATH:target/classes:target/test-classes # # ant -Dbuild.sysclasspath=only jar javadoc # %endif mvn --settings /usr/share/maven2/conf/settings-custom.xml -Dmaven.test.skip=true install %install # jars install -Dpm 644 target/%{name}-%{version}.jar \ $RPM_BUILD_ROOT%{_javadir}/plexus/%{subname}-%{version}.jar %add_to_maven_depmap org.codehaus.plexus %{name} %{version} JPP/%{parent} %{subname} (cd $RPM_BUILD_ROOT%{_javadir}/%{parent} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done) # pom install -Dpm 644 pom.xml $RPM_BUILD_ROOT%{_mavenpomdir}/JPP.%{parent}-%{subname}.pom # # javadoc # install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version} # cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version} # ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} %clean rm -rf $RPM_BUILD_ROOT %post %update_maven_depmap %postun %update_maven_depmap %files %defattr(-,root,root,-) %{_javadir}/%{parent}/ %{_mavenpomdir}/ %{_mavendepmapfragdir}/ %doc LICENSE.txt # %files javadoc # %defattr(-,root,root,-) # %doc %{_javadocdir}/* %changelog * Tue Jul 13 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.2.3-1 - Version bump - Fix few small packaging guidelines violations * Thu Aug 20 2009 Andrew Overholt <overholt@redhat.com> 0:1.2-0.a9.8 - Bump release. * Wed Aug 19 2009 Andrew Overholt <overholt@redhat.com> 0:1.2-0.a9.7 - Document sources and patches * Wed Aug 19 2009 Andrew Overholt <overholt@redhat.com> 0:1.2-0.a9.6 - Update tarball-building instructions - Remove gcj support - Remove unnecessary post requirements * Thu May 14 2009 Fernando Nasser <fnasser@redhat.com> 0:1.2-0.a9.6 - Fix license specification * Tue Apr 28 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.5 - Add BRs maven2-plugin-surfire*, maven-doxia* - Rebuild with maven2-2.0.8 built in non-bootstrap mode * Mon Mar 16 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.4 - rebuild with new maven2 2.0.8 built in bootstrap mode * Tue Jan 13 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.3jpp.1 - re-build with maven * Tue Jan 06 2009 Yong Yang <yyang@redhat.com> 0:1.2-0.a9.2jpp.1 - Imported into devel from dbhole's maven 2.0.8 packages * Wed Jan 30 2008 Deepak Bhole <dbhole@redhat.com> 0:1.2-0.a9.1jpp.1 - Initial build -- merged from JPackage
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor