Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
Please login to access the resource
home:vlj:fedora14:maven2
plexus-velocity
plexus-velocity.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File plexus-velocity.spec of Package plexus-velocity
# Copyright (c) 2000-2005, JPackage Project # All rights reserved. # # Redistribution and use in source and binary forms, with or without # modification, are permitted provided that the following conditions # are met: # # 1. Redistributions of source code must retain the above copyright # notice, this list of conditions and the following disclaimer. # 2. Redistributions in binary form must reproduce the above copyright # notice, this list of conditions and the following disclaimer in the # documentation and/or other materials provided with the # distribution. # 3. Neither the name of the JPackage Project nor the names of its # contributors may be used to endorse or promote products derived # from this software without specific prior written permission. # # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. # # If you don't want to build with maven, and use straight ant instead, # give rpmbuild option '--without maven' %global bootstrap 1 %global _mavenpomdir /usr/share/maven2/poms %global _mavendepmapfragdir /etc/maven/fragments %define with_maven 1 %define without_maven 0 %define section free %define parent plexus %define subname velocity Name: plexus-velocity Version: 1.1.8 Release: 5%{?dist} Epoch: 0 Summary: Plexus Velocity Component License: ASL 2.0 Group: Development/Java URL: http://plexus.codehaus.org/ # svn export http://svn.codehaus.org/plexus/plexus-components/tags/plexus-velocity-1.1.8/ # tar czf plexus-velocity-1.1.8-src.tar.gz plexus-velocity-1.1.8/ Source0: plexus-velocity-%{version}-src.tar.gz Source1: plexus-velocity-1.1.7-build.xml Patch0: pom.patch BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildArch: noarch BuildRequires: jpackage-utils BuildRequires: ant BuildRequires: java-devel BuildRequires: maven2 mvn-helper %if !%{bootstrap} BuildRequires: maven2 >= 2.0.4-10jpp BuildRequires: maven2-plugin-compiler BuildRequires: maven2-plugin-install BuildRequires: maven2-plugin-jar BuildRequires: maven2-plugin-javadoc BuildRequires: maven2-plugin-resources BuildRequires: plexus-maven-plugin BuildRequires: maven-surefire-maven-plugin BuildRequires: maven-surefire-provider-junit BuildRequires: maven-doxia-sitetools BuildRequires: ant-contrib BuildRequires: ant-nodeps BuildRequires: classworlds >= 0:1.1 BuildRequires: jakarta-commons-collections BuildRequires: plexus-container-default BuildRequires: plexus-utils BuildRequires: velocity %endif Requires: classworlds Requires: jakarta-commons-collections Requires: plexus-container-default Requires: plexus-utils Requires: velocity Requires(post): jpackage-utils >= 0:1.7.2 Requires(postun): jpackage-utils >= 0:1.7.2 %description The Plexus project seeks to create end-to-end developer tools for writing applications. At the core is the container, which can be embedded or for a full scale application server. There are many reusable components for hibernate, form processing, jndi, i18n, velocity, etc. Plexus also includes an application server which is like a J2EE application server, without all the baggage. # %package javadoc # Summary: Javadoc for %{name} # Group: Development/Documentation # # %description javadoc # Javadoc for %{name}. %prep %setup -q -n plexus-velocity-%{version} %patch0 for j in $(find . -name "*.jar"); do mv $j $j.no done cp %{SOURCE1} build.xml mvn-helper replace -r /usr/share/maven2/bootstrap_repo/mvn-pass1/ . mvn-helper filter -f /etc/mvn-helper/filters.xml . %build export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository mkdir -p $MAVEN_REPO_LOCAL # mkdir external_repo # ln -s %{_javadir} external_repo/JPP # # %if %{with_maven} # # Use normal pom for now # rm -f release-pom.xml # mvn-jpp \ # -e \ # -Dmaven.repo.local=$MAVEN_REPO_LOCAL \ # install javadoc:javadoc # %else # # mkdir -p target/lib # build-jar-repository -s -p target/lib \ # classworlds \ # commons-collections \ # commons-logging-api \ # plexus/container-default \ # plexus/utils \ # velocity \ # # ant jar javadoc # # %endif mvn --settings /usr/share/maven2/conf/settings-custom.xml -Dmaven.test.skip=true install %install # jars install -d -m 755 $RPM_BUILD_ROOT%{_javadir}/plexus install -pm 644 target/%{name}-%{version}.jar \ $RPM_BUILD_ROOT%{_javadir}/plexus/velocity-%{version}.jar %add_to_maven_depmap org.codehaus.plexus %{name} %{version} JPP/%{parent} %{subname} (cd $RPM_BUILD_ROOT%{_javadir}/plexus && for jar in *-%{version}*; \ do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done) # poms # %if %{with_maven} install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms install -pm 644 pom.xml \ $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{parent}-%{subname}.pom # %endif # javadoc # install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version} # cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version} # ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink %clean rm -rf $RPM_BUILD_ROOT %post %update_maven_depmap %postun %update_maven_depmap %files %defattr(-,root,root,-) %{_javadir}/%{parent} %{_mavendepmapfragdir} # %if %{with_maven} %{_datadir}/maven2 # %endif # %files javadoc # %defattr(-,root,root,-) # %doc %{_javadocdir}/* %changelog * Tue Dec 22 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.1.8-5 - BR java-devel 1.6. * Tue Dec 22 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.1.8-4 - BR maven-surefire-provider-junit. * Tue Dec 22 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.1.8-3 - BR maven-doxia-sitetools. * Tue Dec 22 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.1.8-2 - BR plexus-maven-plugin. * Tue Dec 22 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.1.8-1 - Update to upstream 1.1.8. * Fri Aug 21 2009 Andrew Overholt <overholt@redhat.com> 1.1.7-3.3 - Add ant-nodeps BR * Fri Aug 21 2009 Andrew Overholt <overholt@redhat.com> 1.1.7-3.2 - Add ant-contrib BR * Fri Aug 21 2009 Andrew Overholt <overholt@redhat.com> 0:1.1.7-3.1 - Import from Deepak Bhole's work (import from JPackage, update to 1.1.7) - Remove gcj support * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.1.2-5.2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.1.2-4.2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.1.2-3.2 - drop repotag * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.1.2-3jpp.1 - Autorebuild for GCC 4.3 * Sat Mar 24 2007 Ralph Apel <r.apel at r-apel.de> - 0:1.1.2-3jpp - Build with maven2 by default - Add gcj_support options * Fri Feb 16 2007 Tania Bento <tbento@redhat.com> - 0:1.1.2-2jpp.1 - Fixed %%License. - Fixed %%BuildRoot. - Fixed %%Release. - Removed the %%post and %%postun for javadoc. - Removed %%Vendor. - Removed %%Distribution. - Removed "%%define section free". - Added the gcj support option. - Added BR for jakarta-commons-logging. * Wed May 17 2006 Ralph Apel <r.apel at r-apel.de> - 0:1.1.2-2jpp - First JPP-1.7 release * Mon Nov 07 2005 Ralph Apel <r.apel at r-apel.de> - 0:1.1.2-1jpp - First JPackage build
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor