Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
home:zeussuse:znver2
wireplumber
wireplumber.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File wireplumber.spec of Package wireplumber
# # spec file for package wireplumber # # Copyright (c) 2022 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # %define pipewire_minimum_version 0.3.52 %define apiver 0.5 %define apiver_str 0_5 %define sover 0 %define libwireplumber libwireplumber-%{apiver_str}-%{sover} Name: wireplumber Version: 0.5.0 Release: 0 Summary: Session / policy manager implementation for PipeWire License: MIT Group: Development/Libraries/C and C++ URL: https://gitlab.freedesktop.org/pipewire/wireplumber Source0: wireplumber-%{version}.tar.xz #Source1: split-config-file.py # docs BuildRequires: doxygen BuildRequires: graphviz BuildRequires: %{python_module lxml} BuildRequires: %{python_module breathe} BuildRequires: %{python_module graphviz} BuildRequires: %{python_module Sphinx} BuildRequires: %{python_module sphinx_rtd_theme} # /docs BuildRequires: cmake BuildRequires: fdupes BuildRequires: meson >= 0.59.0 BuildRequires: pipewire >= %{pipewire_minimum_version} BuildRequires: pipewire-spa-plugins-0_2 >= %{pipewire_minimum_version} BuildRequires: pkgconfig BuildRequires: python3-base BuildRequires: python3-lxml BuildRequires: xmltoman BuildRequires: pkgconfig(dbus-1) BuildRequires: pkgconfig(gio-unix-2.0) BuildRequires: pkgconfig(glib-2.0) >= 2.62.0 BuildRequires: pkgconfig(gmodule-2.0) BuildRequires: pkgconfig(gobject-2.0) >= 2.62 BuildRequires: pkgconfig(gobject-introspection-1.0) BuildRequires: pkgconfig(libpipewire-0.3) >= %{pipewire_minimum_version} BuildRequires: pkgconfig(libsystemd) BuildRequires: pkgconfig(lua) BuildRequires: pkgconfig(systemd) #!BuildIgnore: pipewire-session-manager # Setup ALSA devices if PipeWire handles PulseAudio or JACK connections. Requires: (%{name}-audio if (pipewire-pulseaudio or pipewire-jack)) Requires: pipewire >= %{pipewire_minimum_version} Provides: pipewire-session-manager %if 0%{?suse_version} <= 1500 BuildRequires: gcc9 BuildRequires: gcc9-c++ %else BuildRequires: gcc-c++ %endif %{?systemd_ordering} %description WirePlumber is a modular session / policy manager for PipeWire and a GObject-based high-level library that wraps PipeWire's API, providing convenience for writing the daemon's modules as well as external tools for managing PipeWire. %lang_package %package audio Summary: Session / policy manager implementation for PipeWire (audio support) Group: Development/Libraries/C and C++ Requires: %{libwireplumber} = %{version} Requires: %{name} = %{version} Recommends: %{name}-doc = %{version} Recommends: pipewire-jack Recommends: pipewire-pulseaudio Conflicts: pulseaudio BuildArch: noarch %description audio WirePlumber is a modular session / policy manager for PipeWire and a GObject-based high-level library that wraps PipeWire's API, providing convenience for writing the daemon's modules as well as external tools for managing PipeWire. This package enables the use of alsa devices in PipeWire. %package devel Summary: Session / policy manager implementation for PipeWire Group: Development/Libraries/C and C++ Requires: %{libwireplumber} = %{version} Requires: %{name} = %{version} %description devel WirePlumber is a modular session / policy manager for PipeWire and a GObject-based high-level library that wraps PipeWire's API, providing convenience for writing the daemon's modules as well as external tools for managing PipeWire. This package provides all the necessary files for development with WirePlumber %package -n %{libwireplumber} Summary: Session / policy manager implementation for PipeWire Group: System/Libraries %description -n %{libwireplumber} WirePlumber is a modular session / policy manager for PipeWire and a GObject-based high-level library that wraps PipeWire's API, providing convenience for writing the daemon's modules as well as external tools for managing PipeWire. This package provides the wireplumber shared library. %package -n typelib-1_0-Wp-%{apiver_str} Summary: Introspection bindings for libwireplumber Group: System/Libraries %description -n typelib-1_0-Wp-%{apiver_str} WirePlumber is a modular session / policy manager for PipeWire and a GObject-based high-level library that wraps PipeWire's API, providing convenience for writing the daemon's modules as well as external tools for managing PipeWire. This package provides the GObject Introspection bindings for the wireplumber shared library. %package doc Summary: WirePlumber PipeWire session manager documentation Group: Development/Libraries/C and C++ %description doc This package contains documentation for the WirePlumber PipeWire session manager. %prep %autosetup -p1 #%%autosetup -a0 -n %%{name} #pushd src/config/main.lua.d #python3 %{SOURCE1} #rm 90-enable-all.lua #popd %build %if %{pkg_vcmp gcc < 8} export CC=gcc-9 export CXX=g++-9 %endif %meson -Ddoc=enabled \ -Dsystem-lua=true \ -Delogind=disabled %meson_build %install %meson_install %fdupes -s %{buildroot}/%{_datadir}/doc/ %find_lang %{name} %{?no_lang_C} %ifnarch %ix86 ppc64 %check export XDG_RUNTIME_DIR=/tmp %meson_test %endif %pre %systemd_user_pre wireplumber.service %post %systemd_user_post wireplumber.service %if 0%{?suse_version} <= 1500 # If the pipewire.socket user unit is not enabled and the workaround # for boo#1186561 has never been executed, we need to execute it now if [ ! -L %{_sysconfdir}/systemd/user/pipewire.service.wants/wireplumber.service \ -a ! -f %{_localstatedir}/lib/pipewire/wireplumber_post_workaround \ -a -x %{_bindir}/systemctl ]; then for service in wireplumber.service ; do %{_bindir}/systemctl --global preset "$service" || : done mkdir -p %{_localstatedir}/lib/pipewire cat << EOF > %{_localstatedir}/lib/pipewire/wireplumber_post_workaround # The existence of this file means that the wireplumber user services were # enabled at least once. Please don't remove this file as that would # make the services to be enabled again in the next package update. # # Check the following bugs for more information: # https://bugzilla.opensuse.org/show_bug.cgi?id=1200485 EOF fi %endif %preun %systemd_user_preun wireplumber.service %postun %systemd_user_postun wireplumber.service %post -n %{libwireplumber} -p /sbin/ldconfig %postun -n %{libwireplumber} -p /sbin/ldconfig %files %{_bindir}/wireplumber %{_bindir}/wpctl %{_bindir}/wpexec %dir %{_libdir}/wireplumber-%{apiver} %{_libdir}/wireplumber-%{apiver}/*.so %{_userunitdir}/wireplumber.service %{_userunitdir}/wireplumber@.service %{_datadir}/wireplumber # No longer in use since 3d5cee55 %{_datadir}/pipewire %{_datadir}/zsh %exclude %{_datadir}/wireplumber/scripts/monitors/alsa.lua %exclude %{_datadir}/wireplumber/scripts/monitors/alsa-midi.lua %exclude %{_datadir}/wireplumber/scripts/monitors/bluez.lua %exclude %{_datadir}/wireplumber/scripts/monitors/bluez-midi.lua %files lang -f %{name}.lang %files audio %{_datadir}/wireplumber/scripts/monitors/alsa.lua %{_datadir}/wireplumber/scripts/monitors/alsa-midi.lua %{_datadir}/wireplumber/scripts/monitors/bluez.lua %{_datadir}/wireplumber/scripts/monitors/bluez-midi.lua %files devel %{_includedir}/wireplumber-%{apiver} %{_libdir}/libwireplumber-%{apiver}.so %{_libdir}/pkgconfig/wireplumber-%{apiver}.pc %{_datadir}/gir-1.0/Wp-%{apiver}.gir %files -n typelib-1_0-Wp-%{apiver_str} %{_libdir}/girepository-1.0/Wp-%{apiver}.typelib %files -n %{libwireplumber} %{_libdir}/libwireplumber-%{apiver}.so.%{sover} %{_libdir}/libwireplumber-%{apiver}.so.%{sover}.* %files doc %{_datadir}/doc/* %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor