Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
network:cluster:xtreemos
jmock
jmock.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File jmock.spec of Package jmock
# # spec file for package jmock # # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %define section free Name: jmock Version: 1.2.0 Release: 0 Summary: Test Java code using mock objects License: Other uncritical OpenSource License Group: Development/Libraries/Java Url: http://jmock.codehaus.org/license.html Source0: jmock-1.2.0.tar.gz # svn export http://svn.codehaus.org/jmock/tags/1.2.0/ jmock-1.2.0 Source1: jmock-1.2.0.pom Source2: jmock-cglib-1.2.0.pom Source10: build.xml Patch0: jmock-1.2.0-AssertMo.patch Patch1: jmock-1.2.0-build_xml.patch BuildArch: noarch BuildRequires: ant-junit BuildRequires: jpackage-utils >= 1.7.2 %ifarch x86_64 %if 0%{?fedora_version} == 13 # if fedora 13 for x86_64, junit is already included in ant, so nothing! %else BuildRequires: ant >= 1.6 %endif %else BuildRequires: ant >= 1.6 %endif BuildRequires: cglib >= 2.1.3 BuildRequires: junit >= 3.8.1 # BuildRequires: cglib-nohook >= 2.1.3 BuildRequires: asm >= 1.5.3 Requires: asm >= 1.5.3 Requires: cglib >= 2.1.3 BuildRequires: java-devel BuildRoot: %{_tmppath}/%{name}-%{version}-build %description jMock is a library for testing Java code using mock objects. Mock objects help you design and test the interactions between the objects in your programs. The jMock package: * makes it quick and easy to define mock objects, so you don't break the rhythm of programming. * lets you define flexible constraints over object interactions, reducing the brittleness of your tests. * is easy to extend. %package javadoc Summary: Test Java code using mock objects Group: Development/Libraries/Java %description javadoc jMock is a library for testing Java code using mock objects. Mock objects help you design and test the interactions between the objects in your programs. The jMock package: * makes it quick and easy to define mock objects, so you don't break the rhythm of programming. * lets you define flexible constraints over object interactions, reducing the brittleness of your tests. * is easy to extend. %package demo Summary: Test Java code using mock objects Group: Development/Libraries/Java %description demo jMock is a library for testing Java code using mock objects. Mock objects help you design and test the interactions between the objects in your programs. The jMock package: * makes it quick and easy to define mock objects, so you don't break the rhythm of programming. * lets you define flexible constraints over object interactions, reducing the brittleness of your tests. * is easy to extend. %prep %setup -q find . -name "*.jar" | xargs rm %patch0 -p0 %patch1 -p0 mv %{SOURCE10} . %build # export OPT_JAR_LIST="ant/ant-junit junit" # export CLASSPATH=`pwd`/build/classes:$(build-classpath asm cglib-nohook-nodep) ant -lib %{_javadir}:%{_javadir}/asm -Dbuild.sysclasspath=only package %install install -Dpm 644 build/%{name}-core-%{version}.jar \ $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar install -pm 644 build/%{name}-cglib-%{version}.jar \ $RPM_BUILD_ROOT%{_javadir}/%{name}-cglib-%{version}.jar install -pm 644 build/%{name}-tests-%{version}.jar \ $RPM_BUILD_ROOT%{_javadir}/%{name}-tests-%{version}.jar (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done) %add_to_maven_depmap %{name} %{name} %{version} JPP %{name} %add_to_maven_depmap %{name} %{name}-cglib %{version} JPP %{name}-cglib # poms install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms install -pm 644 %{SOURCE1} \ $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}.pom install -pm 644 %{SOURCE2} \ $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-cglib.pom # install -dm 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version} cp -pr build/javadoc-%{version}/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version} ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version} cp -pr examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version} %clean rm -rf $RPM_BUILD_ROOT %post %update_maven_depmap %postun %update_maven_depmap %files %defattr(0644,root,root,0755) %doc LICENSE.txt overview.html %{_javadir}/*.jar %{_datadir}/maven2/poms/* %{_mavendepmapfragdir}/* %files javadoc %defattr(0644,root,root,0755) %{_javadocdir}/%{name}-%{version} %{_javadocdir}/%{name} %files demo %defattr(0644,root,root,0755) %{_datadir}/%{name}-%{version} %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor