Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:12.2:ARM
perl-Clone-PP
perl-Clone-PP.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File perl-Clone-PP.spec of Package perl-Clone-PP
# # spec file for package perl-Clone-PP # # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # Name: perl-Clone-PP Version: 1.02 Release: 1 License: GPL-1.0+ or Artistic-1.0 %define cpan_name Clone-PP Summary: Recursively copy Perl datatypes Url: http://search.cpan.org/dist/Clone-PP/ Group: Development/Libraries/Perl Source: http://www.cpan.org/authors/id/E/EV/EVO/%{cpan_name}-%{version}.tar.gz NoSource: 0 BuildRequires: perl BuildRequires: perl-macros BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildArch: noarch %{perl_requires} %description This module provides a general-purpose clone function to make deep copies of Perl data structures. It calls itself recursively to copy nested hash, array, scalar and reference types, including tied variables and objects. The clone() function takes a scalar argument to copy. To duplicate arrays or hashes, pass them in by reference: my $copy = clone(\@array); my @copy = @{ clone(\@array) }; my $copy = clone(\%hash); my %copy = %{ clone(\%hash) }; The clone() function also accepts an optional second parameter that can be used to limit the depth of the copy. If you pass a limit of 0, clone will return the same value you supplied; for a limit of 1, a shallow copy is constructed; for a limit of 2, two layers of copying are done, and so on. my $shallow_copy = clone( $item, 1 ); To allow objects to intervene in the way they are copied, the clone() function checks for a couple of optional methods. If an object provides a method named 'clone_self', it is called and the result returned without further processing. Alternately, if an object provides a method named 'clone_init', it is called on the copied object before it is returned. %prep %setup -q -n %{cpan_name}-%{version} %build %{__perl} Makefile.PL INSTALLDIRS=vendor %{__make} %{?_smp_mflags} %check %{__make} test %install %perl_make_install %perl_process_packlist %perl_gen_filelist %clean %{__rm} -rf %{buildroot} %files -f %{name}.files %defattr(644,root,root,755) %doc README %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor