Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Backports:SLE-15:Update
stack
stack.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File stack.spec of Package stack
# # spec file for package stack # # Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %global pkg_name stack %bcond_with tests Name: %{pkg_name} Version: 1.5.0 Release: 0 Summary: The Haskell Tool Stack License: BSD-3-Clause Group: Development/Languages/Other Url: https://hackage.haskell.org/package/%{name} Source0: https://hackage.haskell.org/package/%{name}-%{version}/%{name}-%{version}.tar.gz Source1: https://hackage.haskell.org/package/%{name}-%{version}/revision/1.cabal#/%{name}.cabal BuildRequires: chrpath BuildRequires: ghc-Cabal-devel BuildRequires: ghc-aeson-devel BuildRequires: ghc-annotated-wl-pprint-devel BuildRequires: ghc-ansi-terminal-devel BuildRequires: ghc-async-devel BuildRequires: ghc-attoparsec-devel BuildRequires: ghc-base-compat-devel BuildRequires: ghc-base64-bytestring-devel BuildRequires: ghc-binary-devel BuildRequires: ghc-binary-tagged-devel BuildRequires: ghc-blaze-builder-devel BuildRequires: ghc-bytestring-devel BuildRequires: ghc-clock-devel BuildRequires: ghc-conduit-devel BuildRequires: ghc-conduit-extra-devel BuildRequires: ghc-containers-devel BuildRequires: ghc-cryptonite-conduit-devel BuildRequires: ghc-cryptonite-devel BuildRequires: ghc-deepseq-devel BuildRequires: ghc-directory-devel BuildRequires: ghc-echo-devel BuildRequires: ghc-either-devel BuildRequires: ghc-errors-devel BuildRequires: ghc-exceptions-devel BuildRequires: ghc-extra-devel BuildRequires: ghc-fast-logger-devel BuildRequires: ghc-file-embed-devel BuildRequires: ghc-filelock-devel BuildRequires: ghc-filepath-devel BuildRequires: ghc-fsnotify-devel BuildRequires: ghc-generic-deriving-devel BuildRequires: ghc-gitrev-devel BuildRequires: ghc-hackage-security-devel BuildRequires: ghc-hashable-devel BuildRequires: ghc-hastache-devel BuildRequires: ghc-hpack-devel BuildRequires: ghc-hpc-devel BuildRequires: ghc-http-client-devel BuildRequires: ghc-http-client-tls-devel BuildRequires: ghc-http-conduit-devel BuildRequires: ghc-http-types-devel BuildRequires: ghc-lifted-async-devel BuildRequires: ghc-lifted-base-devel BuildRequires: ghc-memory-devel BuildRequires: ghc-microlens-devel BuildRequires: ghc-microlens-mtl-devel BuildRequires: ghc-mintty-devel BuildRequires: ghc-monad-control-devel BuildRequires: ghc-monad-logger-devel BuildRequires: ghc-monad-unlift-devel BuildRequires: ghc-mtl-devel BuildRequires: ghc-network-uri-devel BuildRequires: ghc-open-browser-devel BuildRequires: ghc-optparse-applicative-devel BuildRequires: ghc-optparse-simple-devel BuildRequires: ghc-path-devel BuildRequires: ghc-path-io-devel BuildRequires: ghc-persistent-devel BuildRequires: ghc-persistent-sqlite-devel BuildRequires: ghc-persistent-template-devel BuildRequires: ghc-pid1-devel BuildRequires: ghc-pretty-devel BuildRequires: ghc-process-devel BuildRequires: ghc-project-template-devel BuildRequires: ghc-regex-applicative-text-devel BuildRequires: ghc-resourcet-devel BuildRequires: ghc-retry-devel BuildRequires: ghc-rpm-macros BuildRequires: ghc-safe-devel BuildRequires: ghc-safe-exceptions-devel BuildRequires: ghc-semigroups-devel BuildRequires: ghc-split-devel BuildRequires: ghc-stm-devel BuildRequires: ghc-store-core-devel BuildRequires: ghc-store-devel BuildRequires: ghc-streaming-commons-devel BuildRequires: ghc-tar-devel BuildRequires: ghc-template-haskell-devel BuildRequires: ghc-temporary-devel BuildRequires: ghc-text-binary-devel BuildRequires: ghc-text-devel BuildRequires: ghc-text-metrics-devel BuildRequires: ghc-time-devel BuildRequires: ghc-tls-devel BuildRequires: ghc-transformers-base-devel BuildRequires: ghc-transformers-devel BuildRequires: ghc-unicode-transforms-devel BuildRequires: ghc-unix-compat-devel BuildRequires: ghc-unix-devel BuildRequires: ghc-unordered-containers-devel BuildRequires: ghc-vector-binary-instances-devel BuildRequires: ghc-vector-devel BuildRequires: ghc-yaml-devel BuildRequires: ghc-zip-archive-devel BuildRequires: ghc-zlib-devel Suggests: docker BuildRoot: %{_tmppath}/%{name}-%{version}-build %if %{with tests} BuildRequires: ghc-QuickCheck-devel BuildRequires: ghc-hspec-devel BuildRequires: ghc-mono-traversable-devel BuildRequires: ghc-neat-interpolation-devel BuildRequires: ghc-smallcheck-devel BuildRequires: ghc-th-reify-many-devel %endif %description Stack is a cross-platform program for developing Haskell projects. It is aimed at Haskellers both new and experienced. It features: * Installing GHC automatically, in an isolated location. * Installing packages needed for your project. * Building your project. * Testing your project. * Benchmarking your project. %package -n ghc-%{name} Summary: Haskell %{name} library Group: System/Libraries %description -n ghc-%{name} This package provides the Haskell %{name} shared library. %package -n ghc-%{name}-devel Summary: Haskell %{name} library development files Group: Development/Libraries/Other Requires: ghc-%{name} = %{version}-%{release} Requires: ghc-compiler = %{ghc_version} Requires(post): ghc-compiler = %{ghc_version} Requires(postun): ghc-compiler = %{ghc_version} %description -n ghc-%{name}-devel This package provides the Haskell %{name} library development files. %prep %setup -q cp -p %{SOURCE1} %{name}.cabal %build %ghc_lib_build %install %ghc_lib_install %ghc_fix_rpath %{pkg_name}-%{version} %check %cabal_test %post -n ghc-%{name}-devel %ghc_pkg_recache %postun -n ghc-%{name}-devel %ghc_pkg_recache %files %defattr(-,root,root,-) %doc LICENSE %doc ChangeLog.md README.md doc %{_bindir}/%{name} %files -n ghc-%{name} -f ghc-%{name}.files %defattr(-,root,root,-) %doc LICENSE %files -n ghc-%{name}-devel -f ghc-%{name}-devel.files %defattr(-,root,root,-) %doc ChangeLog.md README.md doc %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor