Elixir is a functional meta-programming aware language built on top of the Erlang VM.
Elixir is a functional meta-programming aware language built on top of the Erlang VM. It is a dynamic language with flexible syntax with macros support that leverages Erlang's abilities to build concurrent, distributed, fault-tolerant applications with hot code upgrades.
Elixir also provides first-class support for pattern matching, polymorphism via protocols (similar to Clojure's), aliases and associative data structures (usually known as dicts or hashes in other programming languages).
Finally, Elixir and Erlang share the same bytecode and data types. This means you can invoke Erlang code from Elixir (and vice-versa) without any conversion or performance hit. This allows a developer to mix the expressiveness of Elixir with the robustness and performance of Erlang.
- Developed at devel:languages:erlang
- Sources inherited from project openSUSE:Factory
-
2
derived packages
- Download package
-
Checkout Package
osc -A https://api.opensuse.org checkout openSUSE:Leap:15.2:FactoryCandidates/elixir && cd $_
- Create Badge
Source Files
Filename | Size | Changed |
---|---|---|
elixir-1.17.3-doc.zip | 0006305718 6.01 MB | |
elixir-1.17.3.tar.gz | 0003256595 3.11 MB | |
elixir.changes | 0000158447 155 KB | |
elixir.spec | 0000003731 3.64 KB | |
macros.elixir | 0000000183 183 Bytes |
Comments 0