Python Lex & Yacc
PLY is yet another implementation of lex and yacc for Python. Some notable
features include the fact that its implemented entirely in Python and it
uses LALR(1) parsing which is efficient and well suited for larger grammars.
PLY provides most of the standard lex/yacc features including support for empty
productions, precedence rules, error recovery, and support for ambiguous grammars.
PLY is extremely easy to use and provides very extensive error checking.
It is compatible with both Python 2 and Python 3.
- Developed at devel:languages:python
- Sources inherited from project openSUSE:Factory
-
7
derived packages
- Download package
-
Checkout Package
osc -A https://api.opensuse.org checkout openSUSE:Leap:16.0:FactoryCandidates/python-ply && cd $_
- Create Badge
Refresh
Refresh
Source Files
Filename | Size | Changed |
---|---|---|
fix-assert-methods.patch | 0000039172 38.3 KB | |
ply-3.11.tar.gz | 0000159130 155 KB | |
python-ply-shebangs.patch | 0000000368 368 Bytes | |
python-ply.changes | 0000008101 7.91 KB | |
python-ply.spec | 0000003239 3.16 KB |
Latest Revision
Ana Guerrero (anag+factory)
accepted
request 1132798
from
Steve Kowalik (StevenK)
(revision 32)
- Add patch fix-assert-methods.patch: * Support Python 3.12 by not using removed assertion methods. - Switch to autosetup and pyproject macros. - Stop using greedy globs in %files.
Comments 0