Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Leap:42.2:Ports
hamcrest
hamcrest.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File hamcrest.spec of Package hamcrest
# # spec file for package hamcrest # # Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %define _without_integration 1 %define _without_tests 1 %define _withouth_jarjar 1 # This option controls integration which requires easymock2 and jmock and junit %bcond_without integration # This option controls jarjar on qdox # Since bundling the qdox classes prevents upgrades, we disable it by default %bcond_with jarjar # This option controls tests which requires ant-junit and testng %bcond_without tests # If integration is disabled, then tests are disabled %if %without integration %bcond_with tests %endif Name: hamcrest Version: 1.3 Release: 0 Summary: Library of matchers for building test expressions License: BSD-3-Clause Group: Development/Libraries/Java Url: http://code.google.com/p/%{name}/ Source0: http://%{name}.googlecode.com/files/%{name}-%{version}.tgz Source1: http://repo1.maven.org/maven2/org/%{name}/%{name}-parent/%{version}/%{name}-parent-%{version}.pom Source2: http://repo1.maven.org/maven2/org/%{name}/%{name}-library/%{version}/%{name}-library-%{version}.pom Source3: http://repo1.maven.org/maven2/org/%{name}/%{name}-integration/%{version}/%{name}-integration-%{version}.pom Source4: http://repo1.maven.org/maven2/org/%{name}/%{name}-generator/%{version}/%{name}-generator-%{version}.pom Source5: http://repo1.maven.org/maven2/org/%{name}/%{name}-core/%{version}/%{name}-core-%{version}.pom Source6: http://repo1.maven.org/maven2/org/%{name}/%{name}-all/%{version}/%{name}-all-%{version}.pom # This file was added by the maintainer for compatibility with maven dep # solving system Source7: %{name}-text-%{version}.pom Source8: hamcrest-core-MANIFEST.MF Source9: hamcrest-library-MANIFEST.MF Source10: hamcrest-text-MANIFEST.MF Source11: hamcrest-integration-MANIFEST.MF Source12: hamcrest-generator-MANIFEST.MF #PATCH-FIX-OPENSUSE: don't use versioned deps, no overview in html Patch0: %{name}-%{version}-build.patch #PATCH-FIX-OPENSUSE: don't bundle QDox classes into hamcrest-generator.jar Patch1: %{name}-%{version}-no-jarjar.patch #PATCH-FIX-OPENSUSE: don't build hamcrest-integration.jar Patch2: %{name}-%{version}-no-integration.patch #PATCH-FIX-OPENSUSE: there is no hamcrest-generator-nodeps Patch3: %{name}-%{version}-javadoc.patch #PATCH-FIX-UPSTREAM: random build crash fix Patch4: hamcrest-1.3-random-build-crash.patch Requires: java >= 1.6.0 Requires: qdox %if %with integration Requires: easymock2 Requires: jmock %endif BuildRequires: ant >= 1.6.5 BuildRequires: java-devel >= 1.6.0 BuildRequires: javapackages-tools BuildRequires: zip %if %with integration BuildRequires: easymock2 %endif %if %with jarjar BuildRequires: jarjar %endif %if %with integration BuildRequires: ant-junit BuildRequires: jmock BuildRequires: junit %endif BuildRequires: qdox %if %with tests BuildRequires: testng %endif BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildArch: noarch %description Provides a library of matcher objects (also known as constraints or predicates) allowing 'match' rules to be defined declaratively, to be used in other frameworks. Typical scenarios include testing frameworks, mocking libraries and UI validation rules. %package javadoc Summary: Javadoc for %{name} Group: Documentation/HTML %description javadoc Javadoc for %{name}. %package demo Summary: Demo files for %{name} Group: Development/Libraries/Java Requires: %{name} = %{version} Requires: junit4 %if %with tests Requires: testng %endif %description demo Demo files for %{name}. %prep %setup -q find . -type f -name "*.jar" | xargs -t rm rm -fr hamcrest-integration/src/main/java/org/hamcrest/integration/JMock1Adapter.java rm -fr hamcrest-integration/src/main/java/org/hamcrest/JMock1Matchers.java rm -fr hamcrest-unit-test/src/main/java/org/hamcrest/integration/JMock1AdapterTest.java # BUILD/%{name}-%{version}/lib/generator/jarjar-1.0rc3.jar.no %if %with jarjar ln -sf $(build-classpath jarjar) lib/generator/ %endif # BUILD/%{name}-%{version}/lib/generator/qdox-1.6.1.jar.no ln -sf $(build-classpath qdox) lib/generator/ # BUILD/%{name}-%{version}/lib/integration/easymock-2.2.jar.no %if %with integration ln -sf $(build-classpath easymock2) lib/integration/ %endif # BUILD/%{name}-%{version}/lib/integration/jmock-%{version}0RC1.jar.no %if %with integration ln -sf $(build-classpath jmock) lib/integration/ # BUILD/%{name}-%{version}/lib/integration/junit-3.8.1.jar.no ln -sf $(build-classpath junit) lib/integration/ # BUILD/%{name}-%{version}/lib/integration/junit-4.0.jar.no #ln -sf $(build-classpath junit4) lib/integration/ %endif # BUILD/%{name}-%{version}/lib/integration/testng-4.6-jdk15.jar.no %if %with tests ln -sf $(build-classpath testng-jdk15) lib/integration/ %endif %patch0 -p1 %if %without jarjar %patch1 -p1 %endif %if %without integration %patch2 -p1 %endif %patch3 -p1 %patch4 -p1 perl -pi -e 's/\r$//g' LICENSE.txt %build export CLASSPATH=$(build-classpath qdox) %if %with integration export OPT_JAR_LIST="junit ant/ant-junit" %endif # The unit-test goal is switched off as some tests fail with JDK 7 # see https://github.com/hamcrest/JavaHamcrest/issues/30 ant -Dant.build.javac.source=1.5 -Dversion=%{version} -Dbuild.sysclasspath=last clean core generator library bigjar javadoc # inject OSGi manifests mkdir -p META-INF cp -p %{SOURCE8} META-INF/MANIFEST.MF touch META-INF/MANIFEST.MF zip -u build/%{name}-core-%{version}.jar META-INF/MANIFEST.MF rm -fr META-INF mkdir -p META-INF cp -p %{SOURCE9} META-INF/MANIFEST.MF touch META-INF/MANIFEST.MF zip -u build/%{name}-library-%{version}.jar META-INF/MANIFEST.MF rm -fr META-INF mkdir -p META-INF cp -p %{SOURCE10} META-INF/MANIFEST.MF touch META-INF/MANIFEST.MF zip -u build/%{name}-text-%{version}.jar META-INF/MANIFEST.MF rm -fr META-INF mkdir -p META-INF cp -p %{SOURCE11} META-INF/MANIFEST.MF touch META-INF/MANIFEST.MF zip -u build/%{name}-integration-%{version}.jar META-INF/MANIFEST.MF rm -fr META-INF mkdir -p META-INF cp -p %{SOURCE12} META-INF/MANIFEST.MF touch META-INF/MANIFEST.MF zip -u build/%{name}-generator-%{version}.jar META-INF/MANIFEST.MF %install # jars install -d -m 755 %{buildroot}%{_javadir}/%{name} install -d -m 755 %{buildroot}%{_mavenpomdir} install -m 644 %{SOURCE1} %{buildroot}%{_mavenpomdir}/JPP.%{name}-parent.pom %add_maven_depmap JPP.%{name}-parent.pom install -m 644 build/%{name}-all-%{version}.jar %{buildroot}%{_javadir}/%{name}/all.jar install -m 644 %{SOURCE6} %{buildroot}%{_mavenpomdir}/JPP.%{name}-all.pom %add_maven_depmap JPP.%{name}-all.pom %{name}/all.jar install -m 644 build/%{name}-core-%{version}.jar %{buildroot}%{_javadir}/%{name}/core.jar install -m 644 %{SOURCE5} %{buildroot}%{_mavenpomdir}/JPP.%{name}-core.pom %add_maven_depmap JPP.%{name}-core.pom %{name}/core.jar install -m 644 build/%{name}-generator-%{version}.jar %{buildroot}%{_javadir}/%{name}/generator.jar install -m 644 %{SOURCE4} %{buildroot}%{_mavenpomdir}/JPP.%{name}-generator.pom %add_maven_depmap JPP.%{name}-generator.pom %{name}/generator.jar install -m 644 build/%{name}-library-%{version}.jar %{buildroot}%{_javadir}/%{name}/library.jar install -m 644 %{SOURCE2} %{buildroot}%{_mavenpomdir}/JPP.%{name}-library.pom %add_maven_depmap JPP.%{name}-library.pom %{name}/library.jar %if %with integration install -m 644 build/%{name}-integration-%{version}.jar %{buildroot}%{_javadir}/%{name}/integration.jar install -m 644 %{SOURCE3} %{buildroot}%{_mavenpomdir}/JPP.%{name}-integration.pom %add_maven_depmap JPP.%{name}-integration.pom %{name}/integration.jar %endif install -m 644 build/%{name}-text-%{version}.jar %{buildroot}%{_javadir}/%{name}/text.jar install -m 644 %{SOURCE7} %{buildroot}%{_mavenpomdir}/JPP.%{name}-text.pom %add_maven_depmap JPP.%{name}-text.pom %{name}/text.jar %if %with tests install -m 644 build/%{name}-unit-test-%{version}.jar %{buildroot}%{_javadir}/%{name}/unit-test.jar %endif # javadoc install -d -m 755 %{buildroot}%{_javadocdir}/%{name} cp -pr build/temp/hamcrest-all-1.3-javadoc.jar.contents/* $RPM_BUILD_ROOT%{_javadocdir}/%{name} # demo install -d -m 755 %{buildroot}%{_datadir}/%{name} cp -pr %{name}-examples %{buildroot}%{_datadir}/%{name}/ %files %defattr(0644,root,root,0755) %doc LICENSE.txt %dir %{_javadir}/%{name} %{_javadir}/%{name}/all.jar %{_javadir}/%{name}/core.jar %{_javadir}/%{name}/generator.jar %if %with integration %{_javadir}/%{name}/integration.jar %endif %{_javadir}/%{name}/library.jar %{_javadir}/%{name}/text.jar %if %with tests %{_javadir}/%{name}/unit-test.jar %endif %{_mavenpomdir}/* %config %{_mavendepmapfragdir}/* %files javadoc %defattr(0644,root,root,0755) %{_javadocdir}/%{name} %files demo %defattr(0644,root,root,0755) %{_datadir}/%{name} %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor