Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Leap:42.2:Ports
jakarta-commons-dbcp-src
jakarta-commons-dbcp.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File jakarta-commons-dbcp.spec of Package jakarta-commons-dbcp-src
# # spec file for package jakarta-commons-dbcp # # Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %define base_name dbcp %define short_name commons-%{base_name} Name: jakarta-commons-dbcp Version: 1.2.2 Release: 0 Summary: Jakarta Commons DataBase Pooling Package License: Apache-2.0 Group: Development/Libraries/Java Url: http://jakarta.apache.org/commons/dbcp/ Source0: commons-dbcp-1.2.2-src.tar.bz2 Source1: pom-maven2jpp-depcat.xsl Source2: pom-maven2jpp-newdepmap.xsl Source3: pom-maven2jpp-mapdeps.xsl Source4: %{base_name}-%{version}-jpp-depmap.xml Source5: commons-build.tar.bz2 Source7: commons-dbcp-1.2.2.pom Patch0: commons-dbcp-1.2.2-project_xml.patch #improved from https://issues.apache.org/jira/browse/DBCP-191 Patch1: java6-compatibility.patch Patch2: jakarta-commons-dbcp-target15.patch #http://pkgs.fedoraproject.org/gitweb/?p=apache-commons-dbcp.git;a=blob_plain;f=jdbc41.patch;hb=HEAD Patch3: jdbc41.patch BuildRequires: ant >= 1.6.5 BuildRequires: jakarta-commons-logging BuildRequires: jakarta-commons-pool >= 1.3 BuildRequires: java-devel BuildRequires: javapackages-tools BuildRequires: jdbc-stdext >= 2.0 BuildRequires: junit >= 3.8.1 BuildRequires: xerces-j2 Requires: commons-collections >= 3.2 Requires: commons-pool >= 1.3 Requires(post): %{_sbindir}/update-alternatives Requires(post): javapackages-tools Requires(postun): javapackages-tools Requires(preun): %{_sbindir}/update-alternatives Provides: %{short_name} = %{version}-%{release} Provides: hibernate_jdbc_cache BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildArch: noarch #!BuildIgnore: jakarta-commons-dbcp-tomcat5 #!BuildIgnore: jakarta-commons-dbcp-tomcat %description The DBCP package creates and maintains a database connection pool package written in the Java language to be distributed under the ASF license. The package is available as a pseudo-JDBC driver and via a DataSource interface. The package also supports multiple logins to multiple database systems, reclamation of stale or dead connections, testing for valid connections, PreparedStatement pooling, and other features. %package javadoc Summary: Javadoc for jakarta-commons-dbcp Group: Development/Libraries/Java %description javadoc This package contains the javadoc documentation for the DBCP package. The DBCP package shall create and maintain a database connection pool package written in the Java language to be distributed under the ASF license. The package shall be available as a pseudo-JDBC driver and via a DataSource interface. The package shall also support multiple logins to multiple database systems, reclamation of stale or dead connections, testing for valid connections, PreparedStatement pooling, and other features. %prep %setup -q -n %{short_name}-%{version}-src # quick hack cp LICENSE.txt ../LICENSE # remove all binary libs find . -name "*.jar" -exec rm -f {} \; bzip2 -dc %{SOURCE5} | tar xf - %patch0 -b .sav %patch1 -b .sav1 %patch2 -b .target15 %patch3 %build if [ ! -f %{SOURCE4} ]; then export DEPCAT=$(pwd)/%{base_name}-%{version}-depcat.new.xml echo '<?xml version="1.0" standalone="yes"?>' > $DEPCAT echo '<depset>' >> $DEPCAT for p in $(find . -name project.xml); do pushd $(dirname $p) %{_bindir}/saxon project.xml %{SOURCE1} >> $DEPCAT popd done echo >> $DEPCAT echo '</depset>' >> $DEPCAT %{_bindir}/saxon $DEPCAT %{SOURCE2} > %{base_name}-%{version}-depmap.new.xml fi ant \ -Dcommons-pool.jar=$(build-classpath commons-pool) \ -Djdbc20ext.jar=$(build-classpath jdbc-stdext) \ -Djunit.jar=$(build-classpath junit) \ -Dxerces.jar=$(build-classpath xerces-j2) \ -Dxml-apis.jar=$(build-classpath xml-commons-jaxp-1.3-apis) \ -Dnaming-common.jar=$(build-classpath tomcat/catalina) \ -Dnaming-java.jar=$(build-classpath tomcat/catalina) \ -Dlogging.jar=$(build-classpath commons-logging) \ -Djava.io.tmpdir=. \ dist %install # jars install -d -m 755 %{buildroot}%{_javadir} install -m 644 dist/%{short_name}.jar %{buildroot}%{_javadir}/%{name}-%{version}.jar (cd %{buildroot}%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|jakarta-||g"`; done) (cd %{buildroot}%{_javadir} && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done) # pom install -d -m 755 %{buildroot}%{_mavenpomdir} install -pm 644 %{SOURCE7} \ %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom %add_maven_depmap # javadoc install -d -m 755 %{buildroot}%{_javadocdir}/%{name} cp -pr dist/docs/* %{buildroot}%{_javadocdir}/%{name} # quick hack clean up rm ../LICENSE # hibernate_jdbc_cache ghost symlink mkdir -p %{buildroot}%{_sysconfdir}/alternatives/ ln -sf %{_sysconfdir}/alternatives/hibernate_jdbc_cache.jar %{buildroot}%{_javadir}/hibernate_jdbc_cache.jar %post update-alternatives --install %{_javadir}/hibernate_jdbc_cache.jar \ hibernate_jdbc_cache %{_javadir}/%{name}.jar 60 %preun if [ $1 -eq 0 ] ; then update-alternatives --remove hibernate_jdbc_cache %{_javadir}/%{name}.jar fi %files %defattr(-,root,root) %doc LICENSE.txt %{_javadir}/%{name}.jar %{_javadir}/%{name}-%{version}.jar %{_javadir}/%{short_name}.jar %{_javadir}/%{short_name}-%{version}.jar %{_javadir}/hibernate_jdbc_cache.jar %ghost %{_sysconfdir}/alternatives/hibernate_jdbc_cache.jar %{_mavenpomdir}/* %{_mavendepmapfragdir}/* %files javadoc %defattr(-,root,root) %doc %{_javadocdir}/%{name} %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor