Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Leap:42.3:Staging:C
python-Sphinx
python-Sphinx.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File python-Sphinx.spec of Package python-Sphinx
# # spec file for package python-Sphinx # # Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # Name: python-Sphinx Version: 1.3.6 Release: 0 Url: http://sphinx-doc.org Summary: Python documentation generator License: BSD-2-Clause Group: Development/Languages/Python Source: http://pypi.python.org/packages/source/S/Sphinx/Sphinx-%{version}.tar.gz BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildRequires: python-devel BuildRequires: python-setuptools # Documentation requirements: BuildRequires: python-Babel BuildRequires: python-Jinja2 >= 2.3 BuildRequires: python-alabaster BuildRequires: python-docutils >= 0.7 BuildRequires: python-mock BuildRequires: python-six >= 1.4 BuildRequires: python-snowballstemmer BuildRequires: python-sphinx_rtd_theme # Testsuite requirements: BuildRequires: python-Pygments >= 2.1 BuildRequires: python-nose Requires(post): update-alternatives Requires(postun): update-alternatives Requires: python-Babel Requires: python-Jinja2 >= 2.3 Requires: python-Pygments >= 2.0 Requires: python-alabaster Requires: python-docutils >= 0.11 Requires: python-six >= 1.4 Requires: python-snowballstemmer Requires: python-sphinx_rtd_theme %if 0%{?suse_version} Recommends: python-rst2pdf %endif # workaround for suboptimal CentOS-7 project config #!BuildIgnore: texinfo Provides: python-sphinx = %{version} Obsoletes: python-sphinx < %{version} %if 0%{?suse_version} && 0%{?suse_version} <= 1110 %{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} %else BuildArch: noarch %endif %description Sphinx is a tool that makes it easy to create intelligent and beautiful documentation for Python projects (or other documents consisting of multiple reStructuredText sources), written by Georg Brandl. It was originally created for the new Python documentation, and has excellent facilities for Python project documentation, but C/C++ is supported as well, and more languages are planned. Sphinx uses reStructuredText as its markup language, and many of its strengths come from the power and straightforwardness of reStructuredText and its parsing and translating suite, the Docutils. %package doc Summary: Documentation for %{name} Group: Documentation/Other Requires: %{name} = %{version} %description doc Sphinx is a tool that makes it easy to create intelligent and beautiful documentation for Python projects (or other documents consisting of multiple reStructuredText sources), written by Georg Brandl. It was originally created for the new Python documentation, and has excellent facilities for Python project documentation, but C/C++ is supported as well, and more languages are planned. Sphinx uses reStructuredText as its markup language, and many of its strengths come from the power and straightforwardness of reStructuredText and its parsing and translating suite, the Docutils. %package latex Summary: Sphinx packages for LaTeX Group: Productivity/Publishing/TeX/Base Requires: texlive-latex Requires: texlive-metafont Requires: texlive-pdftex Requires: tex(8r.enc) Requires: tex(alltt.sty) Requires: tex(amsfonts.sty) Requires: tex(amsmath.sty) Requires: tex(amssymb.sty) Requires: tex(amsthm.sty) Requires: tex(array.sty) Requires: tex(article.cls) Requires: tex(atbegshi.sty) Requires: tex(babel.sty) Requires: tex(bm.sty) Requires: tex(capt-of.sty) Requires: tex(cmap.sty) Requires: tex(color.sty) Requires: tex(colortbl.sty) Requires: tex(dvipdfmx.def) Requires: tex(english.ldf) Requires: tex(eqparbox.sty) Requires: tex(fancybox.sty) Requires: tex(fancyhdr.sty) Requires: tex(fancyvrb.sty) Requires: tex(float.sty) Requires: tex(fncychap.sty) Requires: tex(fontenc.sty) Requires: tex(footnote.sty) Requires: tex(framed.sty) Requires: tex(graphics.sty) Requires: tex(graphicx.sty) Requires: tex(hypcap.sty) Requires: tex(hyperref.sty) Requires: tex(ifthen.sty) Requires: tex(inputenc.sty) Requires: tex(longtable.sty) Requires: tex(makeidx.sty) Requires: tex(multirow.sty) Requires: tex(needspace.sty) Requires: tex(newfloat.sty) Requires: tex(palatino.sty) Requires: tex(parskip.sty) Requires: tex(pcrr.tfm) Requires: tex(pdftex.def) Requires: tex(pdftex.map) Requires: tex(phvr.tfm) Requires: tex(pplr.tfm) Requires: tex(preview.sty) Requires: tex(ptmr.tfm) Requires: tex(pzcmi.tfm) Requires: tex(tabulary.sty) Requires: tex(textcomp.sty) Requires: tex(threeparttable.sty) Requires: tex(times.sty) Requires: tex(titlesec.sty) Requires: tex(upquote.sty) Requires: tex(utf8.def) Requires: tex(utf8x.def) Requires: tex(wrapfig.sty) %description latex Sphinx is a tool that makes it easy to create intelligent and beautiful documentation for Python projects (or other documents consisting of multiple reStructuredText sources), written by Georg Brandl. It was originally created for the new Python documentation, and has excellent facilities for Python project documentation, but C/C++ is supported as well, and more languages are planned. Sphinx uses reStructuredText as its markup language, and many of its strengths come from the power and straightforwardness of reStructuredText and its parsing and translating suite, the Docutils. This package contains the LaTeX components for %{name}. %prep %setup -q -n Sphinx-%{version} sed -i '/#\!/d' sphinx/pycode/pgen2/token.py # Fix non-excutable-script warning # Add Interpreter version suffix to entrypoints (and thus /usr/bin binaries) to # allow for update-alternatives later on: sed -i 's/\(sphinx-.*\) =/\1-%{py_ver} =/' setup.py # Fix wrong end-of-line encoding sed -i 's/\r$//' sphinx/themes/basic/static/jquery.js %build python setup.py build python setup.py build_sphinx && rm build/sphinx/html/.buildinfo python setup.py build_sphinx -b man %install python setup.py install --prefix=%{_prefix} --root=%{buildroot} mkdir -p %{buildroot}%{_sysconfdir}/alternatives for B in apidoc autogen build quickstart ; do touch %{buildroot}%{_sysconfdir}/alternatives/sphinx-$B ln -sf %{_sysconfdir}/alternatives/sphinx-$B %{buildroot}/%{_bindir}/sphinx-$B done install -d %{buildroot}%{_mandir}/man1/ for M in all apidoc build quickstart ; do install -m 644 build/sphinx/man/sphinx-$M.1 %{buildroot}%{_mandir}/man1/sphinx-$M-%{py_ver}.1 touch %{buildroot}%{_sysconfdir}/alternatives/sphinx-$M.1.gz ln -sf %{_sysconfdir}/alternatives/sphinx-$M.1.gz %{buildroot}%{_mandir}/man1/sphinx-$M.1.gz done %find_lang sphinx %check PYTHONPATH=$PWD make test %post update-alternatives \ --install %{_bindir}/sphinx-apidoc sphinx-apidoc %{_bindir}/sphinx-apidoc-%{py_ver} 20 \ --slave %{_bindir}/sphinx-build sphinx-build %{_bindir}/sphinx-build-%{py_ver} \ --slave %{_bindir}/sphinx-autogen sphinx-autogen %{_bindir}/sphinx-autogen-%{py_ver} \ --slave %{_bindir}/sphinx-quickstart sphinx-quickstart %{_bindir}/sphinx-quickstart-%{py_ver} \ --slave %{_mandir}/man1/sphinx-all.1.gz sphinx-all.1 %{_mandir}/man1/sphinx-all-%{py_ver}.1.gz \ --slave %{_mandir}/man1/sphinx-apidoc.1.gz sphinx-apidoc.1 %{_mandir}/man1/sphinx-apidoc-%{py_ver}.1.gz \ --slave %{_mandir}/man1/sphinx-build.1.gz sphinx-build.1 %{_mandir}/man1/sphinx-build-%{py_ver}.1.gz \ --slave %{_mandir}/man1/sphinx-quickstart.1.gz sphinx-quickstart.1 %{_mandir}/man1/sphinx-quickstart-%{py_ver}.1.gz \ %postun if [ $1 -eq 0 ] ; then update-alternatives --remove sphinx-apidoc %{_bindir}/sphinx-apidoc-%{py_ver} fi %files -f sphinx.lang %defattr(-,root,root,-) %doc AUTHORS CHANGES LICENSE README.rst %{_bindir}/sphinx-apidoc %{_bindir}/sphinx-apidoc-%{py_ver} %{_bindir}/sphinx-autogen %{_bindir}/sphinx-autogen-%{py_ver} %{_bindir}/sphinx-build %{_bindir}/sphinx-build-%{py_ver} %{_bindir}/sphinx-quickstart %{_bindir}/sphinx-quickstart-%{py_ver} %{_mandir}/man1/sphinx-all.1.gz %{_mandir}/man1/sphinx-all-%{py_ver}.1.gz %{_mandir}/man1/sphinx-apidoc.1.gz %{_mandir}/man1/sphinx-apidoc-%{py_ver}.1.gz %{_mandir}/man1/sphinx-build.1.gz %{_mandir}/man1/sphinx-build-%{py_ver}.1.gz %{_mandir}/man1/sphinx-quickstart.1.gz %{_mandir}/man1/sphinx-quickstart-%{py_ver}.1.gz %{python_sitelib}/sphinx/ %exclude %{python_sitelib}/sphinx/texinputs/ %{python_sitelib}/Sphinx-%{version}-py%{py_ver}.egg-info %ghost %{_sysconfdir}/alternatives/sphinx-apidoc %ghost %{_sysconfdir}/alternatives/sphinx-autogen %ghost %{_sysconfdir}/alternatives/sphinx-build %ghost %{_sysconfdir}/alternatives/sphinx-quickstart %ghost %{_sysconfdir}/alternatives/sphinx-all.1.gz %ghost %{_sysconfdir}/alternatives/sphinx-apidoc.1.gz %ghost %{_sysconfdir}/alternatives/sphinx-build.1.gz %ghost %{_sysconfdir}/alternatives/sphinx-quickstart.1.gz %files doc %defattr(-,root,root,-) %doc EXAMPLES build/sphinx/html # Requirements are not available on SLES %files latex %defattr(-,root,root,-) %doc AUTHORS LICENSE %{python_sitelib}/sphinx/texinputs/ %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor