Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
openSUSE:Maintenance:4606
nginx.openSUSE_Leap_42.1_Update
nginx.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File nginx.spec of Package nginx.openSUSE_Leap_42.1_Update
# # spec file for package nginx # # Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %define pkg_name nginx %define ngx_prefix %{_prefix} %define ngx_sbin_path %{_sbindir}/nginx %define ngx_conf_dir %{_sysconfdir}/nginx %define ngx_conf_path %{ngx_conf_dir}/nginx.conf %define ngx_log_dir %{_localstatedir}/log/nginx %define ngx_error_log %{ngx_log_dir}/error.log %define ngx_access_log %{ngx_log_dir}/access.log %define ngx_home %{_localstatedir}/lib/nginx %define ngx_tmp_http %{ngx_home}/tmp/ %define ngx_tmp_proxy %{ngx_home}/proxy/ %define ngx_tmp_fcgi %{ngx_home}/fastcgi/ %define ngx_tmp_scgi %{ngx_home}/scgi/ %define ngx_tmp_uwsgi %{ngx_home}/uwsgi/ %define ngx_user_group nginx %define with_cpp_test 0 %define with_google_perftools 0 %define with_fancyindex 1 %define fancyindex_version 0.3.5 %if 0%{?suse_version} <= 1310 %define ngx_pid_path %{_localstatedir}/run/nginx.pid %define ngx_lock_path %{_localstatedir}/run/nginx.lock %else %define ngx_pid_path /run/nginx.pid %define ngx_lock_path /run/nginx.lock %endif %if 0%{?suse_version} != 1315 %define with_libatomic 1 %endif %if 0%{?suse_version} >= 1220 # passenger is required by webyast %if 0%{?suse_version} > 1310 %define with_passenger 0 %else %define with_passenger 1 %endif %endif %if 0%{?suse_version} >= 1210 %define with_systemd 1 BuildRequires: systemd %{?systemd_requires} %endif Name: nginx Version: 1.8.1 Release: 0 Summary: A HTTP server and IMAP/POP3 proxy server License: BSD-2-Clause Group: Productivity/Networking/Web/Proxy Url: http://nginx.org/ Source: http://nginx.org/download/nginx-%{version}.tar.gz Source1: nginx.init Source2: nginx.logrotate Source3: nginx.service Source4: https://github.com/aperezdc/ngx-fancyindex/archive/v%{fancyindex_version}/ngx-fancyindex-%{fancyindex_version}.tar.gz Source100: nginx.rpmlintrc # PATCH-FIX-UPSTREAM nginx-0.4.0-no_Werror.patch Patch0: nginx-0.4.0-no_Werror.patch # PATCH-FIX-UPSTREAM nginx-0.6.38-html.patch Patch2: nginx-0.6.38-html.patch # PATCH-FIX-UPSTREAM nginx-1.2.4-perl_vendor_install.patch Patch3: nginx-1.2.4-perl_vendor_install.patch # PATCH-FIX-UPSTREAM fix /etc/nginx/nginx.conf to suit Linux env Patch4: nginx-1.6.1-default_config.patch # PATCH for fixing docs/html path Patch5: nginx-1.0.15_docs.patch # PATCH-FIX-UPSTREAM nginx-aio.patch fix support for Linux AIO Patch6: nginx-aio.patch BuildRequires: gcc-c++ BuildRequires: gd-devel BuildRequires: libxslt-devel BuildRequires: openssl-devel BuildRequires: pcre-devel BuildRequires: pkgconfig BuildRequires: zlib-devel %requires_eq perl Requires(pre): %fillup_prereq Requires(pre): %insserv_prereq Requires(pre): pwdutils Recommends: logrotate Conflicts: otherproviders(nginx) Provides: http_daemon Provides: httpd BuildRoot: %{_tmppath}/%{name}-%{version}-build %if 0%{?suse_version} == 1310 Patch7: nginx-1.4.2-passenger-4.0.18.patch Patch8: nginx-1.8.0-passenger-4.0.18.patch %endif %if 0%{?suse_version} <= 1310 BuildRequires: GeoIP-devel %else BuildRequires: libGeoIP-devel %endif %if 0%{?with_google_perftools} BuildRequires: google-perftools-devel %endif %if 0%{?with_libatomic} BuildRequires: libatomic-ops-devel %endif %if 0%{?with_passenger} BuildRequires: curl-devel BuildRequires: ruby-devel BuildRequires: rubygem-passenger BuildRequires: rubygem-passenger-devel-static Recommends: packageand(rubygem-passenger:rubygem-passenger-nginx) %endif %description nginx [engine x] is a HTTP server and IMAP/POP3 proxy server written by Igor Sysoev. It has been running on many heavily loaded Russian sites for more than two years. %prep %if 0%{?with_fancyindex} %setup -q -n %{pkg_name}-%{version} -b4 %else %setup -q -n %{pkg_name}-%{version} %endif %patch0 %patch2 %patch3 %patch4 %patch5 %patch6 -p1 perl -pi -e 's|\r\n|\n|g' contrib/geo2nginx.pl %if 0%{?with_passenger} cp -a %{_libdir}/ruby/gems/%{rb_ver}/gems/passenger-* passenger %if 0%{?suse_version} < 1310 if [[ -f "passenger/ext/common/libpassenger_common.a" ]] || \ [[ -f "passenger/ext/common/libboost_oxt.a" ]]; then rm -r passenger/ext/common/libboost_oxt* passenger/ext/common/libpassenger_common* fi %endif %patch7 %patch8 %endif %if 0%{with_fancyindex} mkdir -p ngx-fancyindex-%{fancyindex_version} pushd ../ngx-fancyindex-%{fancyindex_version} cp -r template* LICENSE *.rst $RPM_BUILD_DIR/%{pkg_name}-%{version}/ngx-fancyindex-%{fancyindex_version}/ popd %endif %if 0%{?suse_version} > 1310 sed -i "s/\/var\/run/\/run/" %{_sourcedir}/nginx.init %endif %build ./configure \ --prefix=%{ngx_prefix}/ \ --sbin-path=%{ngx_sbin_path} \ --conf-path=%{ngx_conf_path} \ --error-log-path=%{ngx_error_log} \ --http-log-path=%{ngx_access_log} \ --pid-path=%{ngx_pid_path} \ --lock-path=%{ngx_lock_path} \ --http-client-body-temp-path=%{ngx_tmp_http} \ --http-proxy-temp-path=%{ngx_tmp_proxy} \ --http-fastcgi-temp-path=%{ngx_tmp_fcgi} \ --http-uwsgi-temp-path=%{ngx_tmp_uwsgi} \ --http-scgi-temp-path=%{ngx_tmp_scgi} \ --user=nginx --group=nginx \ --without-select_module \ --without-poll_module \ --with-file-aio \ --with-threads \ --with-ipv6 \ --with-http_ssl_module \ %if 0%{?suse_version} > 1220 --with-http_spdy_module \ %endif --with-http_realip_module \ --with-http_addition_module \ --with-http_xslt_module \ --with-http_image_filter_module \ --with-http_geoip_module \ --with-http_sub_module \ --with-http_dav_module \ --with-http_flv_module \ --with-http_mp4_module \ --with-http_gunzip_module \ --with-http_gzip_static_module \ --with-http_auth_request_module \ --with-http_random_index_module \ --with-http_secure_link_module \ --with-http_degradation_module \ --with-http_stub_status_module \ --with-http_perl_module \ --with-perl=%{_bindir}/perl \ --with-mail \ --with-mail_ssl_module \ --with-pcre \ %if 0%{?with_libatomic} --with-libatomic \ %endif %if 0%{?with_passenger} --add-module=passenger/ext/nginx \ %endif %if 0%{?with_google_perftools} --with-google_perftools_module \ %endif %if 0%{?with_cpp_test} --with-cpp_test_module \ %endif %if 0%{with_fancyindex} --add-module=../ngx-fancyindex-%{fancyindex_version} \ %endif --with-md5=%{_prefix} \ --with-sha1=%{_prefix} \ %if 0%{?suse_version} > 1220 --with-cc-opt="%{optflags} -fPIE -D_GNU_SOURCE -std=gnu99 -fstack-protector" \ --with-ld-opt="-Wl,-z,relro,-z,now -pie" %else --with-cc-opt="%{optflags}" %endif make %{?_smp_mflags} %install make DESTDIR=%{buildroot} install %{?_smp_mflags} %perl_process_packlist install -d -m 0750 %{buildroot}%{ngx_home}/{,tmp,proxy,fastcgi,scgi,uwsgi} install -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{pkg_name} %if 0%{?with_systemd} install -D -m 0644 %{SOURCE3} %{buildroot}%{_unitdir}/nginx.service ln -s -f %{_sbindir}/service %{buildroot}%{_sbindir}/rcnginx %else install -D -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/init.d/%{pkg_name} ln -s -f %{_sysconfdir}/init.d/%{pkg_name} %{buildroot}%{_sbindir}/rc%{pkg_name} %endif rm %{buildroot}/srv/www/htdocs/index.html %post %if 0%{?with_systemd} %service_add_post nginx.service %else %fillup_and_insserv %{pkg_name} %endif %preun %if 0%{?with_systemd} %service_del_preun nginx.service %else %stop_on_removal %{pkg_name} %endif %postun %if 0%{?with_systemd} %service_del_postun nginx.service %else %restart_on_update %{pkg_name} %insserv_cleanup %endif %pre %{_sbindir}/groupadd -r %{ngx_user_group} &>/dev/null ||: %{_sbindir}/useradd -g %{ngx_user_group} -s /bin/false -r -c "user for %{ngx_user_group}" -d %{ngx_home} %{ngx_user_group} &>/dev/null ||: %if 0%{?with_systemd} %service_add_pre nginx.service %endif %files %defattr(-,root,root) %dir %{ngx_conf_dir}/ %config(noreplace) %{ngx_conf_dir}/koi-utf %config(noreplace) %{ngx_conf_dir}/koi-win %config(noreplace) %{ngx_conf_dir}/fastcgi_params %config %{ngx_conf_dir}/fastcgi_params.default %config(noreplace) %{ngx_conf_dir}/mime.types %config %{ngx_conf_dir}/mime.types.default %config(noreplace) %{ngx_conf_dir}/nginx.conf %config %{ngx_conf_dir}/nginx.conf.default %config(noreplace) %{ngx_conf_dir}/fastcgi.conf %config %{ngx_conf_dir}/fastcgi.conf.default %config(noreplace) %{ngx_conf_dir}/win-utf %config(noreplace) %{ngx_conf_dir}/scgi_params %config %{ngx_conf_dir}/scgi_params.default %config(noreplace) %{ngx_conf_dir}/uwsgi_params %config %{ngx_conf_dir}/uwsgi_params.default %{perl_vendorarch}/auto/nginx/ %{perl_vendorarch}/nginx.pm %{ngx_sbin_path} %{_mandir}/man3/nginx.3pm* /srv/www/htdocs/50x.html %if 0%{?suse_version} && 0%{?suse_version} < 1140 %{_localstatedir}/adm/perl-modules/%{name} %endif %{_sbindir}/rc%{pkg_name} %config(noreplace) %{_sysconfdir}/logrotate.d/%{pkg_name} %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{_localstatedir}/log/nginx/ %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{ngx_home}/ %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{ngx_tmp_http} %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{ngx_tmp_proxy} %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{ngx_tmp_fcgi} %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{ngx_tmp_scgi} %dir %attr(750,%{ngx_user_group},%{ngx_user_group}) %{ngx_tmp_uwsgi} %doc CHANGES* %doc conf/ contrib/ %if 0%{with_fancyindex} %doc ngx-fancyindex-%{fancyindex_version}/ %endif %if 0%{?with_systemd} %{_unitdir}/nginx.service %else %{_sysconfdir}/init.d/%{pkg_name} %endif %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor