Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
windows:mingw:win32
mingw32-oce
mingw32-oce.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File mingw32-oce.spec of Package mingw32-oce
# # spec file for package mingw32-oce # # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # # Whether clang should be used instead of gcc %bcond_with scanbuild %if %{with scanbuild} %bcond_without clang %else %bcond_with clang %endif # Whether DRAWEXE should be built %bcond_with build_draw %define _with_java 0 # disable vtk atm, oce code needs some older version %if 0%{?suse_version} > 91310 %bcond_without build_vtk %else %bcond_with build_vtk %endif # Define openCASCADE version %define ocversion 6.9.1 %define _name oce Name: mingw32-%{_name} Version: 0.18.3 Release: 0 Summary: OpenCASCADE Community Edition License: LGPL-2.1 WITH OCCT-exception-1.0 Group: Productivity/Graphics/CAD Url: https://github.com/tpaviot/oce Source0: oce-%{version}.tar.xz BuildRequires: mingw32-cross-cmake BuildRequires: mingw32-filesystem %if %{with clang} BuildRequires: mingw32-libstdc++-devel BuildRequires: mingw32-llvm-clang %else BuildRequires: mingw32-cross-gcc-c++ %endif BuildRequires: mingw32-cross-pkg-config BuildRequires: mingw32-freetype-devel BuildRequires: mingw32-freeglut-devel BuildRequires: mingw32-gl2ps-devel BuildRequires: mingw32-python %if %{with build_draw} BuildRequires: mingw32-tcl-devel BuildRequires: mingw32-tk-devel %endif BuildRequires: xz %if %{with build_vtk} BuildRequires: mingw32-vtk-devel %ifarch x86_64 %else %if 0%{?_with_java} %if 0%{?suse_version} > 1310 BuildRequires: -libjawt.so %else BuildRequires: -libjawt.so() %endif BuildRequires: -libjawt.so(SUNWprivate_1.1) %endif %endif BuildRequires: mingw32-java-devel %endif Provides: mingw32-OCE = %{version} Provides: mingw32-OpenCASCADE = %{ocversion} Obsoletes: mingw32-OCE < %{version} Obsoletes: mingw32-OpenCASCADE < %{ocversion} Conflicts: mingw32-otherproviders(OpenCASCADE) %_mingw32_package_header_debug BuildArch: noarch %description OpenCASCADE is a suite for 3D surface and solid modeling, visualization, data exchange and rapid application development. It is a platform for development of numerical simulation software including CAD/CAM/CAE, AEC and GIS, as well as PDM applications. %package vtk Summary: VTK libraries Group: System/Libraries %description vtk This package includes OpenCASCADE VTK libraries. %package DRAWEXE Summary: Scripting interface to the OpenCASCADE libraries Group: Productivity/Graphics/Visualization/Other %description DRAWEXE This program provides a kind of scripting interface to the OpenCASCADE libraries. You can perform a simple test by starting it and entering at the command line: "pload ALL" then "source /usr/share/oce/src/DrawResources/VisualizationDemo.tcl". %package devel Summary: Development files for openCASCADE Group: Development/Libraries/C and C++ Requires: %{name} = %{version} %if %{with build_vtk} Requires: %{name}-vtk = %{version} %endif Provides: mingw32-OCE-devel = %{version} Provides: mingw32-OpenCASCADE-devel = %{ocversion} Obsoletes: mingw32-OCE-devel < %{version} Obsoletes: mingw32-OpenCASCADE-devel < %{ocversion} Conflicts: mingw32-otherproviders(OpenCASCADE-devel) %description devel This package contains the files needed for development with OpenCASCADE. %_mingw32_debug_package %prep %setup -q -n %{_name}-%{version} %build CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \ CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \ %if %{with clang} %if %{with scanbuild} CC=/usr/share/clang/scan-build/ccc-analyzer CXX=/usr/share/clang/scan-build/c++-analyzer CCC_CXX=clang++ \ %else CC=clang CXX=clang++ \ %endif %endif %_mingw32_cmake \ -DOCE_USE_BUNDLE=OFF \ -DOCE_USE_PCH=OFF \ -DOCE_BUILD_SHARED_LIB=ON \ -DOCE_DISABLE_X11=OFF \ -DOCE_MODEL=ON \ -DOCE_OCAF=ON \ -DOCE_DATAEXCHANGE=ON \ %if %{with build_vtk} -DOCE_WITH_VTK=ON \ %else -DOCE_WITH_VTK=OFF \ %endif %if %{with build_draw} -DOCE_DRAW=ON \ %else -DOCE_DRAW=OFF \ %endif -DOCE_VISUALISATION=ON -DOCE_DISABLE_TKSERVICE_FONT=OFF \ -DOCE_WITH_GL2PS=ON \ -DOCE_WITH_FREEIMAGE=OFF \ -DOCE_EXTRA_WARNINGS=OFF \ -DOCE_TESTING=OFF \ -DOCE_ADD_HEADERS=OFF \ -DOCE_RPATH_FILTER_SYSTEM_PATHS=ON \ -DOCE_ENABLE_DEB_FLAG=ON \ -DOCE_COVERAGE=OFF \ -DOCE_MULTITHREAD_LIBRARY=OPENMP -DOCE_TBB_MALLOC_SUPPORT=OFF \ -DOCE_INSTALL_PREFIX=%_mingw32_prefix \ -DOCE_INSTALL_BIN_DIR=%_mingw32_bindir \ -DOCE_INSTALL_LIB_DIR=%_mingw32_libdir \ -DOCE_INSTALL_PACKAGE_LIB_DIR=%_mingw32_libdir \ -DOCE_INSTALL_INCLUDE_DIR=%_mingw32_includedir/oce \ -DOCE_INSTALL_DATA_DIR=%_mingw32_datadir/oce \ -DOCE_INSTALL_CMAKE_DATA_DIR=%_mingw32_datadir/oce \ %if %{with scanbuild} /usr/share/clang/scan-build/scan-build --use-analyzer %_bindir/clang -analyze-headers \ %endif %_mingw32_cmake_build %install %_mingw32_cmake_install rm %{buildroot}%{_mingw32_libdir}/env.bat rm %{buildroot}%{_mingw32_libdir}/msvc.bat # TODO do not let cmake install them rm %{buildroot}%{_mingw32_libdir}/libfreetype.dll.a # this file is not present on openSUSE_Leap_42.3 if test -f %{buildroot}%{_mingw32_bindir}/libgl2ps.dll; then rm %{buildroot}%{_mingw32_bindir}/libgl2ps.dll fi %files %defattr(-,root,root,-) %_mingw32_bindir/libFW*.dll %_mingw32_bindir/libPT*.dll %_mingw32_bindir/libTK*.dll %if %{with build_vtk} %exclude %_mingw32_bindir/*Vtk*.dll %endif %_mingw32_datadir/oce %exclude %_mingw32_datadir/oce/*.cmake %if %{with build_draw} %exclude %_mingw32_datadir/oce/src/DrawResources %files DRAWEXE %defattr(-,root,root,-) %_mingw32_bindir/DRAWEXE.exe %_mingw32_datadir/oce/src/DrawResources %endif %if %{with build_vtk} %files vtk %defattr(-,root,root,-) %_mingw32_bindir/*Vtk*.dll %endif %files devel %defattr(-,root,root,-) %doc NEWS.md %_mingw32_datadir/oce/*.cmake %_mingw32_includedir/oce %_mingw32_libdir/*.dll.a %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor