Sign Up
Log In
Log In
or
Sign Up
Places
All Projects
Status Monitor
Collapse sidebar
windows:mingw:win64
mingw64-kconfig
mingw64-kconfig.spec
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File mingw64-kconfig.spec of Package mingw64-kconfig
# # spec file for package mingw64-kconfig # # Copyright (c) 2019 SUSE LLC # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via https://bugs.opensuse.org/ # %define kconf_update 0 %define sonum 5 %define _tar_path 5.103 # Full KF5 version (e.g. 5.33.0) %{!?_mingw64_kf5_version: %global _mingw64_kf5_version %{version}} # Last major and minor KF5 version (e.g. 5.33) %{!?_mingw64_kf5_bugfix_version: %define _mingw64_kf5_bugfix_version %(echo %{_mingw64_kf5_version} | awk -F. '{print $1"."$2}')} %bcond_without lang %define _name kconfig Name: mingw64-%{_name} Version: 5.103.0 Release: 0 Summary: Advanced configuration system License: LGPL-2.1-or-later AND GPL-2.0-or-later Group: System/GUI/KDE URL: https://www.kde.org Source: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz %if %{with lang} Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz.sig Source2: frameworks.keyring %endif # PATCH-FEATURE-OPENSUSE Patch0: 0001-Translate-desktop-entries-using-gettext.patch # PATCH-FIX-UPSTREAM Patch2: 0002-Add-cross-compile-support-for-kconfig_compiler-and-k.patch Patch3: 0003-Add-5-postfix-to-target-kconf_update-to-avoid-name-c.patch Patch4: 0004-Use-5-suffix-for-kconfig_compiler-to-be-in-sync-with.patch Patch5: 0005-Do-not-apply-linux-only-related-access-right-check-f.patch Patch6: kconfig-5.103.0-build-fix.patch BuildRequires: cmake(Qt5Core) BuildRequires: cmake(Qt5DBus) BuildRequires: cmake(Qt5Gui) BuildRequires: cmake(Qt5LinguistTools) BuildRequires: cmake(Qt5Qml) BuildRequires: cmake(Qt5Xml) BuildRequires: mingw64-cross-cmake BuildRequires: mingw64-cross-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version} BuildRequires: mingw64-cross-gcc-c++ BuildRequires: mingw64-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version} BuildRequires: mingw64-kf5-filesystem BuildRequires: mingw64(cmake:Qt5Core) >= 5.11.0 BuildRequires: mingw64(cmake:Qt5DBus) >= 5.11.0 BuildRequires: mingw64(cmake:Qt5Gui) >= 5.11.0 BuildRequires: mingw64(cmake:Qt5Qml) >= 5.11.0 BuildRequires: mingw64(cmake:Qt5Xml) >= 5.11.0 BuildRequires: mingw64(lib:intl) %_mingw64_package_header_debug # TODO Fix me #BuildArch: noarch %description KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. KConfigCore provides access to the configuration files themselves. It features: - centralized definition: define your configuration in an XML file and use `kconfig_compiler` to generate classes to read and write configuration entries. - lock-down (kiosk) support. KConfigGui provides a way to hook widgets to the configuration so that they are automatically initialized from the configuration and automatically propagate their changes to their respective configuration files. %package -n mingw64-libKF5ConfigCore%{sonum} Summary: System for configuration files Group: System/GUI/KDE %requires_ge mingw64-libQt5Core5 Recommends: mingw64-kconf_update5 = %{version} %if %{with lang} Recommends: mingw64-libKF5ConfigCore%{sonum}-lang = %{version} %endif BuildArch: noarch %description -n mingw64-libKF5ConfigCore%{sonum} KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. KConfigCore provides access to the configuration files themselves. %package -n mingw64-libKF5ConfigGui%{sonum} Summary: Widgets hooks for configuration entities Group: System/GUI/KDE %requires_ge mingw64-libKF5ConfigCore5 %requires_ge mingw64-libQt5Core5 %requires_ge mingw64-libQt5Gui5 %requires_ge mingw64-libQt5Xml5 BuildArch: noarch %description -n mingw64-libKF5ConfigGui%{sonum} KConfigGui provides a way to hook widgets to the configuration so that they are automatically initialized from the configuration and automatically propagate their changes to their respective configuration files. %package -n mingw64-kconf_update5 Summary: Configuration file access Group: System/GUI/KDE Requires: mingw64-libKF5ConfigCore%{sonum} = %{version} BuildArch: noarch %description -n mingw64-kconf_update5 KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. This package contains the kconf_update tool. %package -n mingw64-cross-kconfig-tools Summary: Utilities for KConfig Group: Development/Libraries/KDE %description -n mingw64-cross-kconfig-tools Utilities for KConfig, which provides an advanced configuration system. %package devel Summary: KConfig Development files Group: Development/Libraries/KDE Requires: mingw64-cross-kconfig-tools Requires: mingw64-extra-cmake-modules Requires: mingw64-kconf_update5 = %{version} Requires: mingw64-libKF5ConfigCore%{sonum} = %{version} Requires: mingw64-libKF5ConfigGui%{sonum} = %{version} Requires: mingw64(cmake:Qt5Xml) >= 5.11.0 BuildArch: noarch %description devel KConfig provides an advanced configuration system. It is made of two parts: KConfigCore and KConfigGui. KConfigCore provides access to the configuration files themselves. It features: - centralized definition: define your configuration in an XML file and use `kconfig_compiler` to generate classes to read and write configuration entries. - lock-down (kiosk) support. KConfigGui provides a way to hook widgets to the configuration so that they are automatically initialized from the configuration and automatically propagate their changes to their respective configuration files. Development files. %lang_package -n mingw64-libKF5ConfigCore%{sonum} %_mingw64_debug_package %prep %autosetup -p1 -n %{_name}-%{version} %build cmake -B native-build -DCMAKE_INSTALL_PREFIX=/usr/%{_mingw64_target} cmake --build native-build -t kconfig_compiler %if %kconf_update cmake --build native-build -t kconf_update %endif OPTIONS="-DKCONFIG_COMPILER_EXECUTABLE=$PWD/bin/kconfig_compiler5 -DKCONF_UPDATE_EXECUTABLE=$PWD/bin/kconf_update5" %_mingw64_cmake_kf5 -d build -- -DKDEWIN_LIBRARIES=intl $OPTIONS %_mingw64_cmake_build %install cmake --build native-build/src/kconfig_compiler -t install DESTDIR=%{buildroot} %if %kconf_update # FIXME: unresolved reference to -lintl cmake --build native-build/src/kconf_update -t install DESTDIR=%{buildroot} cmake --build native-build/src/core -t install DESTDIR=%{buildroot} cmake --build native-build/src/gui -t install DESTDIR=%{buildroot} cmake --build native-build/src/qml -t install DESTDIR=%{buildroot} %endif mkdir -p %{buildroot}%{_prefix}/%{_mingw64_target}/bin mv %{buildroot}%{_prefix}/%{_mingw64_target}/lib64/libexec/kf5/* %{buildroot}%{_prefix}/%{_mingw64_target}/bin mkdir -p %{buildroot}%{_prefix}/bin ln -s ../%{_mingw64_target}/bin/kconfig_compiler5 %{buildroot}%{_prefix}/bin/%{_mingw64_target}-kconfig_compiler5 %if %kconf_update ln -s ../%{_mingw64_target}/bin/kconf_update5 %{buildroot}%{_prefix}/bin/%{_mingw64_target}-kconf_update5 %endif %_mingw64_kf5_makeinstall -C build %if %{with lang} %_mingw64_find_lang %{_name}5 --all-name --with-qt --without-mo %endif %if %{with lang} %files -n mingw64-libKF5ConfigCore%{sonum}-lang -f %{_name}5.lang %endif %files -n mingw64-libKF5ConfigCore%{sonum} %license LICENSES/* %doc README* %{_mingw64_kf5_bindir}/k*config5.exe %{_mingw64_kf5_bindir}/libKF5ConfigCore*.dll %{_mingw64_kf5_bindir}/libKF5ConfigQml.dll %{_mingw64_kf5_debugdir}/kconfig.categories %{_mingw64_kf5_debugdir}/*.renamecategories %files -n mingw64-libKF5ConfigGui%{sonum} %license LICENSES/* %doc README* %{_mingw64_kf5_bindir}/libKF5ConfigGui*.dll %files -n mingw64-kconf_update5 %license LICENSES/* %doc README* %dir %{_mingw64_kf5_libexecdir} %{_mingw64_kf5_libexecdir}/kconf_update5.exe %files -n mingw64-cross-kconfig-tools %{_prefix}/%{_mingw64_target}/bin/kconfig_compiler5 %{_prefix}/bin/%{_mingw64_target}-kconfig_compiler5 %if %kconf_update %{_prefix}/%{_mingw64_target}/bin/kconf_update5 %{_prefix}/bin/%{_mingw64_target}-kconf_update5 %endif %files devel %{_mingw64_kf5_libexecdir}/kconfig_compiler5.exe %{_mingw64_kf5_libdir}/libKF5ConfigCore.dll.a %{_mingw64_kf5_libdir}/libKF5ConfigGui.dll.a %{_mingw64_kf5_libdir}/libKF5ConfigQml.dll.a %{_mingw64_kf5_libdir}/cmake/KF5Config/ %{_mingw64_kf5_includedir}/ %{_mingw64_kf5_mkspecsdir}/qt_KConfigCore.pri %{_mingw64_kf5_mkspecsdir}/qt_KConfigGui.pri %changelog
Locations
Projects
Search
Status Monitor
Help
OpenBuildService.org
Documentation
API Documentation
Code of Conduct
Contact
Support
@OBShq
Terms
openSUSE Build Service is sponsored by
The Open Build Service is an
openSUSE project
.
Sign Up
Log In
Places
Places
All Projects
Status Monitor